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About this book

Installing IBM Network Station Manager V2R1 on Windows 2000 (SA23-2811) provides
planning, installation, configuration, and migration information for the IBM
Network Station Manager Version 2 Release 1 licensed program (5648-C07),
hereafter referred to in this publication as IBM Network Station Manager, on a
Windows 2000 server.

IBM Network Station Manager V2R1 is also known as IBM NetVista Thin Client
Manager V2R1. This software enables a systems administrator to manage and
administer Network Stations and NetVista thin clients. For the purposes of
consistency, this publication uses the term thin clients to refer to both Network
Stations and NetVista thin clients.

Who should read this book
The person or group who installs and administers IBM Network Station Manager
on a Windows 2000 server should read this publication.

Information on the Internet
v You can find additional information about your thin client at the following URL:

http://www.pc.ibm.com/support

1. Click NetVista.
2. Click NetVista thin client.

v You can obtain the latest version of this information at the following URL:

http://www.ibm.com/nc/pubs

This is the same URL that is printed on the cover of this document.

Related information
The following information is available for IBM Network Station Manager:

Information name Information description

Installing IBM Network Station
Manager for AS/400, SC41-0684

Describes the installation and simple configuration of an
AS/400 Network Station environment. It is shipped with
the IBM Network Station Manager licensed program.
Updates to this information are at
http://www.ibm.com/nc/pubs.

Installing IBM Network Station
Manager for RS/6000, SC41-0685

Describes the installation and simple configuration of an
RS/6000 Network Station environment. It is shipped
with the IBM Network Station Manager licensed
program. Updates to this information are at
http://www.ibm.com/nc/pubs.
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Information name Information description

Installing IBM Network Station
Manager on Windows NT, SC41-0688

Describes the installation and simple configuration of a
Windows NT Network Station environment. It is shipped
with the IBM Network Station Manager licensed
program. Updates to this information are at
http://www.ibm.com/nc/pubs.

Installing IBM Network Station
Manager on Windows 2000, SA23-2811

Describes the installation and simple configuration of a
Windows 2000 thin client environment. Updates to this
information are at http://www.ibm.com/nc/pubs.

Using IBM Network Station Manager,
SC41-0690

Describes the basic tasks for managing user desktops
through the IBM Network Station Manager program. It
is shipped with the IBM Network Station Manager
licensed program. Updates to this information are at
http://www.ibm.com/nc/pubs.

IBM Network Station Advanced
Information

Describes tasks and information beyond a basic
installation and configuration of your Network Station
environment. This information is only available at
http://www.ibm.com/nc/pubs.

IBM Network Station Manager help text Describes the basic how-to tasks for configuring your
Network Station desktop appearance. This information is
availble by clicking the help icon in the IBM Network
Station Manager program.

Desktop help Describes how to use and operate the Network Station
desktop. This information is available by clicking the
help icon in the lower right of the Network Station
desktop.

How to send your comments
Your feedback is important in helping to provide the most accurate and
high-quality information. If you have any comments about this book or any other
documentation, fill out the readers’ comment form at the back of this book.
v If you prefer to send comments by mail, use the readers’ comment form with the

address that is printed on the back. If you are mailing a readers’ comment form
from a country other than the United States, you can give the form to the local
IBM branch office or IBM representative for postage-paid mailing.

v If you prefer to send comments by FAX, use either of the following numbers:
– United States and Canada: 1-800-937-3430
– Other countries: 1-507-253-5192

v If you prefer to send comments electronically, use this network ID:
– IBMMAIL, to IBMMAIL(USIB56RZ)
– RCHCLERK@us.ibm.com

Be sure to include the following:
v The name of the book.
v The publication number of the book.
v The page number or topic to which your comment applies.
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IBM Network Station overview
The IBM Network Station Manager licensed program code is made up of several
programs that are installed on a server. One of these programs is Network Station
Manager. Network Station Manager allows you to set and change configurations
for IBM thin clients (also referred to as Network Stations or NetVista thin clients)
and thin client users through a Web browser. See the Using IBM Network Station
Manager book for more information about the IBM Network Station Manager
program.

Since the Network Station does not contain a hard drive, the Network Station
accesses a server to download the client operating system, client programs, and
data. After the Network Station loads the client operating system, the Network
Station displays a graphical user interface (GUI). The GUI can provide the user
access to the following resources:
v 5250 emulator application
v 3270 emulator application
v Telnet application
v Web browser application (Netscape Communicator)
v Java applets or applications
v Windows-based applications
v Local and remote printers

The Network Station communicates using Transmission Control Protocol/Internet
Protocol (TCP/IP) over a token-ring connection or Ethernet connection to a server.
Each Network Station runs the client operating system and communicates to a
server that runs Network Station Manager and other application programs.

Figure 1 on page 2 shows what happens when you power on a Network Station.
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«1¬ A non-volatile random access memory (NVRAM) resident program starts. The
Network Station automatically runs a series of power-on self tests (POST).

«2¬ The Network Station contacts a DHCP boot server. The Network Station
exchanges its media access control (MAC) address for the IP address that is
provided by the server. The boot server also provides the address or path of the
base code server. The Network Station may alternatively retrieve this information
from values that are stored in its NVRAM.

«3¬ The Network Station downloads the base code from the base code server using
trivial file transfer protocol (TFTP) or network file system (NFS).

«4¬ The Network Station downloads the workstation-based configuration
information from the workstation configuration server.

«5¬ The Network Station presents a logon screen. When the user enters a user id
and password, the authentication server verifies the user’s identification.

«6¬ The user’s configuration server downloads and initiates the personalized
environment preferences of the user.

«7¬ The Network Station displays the personalized desktop of the user. The user is
able to access application programs that reside on the application server (or host
computer).

Each Network Station contains a simple network management protocol (SNMP)
agent as part of its operating system. An SNMP manager at a central location can
communicate and exchange information with the agent on a Network Station. You

Figure 1. Thin client power-on sequence
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can use this information to manage your network environment. SNMP is an
industry-standard protocol for network management. See IBM Network Station
Advanced Information for more information about SNMP. You can find this
document at http://www.ibm.com/nc/pubs.

Each Network Station can display the IBM Network Station Setup Utility or IBM
Network Station NS Boot utility. The Setup Utility or NS Boot utility allows you to
View or Set (change) configuration settings on a particular Network Station. For
example, you can view the MAC address or you can set the monitor resolution of
the Network Station. See Using IBM Network Station Manager for more information
about the Setup Utility and NS Boot Utility.

TCP/IP overview
In order for the Network Station to communicate with your servers, you need a
TCP/IP network. If you understand your TCP/IP network, installing and
configuring your Network Station and Network Station Manager is much easier. To
help understand your network, draw a diagram of your network.

Refer to the network examples in this section to help you understand how to
configure your network. Choose the network example that most closely resembles
your network diagram. Refer to these examples as you configure and install
Network Stations on your network.

Note: You do not need to be an expert in order to set up a TCP/IP network.
However, you should have an understanding of basic TCP/IP. A detailed
introduction to TCP/IP is beyond the scope of this book. If you need to
improve your understanding of TCP/IP, you can contact your IBM sales
representative, who has information about classes in your area. You may
also want to refer to the redbook, TCP/IP Tutorial and Technical Overview,
GG24-3376.

LAN network examples

LAN network example 1
Figure 2 on page 4 shows an example of a network diagram in which two Network
Stations are connected over a simple local area network (LAN).
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LAN network example 2
Figure 3 shows an example of a network diagram in which two Network Stations
are connected to the server over a local LAN. Two more Network Stations connect
to the server through a router over a remote LAN.

LAN network example 3
In Figure 4 on page 5, additional Network Stations connect to the server by using
Ethernet connections and token-ring connections. Two token-ring LANs connect
via a router. A Domain Name Server (DNS) also connects to the network.

Figure 2. Two Network Stations connected to the server over a simple LAN

Figure 3. Two Network Stations connected to the server over a local LAN and two Network
Stations connected to the server through a router over a remote LAN
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MAC addresses
Every Network Station comes with a unique identifying number that can be used
to keep track of which IP address has been assigned to it. Media access control
(MAC) addresses of each Network Station are assigned by manufacturing and
hard-coded into the machine. The MAC address of a Network Station is on the
side panel of the small box in which the logic unit is packaged. If you no longer
have the box, see the Using IBM Network Station Manager book for instructions on
how to find the MAC address.

You can override the hard-coded MAC address with a customer-assigned MAC
address. See Using IBM Network Station Manager for instructions on how to
override the hard-coded MAC address.

IP addresses
Internet Protocol (IP) addresses are numbers that are assigned to devices on a
network (or on the Internet). IP addresses allow computers to communicate
through TCP/IP. IP addresses consist of four numbers (from 0 to 255) that are
separated by periods, for example 192.168.1.1. The numbers that are separated by
periods indicate the network to which a computer belongs and the specific location
of the host computer within that network.

IP addresses are not just for computers such as Network Stations, but also for
routers, servers, and even subnets and networks themselves. For example, the IP
address of a network might be 192.168.1.0. A router on that network might use the
IP address 192.168.1.1. A Network Station on the same network might have the
address 192.168.1.145.

Figure 4. Four Network Stations connected to a network using a router and a domain name
server
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Each Network Station must have a unique IP address. If you are using the DHCP
boot method, you must specify a range of IP addresses so that the server can
assign an address to each Network Station. For intranets (networks within your
own organization), you can assign your own addresses. However, if you want to
connect to the Internet, a central authority must officially assign the network
addresses and domain names. At the time of this writing, the authority is as
follows:
Network Solutions, Inc.
InterNIC Registration Services
505 Huntmar Park Drive
Herndon, VA 22070
1-703-742-4811
E-mail: hostmaster@internic.net
http://rs.internic.net

Boot methods
Since a Network Station has no disk from which to start, it must request
information either from its own non-volatile random access memory (NVRAM) or
from a server. The Network Station needs to find an IP address for itself. The IP
address allows the Network Station to communicate with other hosts. The
Network Station can use one of the following methods to request and receive this
information:
v Dynamic Host Control Protocol (DHCP)
v Non-Volatile Random Access Memory (NVRAM)

Note: If you use the DHCP boot method, you must configure all routers and
gateways in your network to send and receive DHCP packets. If you cannot
configure your routers to be DHCP relay agents, you could do either of the
following:
v Use a system that has the necessary configuration support to receive

limited DHCP broadcasts. Then forward those broadcasts to the
appropriate server.

v Use the NVRAM boot method for those Network Stations that are behind
a router that cannot forward DHCP broadcasts.

DHCP
Dynamic Host Configuration Protocol (DHCP) is a TCP/IP protocol. DHCP
provides a way for a server to automatically allocate IP addresses and
configuration information without forcing the administrator to record and track the
MAC addresses of the networked computers. DHCP is capable of assigning either
a permanent IP address or a temporary IP address for every host or Network
Station within a predetermined range of IP addresses. You can also use DHCP to
assign IP addresses either statically or dynamically.

In static IP address assignment, you define the MAC address of every Network
Station in the DHCP server configuration along with an IP address, which is
reserved for the Network Station with this MAC address. A Network Station,
identifying itself by its MAC address, sends a request to the DHCP server. The
server then returns the IP address that it has reserved for that client.

In dynamic IP address assignment, the server still identifies a Network Station by
its MAC address. However, instead of using a fixed IP address, the server allocates
any address out of the available pool. The server leases the address to the Network

6 Installing IBM Network Station Manager V2R1 on Windows 2000



Station for a specified period of time. The address returns to the pool either when
the client releases it or when the lease runs out.

DHCP can allow for unlisted clients. Any client, even one with an undefined MAC
address in the DHCP configuration, may request an IP address from the pool of
available addresses. The use of unlisted clients might be appropriate in an
environment in which it is not necessary or preferable to keep track of MAC
addresses.

DHCP servers can reuse IP addresses that are not currently being used.

Finally, DHCP provides a large set of configuration options that may include
user-defined options. These options are useful in configuring advanced network
environments. See IBM Network Station Advanced Information for a more in-depth
discussion of advanced network environments. You can find this document at
http://www.ibm.com/nc/pubs.

NVRAM
Non-Volatile Random-Access Memory (NVRAM) refers to local Network Station
memory. When you use the NVRAM boot method, you code the IP addresses of
the Network Station and its server into the memory of the individual Network
Station. The Network Station powers on and requests the download of the base
code file from the server.

The NVRAM boot method is most practical in small, stable networks. You may
also choose to use the NVRAM boot method for one of the following reasons:
v As a method to avoid routers that block DHCP broadcast requests. DHCP

broadcast requests for IP addresses can create unnecessary traffic on the
network. Many network routers are configured not to pass these broadcast
requests. Since NVRAM does not need to request its IP address (because it has
been entered in the NVRAM of the Network Station), it does not make
broadcasts.

v As an aid in finding and correcting problems with network connections.
v As an aid in finding and correcting problems with DHCP configurations.

This method may not work well for larger networks for the following reasons:
v You must enter setup data into each Network Station manually.
v DHCP can configure many more parameters that may not be easily configured

with this method.

For information about how to configure NVRAM in the Setup Utility or NS Boot
utility, see the Using IBM Network Station Manager book.

Boot file service
The Network Station uses either TFTP or NFS to receive the base code file from the
base code server. Trivial file transfer protocol (TFTP) is a simple protocol that is
used to transfer files. The network file system (NFS) makes files and directories
available to clients. NFS is generally more reliable than TFTP.

Understanding the IBM Network Station 7
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Java on the Network Station
Java is a programming language that is designed to bridge the gap between
different platforms. Java’s imperative, ″Write once, run anywhere,″ refers to its
portability and to the ability of a single Java program to run on different platforms.
To view Java applications, you need a bundle of Java-enabling programs called
Java Virtual Machine (JVM). Using JVM on diskless clients such as the Network
Station allows the user to access applications without using permanent disk space
either on the Network Station or on the server.

There are two kinds of Java programs:
v Applets — require a browser or applet viewer
v Applications — display directly

The first variety, applets, rely on a browser or applet viewer to provide windows
and graphical layout. In general, the browser does not “trust” applets because they
are downloaded across the Internet. In other words, the browser can restrict
applets from reading or writing to local files and from connecting to machines
other than those from which they are downloaded. These restrictions protect users
from virus-contaminated programs and provide a safe environment for examining
programs on the Internet.

See IBM Network Station Advanced Information for more information about Java. You
can find this document at at http://www.ibm.com/nc/pubs.

Windows applications on the Network Station
Network Stations can run Windows-based applications through the use of a
multi-user Windows server. There are several products that can provide a
multi-user Windows server:
v Citrix WinFrame is a multi-user Windows application server that is based on

Windows NT 3.51. Citrix WinFrame communicates to the Network Station by
using the independent computer architecture (ICA) protocol.

v NCD WinCenter is a multi-user Windows application product that requires
Citrix WinFrame or Microsoft Windows NT Server 4.0, Terminal Server Edition.
NCD WinCenter communicates to the Network Station by using the X11
protocol.

v Citrix MetaFrame is a multi-user Windows application product that is supported
by Microsoft Windows NT Server 4.0, Terminal Server Edition, and Microsoft
Windows 2000 Servers. Citrix MetaFrame communicates to the Network Station
by using the ICA protocol.

Network Stations that start from a V1R3 or V2R1 IBM Network Station Manager
licensed program server can communicate to a multi-user Windows server using
the X11 protocol or the ICA protocol.

For more information, see the following Web sites:
v WinFrame and MetaFrame - http://www.citrix.com
v WinCenter - http://www.ncd.com
v Windows NT Server 4.0, Terminal Server Edition - http://www.microsoft.com
v Windows 2000 Servers - http://www.microsoft.com
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Thin client memory requirements
Thin clients download each of their applications into memory. If you plan to run
multiple applications on your thin clients, verify that each thin client has adequate
memory to handle the projected applications. Subsequent releases of applications
may have increased memory requirements.

Follow these steps to verify that your thin clients have enough memory to run
their applications:
__ 1. Open your browser, and access the following URL:

http://www.pc.ibm.com/support

__ 2. Click NetVista, and then click NetVista thin client.
__ 3. In the Search box, type memory requirements.

Taking advantage of multiple server environments
You can install the IBM Network Station Manager licensed program on multiple
computer systems. For a more in-depth discussion of this topic, see the IBM
Network Station Advanced Information. You can find this document at
http://www.ibm.com/nc/pubs.

New features in Version 2 Release 1
IBM Network Station Manager Version 2 Release 1 (V2R1) introduces many new
features. These features include:

Client desktop
The client desktop has a new look and includes the following:
v 16-bit color support
v Scalable fonts
v Desktop help
v Kiosk mode

For more information, see the Using IBM Network Station Manager book.

Netscape Communicator 4.5
Netscape Comunicator 4.5 includes the Navigator browser, and Messenger
(e-mail and news). The browser is fully compatible with other Unix
versions of Netscape Navigator. Key features that are new in this version
include:
v Netscape JVM
v Runtime Plug-in for the Network Station, Java Edition
v PDF helper application
v Real Player helper application
v Audio player helper application
v Video player helper application

For more information, see the Using IBM Network Station Manager book.

Windows application support
Enhanced ICA support. For more information, see the Using IBM Network
Station Manager book.
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VT emulator
Enhanced VT emulator. For more information, see the Using IBM Network
Station Manager book.

Productivity applications

v File manager
v Text editor
v Calendar
v Calculator
v Paint

For more information, see the Using IBM Network Station Manager book.

Java environments
The IBM Network Station Manager licensed program provides two JVMs:
v Netscape 4.5 JVM
v IBM JVM (JDK 1.1.8)

Flash memory support
Flash memory support provides the ability to boot locally from a flash
memory card and a flash memory management utility. For more
information, see IBM Network Station Advanced Information. You can find
this document at http://www.ibm.com/nc/pubs.

Hardware support

Table 1 shows the IBM Network Station hardware by machine type, model
number, and series. It also shows which version and release of the IBM
Network Station Manager licensed program is required to support a
particular hardware machine type and model.

For example:
v Machine type 8364 model Exx requires V2R1
v Machine type 8362 model A22 is supported by either V2R1 or V1R3

Table 1. IBM Network Station hardware types, models, and series

Compatible
release

Machine type - model

Series 100 Series 300 Series 1000 Series 2200 Series 2800

V2R1 only 8363-Exx
8363-Txx

8364-Exx
8364-Txx

both V2R1
and V1R3

8361-110
8361-210

8362-A22
8362-A23
8362-A52
8362-A53

V1R3 only 8361-100
8361-200

8361-341*

* Twinaxial model supported only on AS/400 servers.

Coexistence with V1R3
Windows NT, AS/400, and RS/6000 server environments can support
V2R1 coexistence with V1R3. You can install V2R1 on a system1 that runs
V1R3. The V2R1 installation does not affect the V1R3 environment. Both
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V2R1 and V1R3 can coexist and operate on the same server. The ability to
have V2R1 and V1R3 coexist on the same server allows support for all thin
client hardware models.

1. Coexistence does not apply to Windows 2000 thin client environments. V1R3 is not supported on Windows 2000 servers.
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About this section
This section provides information on planning and running a typical installation
of IBM Network Station Manager V2R1 on a Windows 2000 server.

Planning the installation
Plan the installation of IBM Network Station Manager by identifying an applicable
upgrade path from the following table. To minimize errors and reduce installation
time, you can follow the upgrade paths that are recommended by IBM. An asterisk
(*) marks a recommended upgrade path.

Current server
environment

Upgrade goals Upgrade paths

* Fresh installation

A single, newly installed
Windows 2000 server

Install IBM Network
Station Manager for the
first time on the same
Windows 2000 server

1. Read important release information. See “Important
information” on page 16.

2. Ensure that your Windows 2000 server meets the server
requirements. See “Server requirements” on page 16.

3. Verify that your Windows 2000 server runs the
prerequisite software. See “Prerequisite software” on
page 17.

4. Install IBM Network Station Manager V2R1. See
“Running the installation” on page 18.

Single-server: operating system upgrade

A single Windows NT®

server with IBM Network
Station Manager V2R1
installed

v Upgrade your Windows
NT server operating
system to Windows 2000
Server

v Maintain IBM Network
Station Manager V2R1
on the same server after
the operating system
upgrade

1. Upgrade your server operating system to Windows 2000
Server. Refer to Microsoft® documentation for more
information.

a. Read important release information. See “Important
information” on page 16.

b. Ensure that your Windows 2000 server meets the
server requirements. See “Server requirements” on
page 16.

c. Verify that your Windows 2000 server runs the
prerequisite software. See “Prerequisite software” on
page 17.

2. Apply the latest Service Update for IBM Network
Station Manager V2R1.

* Dual-server: operating system upgrade
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Current server
environment

Upgrade goals Upgrade paths

v A single Windows NT
server with IBM
Network Station
Manager V2R1

v A single Windows 2000
server on which you
plan to maintain IBM
Network Station
Manager V2R1

v Move IBM Network
Station Manager V2R1
from the Windows NT
server to the Windows
2000 server

1. Read important release information. See “Important
information” on page 16.

2. Ensure that your Windows 2000 server meets the server
requirements. See “Server requirements” on page 16.

3. Verify that your Windows 2000 server runs the
prerequisite software. See “Prerequisite software” on
page 17.

4. From the Windows 2000 server, map a connection to the
Windows NT server, and copy the entire
[drive:]\NetworkStationV2\userbase directory from the
Windows NT server to the Windows 2000 server.
Note: When you install IBM Network Station Manager,
the setup program resets the persmissions on the
\userbase directory to work correctly on the Windows
2000 server.

5. Install IBM Network Station Manager V2R1 on the
Windows 2000 server. See “Running the installation” on
page 18

6. Uninstall IBM Network Station Manager V2R1 on the
Windows NT server through the Add/Remove
Programs utility in the Control Panel. See “Uninstalling
IBM Network Station Manager” on page 22.

Single-server: operating system upgrade and IBM Network Station Manager migration
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Current server
environment

Upgrade goals Upgrade paths

A single Windows NT
server with IBM Network
Station Manager V1R3

Attention: If you have
thin clients that you need
to support with V1R3,
ensure that you maintain
V1R3 on a Windows NT
server.

v Upgrade your Windows
NT server operating
system to Windows 2000
Server

v Upgrade IBM Network
Station Manager from
V1R3 to V2R1 on the
same server after the
operating system
upgrade

1. Apply the latest V1R3 Service Update to your V1R3
software on the Windows NT server. You can download
the latest V1R3 Service Update from
http://techsupport.services.ibm.com/nc.
Note: The latest V1R3 Service Update ensures that you
can successfully migrate from V1R3 to V2R1.

2. If you use IBM DHCP, disable or stop the IBM DHCP
server.

3. Uninstall the following software through the
Add/Remove Programs applet in the Windows NT
Control Panel:

v IBM Network Station Manager V1R3 (see
“Uninstalling IBM Network Station Manager” on
page 22).

v Lotus® Domino™ Go Webserver

4. Upgrade your server operating system to Windows 2000
Server. Refer to Microsoft documentation for more
information.

a. Read important release information. See “Important
information” on page 16.

b. Ensure that your Windows 2000 server meets the
server requirements. See “Server requirements” on
page 16.

c. Verify that your Windows 2000 server runs the
prerequisite software. See “Prerequisite software” on
page 17.

5. Install IBM Network Station Manager V2R1. See
“Running the installation” on page 18.
Note: Migrate your V1R3 preference files to V2R1. See
“Migrating to your new IBM Network Station Manager
release” on page 39.

* Dual-server: operating system upgrade and IBM Network Station Manager migration

v A single Windows NT
server with IBM
Network Station
Manager V1R3

v A single Windows 2000
server on which you
plan to install IBM
Network Station
Manager V2R1

Attention: If you have
thin clients that you need
to support with V1R3,
ensure that you maintain
V1R3 on a Windows NT
server.

v Install IBM Network
Station Manager on the
Windows 2000 server

v Migrate V1R3 preference
files on the Windows
NT server to V2R1 on
the Windows 2000
server

1. Apply the latest V1R3 Service Update to your V1R3
software on the Windows NT server. You can download
the latest V1R3 Service Update from
http://techsupport.services.ibm.com/nc.

2. Read important release information. See “Important
information” on page 16.

3. Ensure that your Windows 2000 server meets the server
requirements. See “Server requirements” on page 16.

4. Verify that your Windows 2000 server runs the
prerequisite software. See “Prerequisite software” on
page 17.

5. Install IBM Network Station Manager V2R1 on the
Windows 2000 server. See “Running the installation” on
page 18.
Note: Migrate your V1R3 preference files to V2R1. See
“Migrating to your new IBM Network Station Manager
release” on page 39.
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Important information
1. If you are migrating from IBM Network Station Manager V1R3, read the

information in “Migrating to your new IBM Network Station Manager release”
on page 39 before you start the IBM Network Station Manager V2R1

installation.
2. If you plan to separate various IBM Network Station Manager V2R1 functions

across your servers, refer to the IBM Network Station Advanced Information online
publication.

3. Read the readme.txt file on the IBM Network Station Manager installation CD
for important product release information.

Server requirements
Verify that your Windows 2000 server meets these system requirements.

Table 2. Server Requirements

Server requirement How to check for the requirement

Your Intel-based server must run any of the
following operating system software:

v Windows 2000 Server

v Windows 2000 Advanced Server

__ 1. From your Windows 2000 server
desktop, click Start->Settings-
>Control Panel->System.

__ 2. Click the General tab.

__ 3. Verify that the correct Windows 2000
Server software is installed.

Your server must be configured as one of
the following:

v Stand-alone server

v Domain member (member server of a
domain)

v Domain controller

IBM recommends the installation and
configuration of a thin client environment
on a stand-alone server or a domain
member server.

__ 1. From your Windows 2000 server
desktop, click Start->Settings-
>Control Panel->System.

__ 2. Click the Network Identification tab.

__ 3. Verify that your server is a member of
either a domain or a workgroup.

Your server must have at least 500 MB of
free hard disk space to accommodate IBM
Network Station Manager and other
required software.

If you are installing IBM Network Station
Manager from the Internet, you need an
extra 250 MB of free disk space. This extra
disk space is for downloading the software
and expanding the executable files on your
hard drive.

__ 1. From your Windows 2000 server
desktop, double-click on the My
Computer icon.

__ 2. Right-click on the drive where you
plan to install IBM Network Station
Manager.

__ 3. Select Properties, and click the
General tab.

__ 4. Verify that you have enough free hard
disk space to accommodate the IBM
Network Station Manager software.
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Table 2. Server Requirements (continued)

Server requirement How to check for the requirement

The file system of your server must be
NTFS.

__ 1. From your Windows 2000 server
desktop, double-click on the My
Computer icon.

__ 2. Right-click on the drive where you
plan to install IBM Network Station
Manager.

__ 3. Select Properties, and click the
General tab.

__ 4. Verify that your file system is NTFS.

Your server must have correct regional
settings.

__ 1. From your Windows 2000 server
desktop, click Start->Settings-
>Control Panel->Regional Options.

__ 2. Click the General tab.

__ 3. Check to see if your locale is
highlighted.

__ 4. Click Set Default.

__ 5. Select your locale from the pulldown
list, and click OK.

__ 6. Click Apply, and then click OK.

Prerequisite software
Verify that your Windows 2000 server runs the following prerequisite software:
v Any of the following web browsers:

– Netscape Communicator 4.5 or higher
– Microsoft Internet Explorer 5.0 or higher

v Microsoft Internet Information Server 5.0 (IIS) or higher
v Microsoft Dynamic Host Control Protocol (DHCP2)

Notes:

1. The Windows 2000 thin client environment does not support Lotus Domino Go
Webserver and IBM DHCP. If you currently have any of these software, you
must convert or upgrade to the prerequisite software.

2. You can use the IBM Network Station Manager installation CD to install
Netscape Communicator on your server.

3. You need the Windows 2000 Server installation CD to install these
prerequisites. Refer to Microsoft documentation for more information on
installation and configuration.
v Microsoft Internet Explorer 5.0
v Microsoft Internet Information Server 5.0
v Microsoft DHCP

Installing Microsoft DHCP
Follow these steps to install Microsoft DHCP:
__ 1. Insert the Windows 2000 installation CD into your CD-ROM drive.

2. Microsoft DHCP is not required if you plan to only use NVRAM to manage the network IP information for your thin clients.
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__ 2. From your server desktop, select Start->Programs->Administrative
Tools->Configure your Server.
The Windows 2000 Configure your Server window appears.

__ 3. Click Networking, and then click DHCP.
__ 4. Click Start the Windows Components Wizard.

The Windows Components Wizard appears.
__ 5. Highlight Networking Services from the list of components, and click

Details.
The Networking Services window appears.

__ 6. Select Dynamic Host Configuration Protocol (DHCP), and click OK.
The Networking Services window closes, and the Windows Components
Wizard appears.

__ 7. Click Next to install DHCP on your server.
__ 8. Click Finish to close the Windows Components Wizard.

Installing Microsoft IIS
Follow these steps to install Microsoft IIS:
__ 1. Insert the Windows 2000 installation CD into your CD-ROM drive.
__ 2. From your server desktop, select Start->Programs->Administrative

Tools->Configure your Server.
The Windows 2000 Configure your Server window appears.

__ 3. Click Web/Media Server, and then click Web Server.
__ 4. Click Start the Windows Components Wizard.

The Windows Components Wizard appears.
__ 5. Highlight Internet Information Services (IIS) from the list of components,

and click Details.
The Internet Information Services (IIS) window appears.

__ 6. Select the following minimum components, and click OK.
v Common Files
v Internet Information Services Snap-In
v Internet Services Manager (HTML)
v World Wide Web Server

The Internet Information Services (IIS) window closes, and the Windows
Components Wizard appears.

__ 7. Click Next to install IIS on your server.
__ 8. Click Finish to close the Windows Components Wizard.

Running the installation
These instructions pertain to a typical installation of IBM Network Station
Manager V2R1 on a Windows 2000 server.

Attention: If you choose another type of installation, some screens3 of the setup
program may not appear. For more information on a custom installation, a base
code server installation, or an authentication server installation, refer to the IBM
Network Station Advanced Information online publication.
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Follow these steps to install IBM Network Station Manager on your Windows 2000
server:
__ 1. Verify that there are no active users that are logged onto your server.
__ 2. Close all programs, restart your computer, and log in as administrator.
__ 3. Insert the IBM Network Station Manager CD into your CD-ROM drive.
__ 4. Select the language for the CD installation program.
__ 5. Select Install IBM Network Station Manager V2.
__ 6. Select Run Installation.
__ 7. Select the language for the installation, and click OK.
__ 8. Click Next on the Welcome window.
__ 9. Select Yes to accept the license agreement.
__ 10. Click Next to install IBM Network Station Manager in the default

directory.4

__ 11. Select Typical Install, and click Next.

Notes:

a. For general information on the types of installation, refer to “Types of
Installation” on page 20.

b. For technical information on a custom installation, a base code server
installation, or an authentication server installation, refer to the IBM
Network Station Advanced Information online publication.

__ 12. Click Next to add icons to the default program folder.
__ 13. Select one of the following options, and click Next.

v Select Yes to migrate your V1R3 preference files to V2R1, and enter the
location of the V1R3 user preference files in the source directory box.

v Select No if you are not migrating any V1R3 preference files during the
current installation.

__ 14. Click Next to install eNetwork™ On-Demand Server (eNOD) in the default
directory.

__ 15. Select any additional options to install, and click Next.
__ 16. Click Next to accept the current settings.

The setup program stores your installation settings in a log file,
[drive:]\NetworkStationV2\instops.txt.

__ 17. Click Yes to begin copying files.
The setup program installs the components and options you selected on
your server.

__ 18. Click Finish to restart your computer, and complete the setup program.

If you have additional software components to install, refer to “Installing the
strong encryption (128-bit) products” on page 22.

If you encountered errors during the installation, refer to “Resolving installation
problems” on page 22.

3. The Migration Location window does not appear if you select a Custom Install or a Base Code Server installation. If you select
Custom Install, and if you plan to migrate your V1R3 preference files to V2R1, you should run a manual migration. Refer to the
IBM Network Station Advanced Information online publication, and “Migrating to your new IBM Network Station Manager release”
on page 39 for more information.

4. If you use TFTP to start your thin clients, you must install in the default directory.
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To configure your thin client environment, read “Configuring a thin client
environment” on page 31.

Types of Installation

Type of Installation Description

Typical Install Provides a full installation of IBM Network Station Manager
that supports authentication and base code functions. A typical
install is the equivalent of an Authentication Server installation
and a Base Code Server installation. This option installs the
Network Station Files and Server Files of IBM Network Station
Manager in the language of the default locale.

Custom Install
(advanced users only)

Lets you select and specify individual components of IBM
Network Station Manager for installation.

Notes:

1. This option may require additional configuration on your
server after installation. Refer to the IBM Network Station
Advanced Information online publication for more information.

2. For a general description of each component, read
“Components of IBM Network Station Manager”.

Authentication Server Authenticates users and lets you configure IBM Network Station
Manager settings for each user. This option installs the Server
Files.

Notes:

1. Refer to the IBM Network Station Advanced Information online
publication for more information.

2. For a general description of the Server Files, read
“Components of IBM Network Station Manager”.

Base Code Server Sets up TCP/IP services, and lets you run application programs
on your thin clients. This option installs the Network Station
Files.

Notes:

1. Refer to the IBM Network Station Advanced Information online
publication for more information.

2. For a general description of the Network Station Files, read
“Components of IBM Network Station Manager”.

Components of IBM Network Station Manager
1. Network Station Files include programs that allow you to run your thin client

applications. Network Station Files have the following main components:
v Components for Series 2800 and Series 2200

These include subcomponents for both Series 2800 and Series 2200 thin
clients.

v Components for Series 1000 and Series 300
These include subcomponents for both Series 1000 and Series 300 thin clients.

Each of these two main components includes installable subcomponents.
Table 3 on page 21 briefly describes each of these subcomponents.

20 Installing IBM Network Station Manager V2R1 on Windows 2000



Table 3. Subcomponents of Network Station Files

Component Name Description

Network Station
Operating System

The kernel or operating system controls the operations of your
thin clients.

ICA Client and Remote
Application Manager

ICA enables thin clients to run Windows-based programs. ICA
lets you see and work with the Windows-based user interface
of a program while the application runs on the server.

Terminal Emulation
Software

This program allows you to run 5250, 3270, and VT terminal
sessions on your thin clients.

Netscape Communicator On the thin client, the Netscape Communicator browser
functions as a client by sending requests for information and
displaying the information for the user. You also use Netscape
Communicator to access and configure your thin clients.

Network Station Java™

Virtual Machine (JVM)
JVM provides your thin clients with a Java runtime
environment that enables loading of Java-based applications.

Network Station Complete
Font Support

This component installs the entire collection of system fonts
for your thin clients.

National Language
Support

This program allows you to run IBM Network Station
Manager in your preferred language.

2. Server Files include programs that your server runs to manage your thin
clients. Server Files have the following main components:
v Network Station Manager Program

Network Station Manager allows you to configure and manage your thin
clients from a server.

v Network Station Login Service
This program allows you to authenticate users and start login access on your
thin clients.

v Common Server Files
These are components that support IBM Network Station Manager.

Supported languages
Table 4. Supported Languages and Language Designators

UNIX®

Language
Designator

Language Language
Designator

Language

da_DK Danish in Denmark fr_CH French in Switzerland

de_CH German in Switzerland fr_FR French in France

de_DE German in Germany it_CH Italian in Switzerland

en_GB English in Great Britain it_IT Italian in Italy

en_US English in the United States nl_BE Dutch in Belgium

es_ES Spanish in Spain nl_NL Dutch in The Netherlands

es_LA Spanish in Latin America no_NO Norwegian in Norway

fi_FI Finnish in Finland pt_BR Portuguese in Brazil

fr_BE French in Belgium pt_PT Portuguese in Portugal

fr_CA French in Canada sv_SE Swedish in Sweden
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Installing the strong encryption (128-bit) products
Customers from countries that allow strong encryption product imports have the
option of installing the strong encryption (128-bit) products that are included in the
IBM Network Station Manager (strong encryption) installation CD. The strong
encryption (128-bit) products include the following:
v 128-bit Netscape Communicator browser
v Secure Sockets Layer (SSL shared library)
v 128-bit ICA Client and Remote Application Manager.

You can automatically install these products during the IBM Network Station
Manager installation by clicking Yes when the the setup program prompts you.

Follow these steps to manually install the strong encryption (128-bit) products:
__ 1. Insert the IBM Network Station Manager CD into your CD-ROM drive.
__ 2. Run the following command from the Windows 2000 Run command box:

[CD-ROM drive]:\ntnsm\en\products\nsm128\setup.exe

An installation wizard screen appears.
__ 3. Follow the prompts of the installation wizard to complete the installation.

Uninstalling IBM Network Station Manager
Follow these steps to uninstall any software thatIBM Network Station Manager
from your Windows 2000 server:
__ 1. Verify that there are no active users that are logged onto your server.
__ 2. Close all programs, restart your computer, and log in as administrator.
__ 3. Select Start-Settings-Control Panel-Add/Remove Programs.
__ 4. Select IBM Network Station Manager V2R1, and click Add/Remove.
__ 5. Follow the prompts of the wizard that appears.
__ 6. Click Finish to complete the uninstallation.

Resolving installation problems
If problems occur during the installation of IBM Network Station Manager, consult
Table 5 with your installation error, and follow the steps to resolve the problem. If
the installation problem persists, contact IBM technical support.

Table 5. Common Installation Errors

Error message How do I resolve the error?

Cannot create an IBM
Network Station Manager
user group.

The setup program did not create the NSMUser group or NSMAdmin group.

1. Exit the setup program.

2. Restart your server.

3. Run the setup program again.
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

Cannot configure Microsoft
Internet Information Server

The setup program cannot configure Microsoft Internet Information Server.

Follow these steps to configure IIS manually:

v From your Windows 2000 server desktop, click Start->Programs->Administrative
Tools-> Computer Management.

v From the Tree area, click Services and Applications->Internet Information
Services.

v Select the Default web site.

v From the Actions menu, select New->Virtual Directory.

1. For Alias to be used to access virtual directory, enter networkstationv2,
and click Next.

2. For the path, enter [drive:]\{float}\NetworkStationV2\servbase\html, and
click Next.

3. Select Allow Read Access only, and click Next.

4. Click Finish.

5. Right-click networkstationv2 and select Properties.

a. Select the Documents tab.

b. Check enable Default Document, and click Add.

c. Enter admin.htm.

d. Select the Directory Security tab, and click Edit.

e. Check Basic Authentication (Password is sent in clear text.), and click
OK.

f. Click OK to close the networkstationv2 properties dialog box.

6. Right-click networkstationv2.

7. From the Actions menu, select New->Virtual Directory.

a. For Alias to be used to access virtual directory, enter admin, and click
Next.

b. For the path, enter [drive:]\{float}\NetworkStationV2\servbase\cgi-bin,
and click Next.

c. Select Allow execute access (includes script access) only, and click Next.

d. Click Finish.

8. Right-click admin and select Properties.

a. Select the Documents tab.

b. Check enable Default Document, and click Add.

c. Enter nsmcgain.exe.

d. Select the Directory Security tab, and click Edit on the Anonymous Access
and Authentication Control box.

e. Check Basic Authentication (Password is sent in clear text.), and click
OK.

f. Click OK to close the networkstationv2 properties dialog box.

9. From the Actions menu, select New->Virtual Directory.

a. For Alias to be used to access virtual directory, enter cgi, and click Next.

b. For the path, enter [drive:]\{float}\NetworkStationV2\servbase\cgi-bin,
and click Next.

c. Select Allow execute access (includes script access) only, and click Next.

d. Click Finish.

10. Select the Default web site.
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

v From the Actions menu, select New->Virtual Directory.

1. For Alias to be used to access virtual directory, enter flashconfigs, and click
Next.

2. For the path, enter
[drive:]\{float}\NetworkStationV2\userbase\flash\ImageConfigs, and click
Next.

3. Select Allow Read Access only, and click Next.

4. Click Finish.

5. Right-click flashconfigs and select Properties.

a. Select the Documents tab.

b. Check enable Default Document, and click Add.

c. Enter admin.htm.

d. Select the Directory Security tab, and click Edit on the Anonymous Access
and Authentication Control box.

e. Check Basic Authentication (Password is sent in clear text.), and click
OK.

f. Click OK to close the networkstationv2 properties dialog box.

Cannot find file system. The drive or partition where you plan to install IBM Network Station Manager may
be damaged.

Select a fixed drive for the IBM Network Station Manager installation.

Cannot install the IBM
Network Station Login
Service.

The setup program cannot install the IBM Network Station Login Service.

1. Make sure that you configured your Network Adapter card correctly. Your
Network Adapter card should work properly before installing IBM Network
Station Manager.

2. Make sure that your network cable is plugged in correctly.

3. Restart your server.

4. Run the setup program again.

Cannot obtain the Domain
Controller name.

The setup program cannot locate the Domain Controller name for your Windows
2000 server.

Verify that your Windows 2000 Domain Controller is responding to requests and is
accessible from the network.

Corrupted AS/400® Integrated
PC Server Registry.

The required PTF is not installed on the Integrated Netfinity® Server. This PTF fixes
a registry compatibility problem with the installation of the NDIS intermediate
support driver.

1. Exit from the setup program.

2. Restart your server.

3. Refer to the V2R1 readme.txt file for the PTF name.

4. Apply the required PTF.

5. Run the setup program again.
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

Error configuring NFS. The setup program cannot configure NFS properly.

Follow these steps to configure NFS manually:

1. From your Windows 2000 server desktop, click Start->Programs->eNetwork
On Demand Server->NFS Server Configuration.

2. Select the Directories tab and click Add.

3. Enter [drive:]\{float}\NetworkStationV2\userbase in the Directory field.

4. Enter /NetworkStationV2/userbase/ in the Alias field.

5. Select Allow hosts read and write access, and click Add.

6. Click Add.

7. Enter [drive:]\float\NetworkStationV2\prodbase in the Directory field.

8. Enter /NetworkStationV2/prodbase/ in the Alias field.

9. Select Allow hosts read-only access, and click Add.

10. Select the Users tab.

11. Select NSMNFS_User, and click Add.

12. Select NSM_NFSRoot, and click Add.

13. From the pulldown menu, click File->Save.

Error configuring TFTP. The setup program cannot configure TFTP properly. Configure TFTP properly.
Follow these instructions:

1. From your Windows 2000 server desktop, click Start->Programs->eNetwork On
Demand Server->TFTP Server Configuration.

2. Enter [drive:]\{float}\NetworkStationV2\prodbase in the Directory field, and
click Add.

3. From the pulldown menu, click File->Save.

Error creating user directories. The setup program did not create some or all of the following directories:

/NetworkStationV2/userbase
/NetworkStationV2/userbase/profiles
/NetworkStationV2/userbase/profiles/groups
/NetworkStationV2/userbase/profiles/ncs
/NetworkStationV2/userbase/profiles/users

/NetworkStationV2/userbase/nsmshared
/NetworkStationV2/userbase/nsmshared/kiosk

/NetworkStationV2/userbase/home/
/NetworkStationV2/userbase/home/kiosk

/NetworkStationV2/userbase/flash/

The setup program did not create some or all of the following base permissions:

v Full Control for Administrators, NSMAdmin, and SYSTEM

v Read for NSMUser

Follow these steps:

1. Exit from the setup program.

2. Restart your server.

3. Run the setup program again.
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

v Error launching eNetwork
On-Demand Server
installation.

v Error creating input file for
eNetwork On-Demand
Server installation.

The setup program cannot install eNOD properly.

Install the eNOD services manually. Follow these instructions:

1. Insert the IBM Network Station Manager CD into your CD-ROM drive.

2. Wait for the autorun dialog box to appear. Exit from this window.

3. Run the command, [CD-ROM
drive]:\ntnsm\en\products\eNOD\tcpip\setup.exe, from the Windows 2000
Run command box.

4. Follow the installation instructions.

5. Select Finish to restart your computer and complete the eNOD services
installation.

Error updating path
environment variable.

The setup program cannot add the necessary entries to the system path.

Add IBM Network Station Manager to the system path manually.

Follow these steps to update the path environment variable manually:

1. From your Windows 2000 server desktop, click Start->Settings->Control
Panel->System.

2. Click the Advanced tab.

3. Under Environment Variables, select Path.

4. Append [drive:]\{float}\NetworkStationV2\servbase\bin to the end of the
current value of your path variable.

5. Click Set, and then click OK.

Error while trying to
synchronize the /etc/hosts
file.

This file was not correctly set up. Use the following sample to replace this file
manually:

Example for:

[drive:]\{float}\NetworkStationV2\prodbase\ppc\etc\hosts
[drive:]\{float}\NetworkStationV2\prodbase\x86\etc\hosts
127.0.0.1 localhost
9.3.159.186 starscream starscream.austin.ibm.com

Format: <Server IP Address> <computer name> <fully qualified computer name>

File system is not NTFS. The drive or partition where you plan to install IBM Network Station Manager
must be formatted using NTFS.

1. Exit from the setup program.

2. Select a fixed drive that uses the NTFS file system, or switch the current drive to
NTFS.

3. Run the setup program again.
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

Installation was unable to
configure the /etc/resolv.conf
file.

This file was not correctly set up. Use the following sample to replace these files
manually:

Files to be replaced:

[drive:]\{float}\NetworkStationV2\prodbase\ppc\etc\resolv.conf
[drive:]\{float}\NetworkStationV2\prodbase\x86\etc\resolv.conf

Format:

domain <domain name>
search <domain name 1> . . . <domain name n>
nameserver <name server IP address>

. . . nameserver <name server IP address>
lookup file bind

Example:

domain rchland.ibm.com
search rchland.ibm.com ibm.com
nameserver 12.34.56.78
nameserver 12.34.56.89
nameserver 12.34.56.90
lookup file bind

Migration internal error. Run
the migration utility from the
command line.

An invalid parameter was used to run migration.

1. Check the Windows 2000 Application Event Log for more information.

2. Refer to Table 9 on page 43 for valid migration parameters.

3. Run the migration utility from the command line.

Migration utility initialization
failed. Run the migration
utility from the command line.

An invalid parameter was used to run migration, or the migration program did not
complete successfully.

1. Check the Windows 2000 Application Event Log for more information.

2. Refer to Table 9 on page 43 for valid migration parameters.

3. Run the migration utility from the command line.

Migration utility parameter
not valid. Run the migration
utility from the command line.

An invalid parameter was used to run migration.

1. Check the Windows 2000 Application Event Log for more information.

2. Refer to Table 9 on page 43 for valid migration parameters.

3. Run the migration utility from the command line.

Network File System (NFS)
failed with the following
error:

An error occurred while setting NFS permissions. See the NSM_NFS_Error.txt for
more information. Contact IBM Technical Support.

NFS user creation error. The setup program cannot create NFS User.

1. Exit from the setup program.

2. Restart your server.

3. Run the setup program again.

North American (128-bit)
encrypted products
installation error.

This error appears if you are using the North American version of the IBM Network
Station Manager installation CD. The installation cannot install the 128-bit strong
encryption products.

Install the 128-bit strong encryption products manually. Refer to “Installing the
strong encryption (128-bit) products” on page 22 for instructions.
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

Not enough Free Space on
Disk.

You need at least 500 MB of free disk space to install IBM Network Station Manager
on your server.

1. Exit from the setup program.

2. Free up some disk space or select another fixed drive with enough free disk
space.

3. Run the setup program again.

The drive chosen is not a
fixed drive. Choose another
install location.

The setup program cannot install IBM Network Station Manager on a remote or
network drive.

Select a fixed drive for the installation.

The following error occurred
during Setup. Error: 100

The V1R3 Network Station Login Service was not removed successfully.

Disable the V1R3 Network Station Login Service. Refer to “Starting and stopping
services” on page 34 for instructions.

The following error occurred
during Setup. Error: 101

The setup program cannot migrate the IBM Network Station Login Service to V2R1.

Disable the V1R3 Network Station Login Service. Refer to “Starting and stopping
services” on page 34 for instructions.

The following error occurred
during Setup. Error: [102 to
115]

The program used to automatically syncronize the language initial locale preference
for the Network Station login encountered an error. The language preference for the
client login needs to be set properly.

A utility program can be run to automatically set this preference. This program is in
[drive]:\{float}\NetworkStationV2\servbase\bin ({float} is a subdirectory).

You can run this program from a Windows 2000 command prompt. The command
is:

nsmutlds -v ll_CC

where ll_CC is the 5 digit language designator for the client login language. Refer
to “Supported languages” on page 21 for more information.

If this utility does not run successfully, contact IBM technical support.
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

Unknown client
synchronization error.

The setup program was unable to configure following files. Use the following
samples to replace these files manually.

Files to be replaced:

[drive:]\{float}\NetworkStationV2\prodbase\ppc\etc\hosts
[drive:]\{float}\NetworkStationV2\prodbase\x86\etc\hosts

Format:

<server IP address><computer name><fully qualified computer name>

Example:

12.34.56.01 localhost
12.34.56.78 starscream starscream.rchland.ibm.com

Files to be replaced:

[drive:]\{float}\NetworkStationV2\prodbase\ppc\etc\resolv.conf
[drive:]\{float}\NetworkStationV2\prodbase\x86\etc\resolv.conf

Format:

domain <domain name>
search <domain name 1> . . . <domain name n>
nameserver <name server IP address>

. . . nameserver <name server IP address>
lookup file bind

Example:

domain rchland.ibm.com
search rchland.ibm.com ibm.com
nameserver 12.34.56.78
nameserver 12.34.56.89
nameserver 12.34.56.90
lookup file bind

User not authorized to run
setup and migration. User
must belong to the
NSMAdmin group. Run the
migration utility from the
command line.

A user that belongs to the NSMAdmin group should run migration.

1. Check the Windows 2000 Application Event Log for more information.

2. Restart your server.

3. Login as a user that belongs to the NSMAdmin group.

4. Run the migration utility from the command line.

V1R3 migration source
directory does not exist or
V1R3 not installed on this
server. Run the migration
utility from the command line.

The setup program cannot locate the V1R3 preference files on your server, or the
source directory location specified was not accessible.

1. Check the Windows 2000 Application Event Log for more information.

2. Verify the directory location of IBM Network Station Manager V1R3.

3. Run the migration utility from the command line.

V1R3 uninstall error. The setup program was unable to automatically uninstall IBM Network Station
Manager V1R3.

Uninstall this product manually by using Add/Remove Programs from the
Windows 2000 Control Panel.

WARNING: Previous version
found:

The setup program detected an earlier version of IBM Network Station Manager.

Remove V1R3. Refer to “Uninstalling IBM Network Station Manager” on page 22
for instructions.
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About this section
This section provides information on configuring a thin client environment on
Windows 2000.

Planning the configuration
To configure a thin client environment on your Windows 2000 server, you must
complete the following tasks:
v Add a user account to the NSMUser group for the thin client user.
v Configure your DHCP settings.

Creating Users and Groups
When you create user accounts or group accounts for your thin clients, observe the
following restrictions for user names, group names, and passwords:
v User names and group names must not be identical to Windows 2000 or

Windows 2000 domain names or server names.
v Names cannot be more than 20 characters long.
v Names must be subsets of the ″invariant ASCII″ or the English alphanumeric set.

They may not contain any of the following elements:

Double-byte characters
Characters below ASCII 33 and above ASCII 127
Control characters
Spaces or tabs
Any of the following characters:

Forward slash (/)
Backward slash (\)
Colon (:)
Semicolon (;)
Asterisk (*)
Question mark (?)
Quotation mark (″)
″Greater than″ symbol (>)
″Less than″ symbol (<)
Brackets ([, ])
Plus sign (+)

If your Windows 2000 server is either a stand-alone server or a domain member
server, follow these steps to create users or groups:
__ 1. From your server desktop, click Start->Programs->Administrative

Tools->Computer Management.

© Copyright IBM Corp. 2000 31



The Computer Management window appears.
__ 2. Double-click Local Users and Groups to expand it.
__ 3. Select one of the following options:

v To create a new user, select Users.
__ a. From the menu, select Action->New User.

The New User dialog box appears.
__ b. Enter valid values for the user name and password fields.
__ c. Specify any password or account options, and click Create.
__ d. Click Close to close the New User dialog box.

v To create a new group, select Groups.
__ a. From the menu, select Action->New Group.

The New Group dialog box appears.
__ b. Enter valid values for the group name and description fields, and

click Create.
To manually create the NSM groups, type NSMAdmin or
NSMUser in the group name field.

__ c. Click Close to close the New Group dialog box.
__ 4. Verify that the new user or new group appears on the details area of the

Computer Management window.

If your Windows 2000 server is a domain controller, follow these steps to create
domain users or domain groups:
__ 1. From your server desktop, click Start->Programs->Administrative

Tools->Active Directory Users and Computers.
The Active Directory Users and Computers window appears.

__ 2. Select Users.
__ 3. Select one of the following options:

v To create a domain user, select Action->New->User from the menu.
The New Object - User wizard appears.
__ a. Enter valid values for the first name, last name, and user logon

name fields, and click Next.
__ b. Specify a password, check any account options, and click Next.
__ c. Click Finish to complete the wizard.

v To create a new group, select Action->New->Group from the menu.
The New Object - Group dialog box appears.
__ a. Enter a valid group name in the group name field.

To manually create the NSM groups, type NSMAdmin or
NSMUser in the group name field.

__ b. Select a group scope.
__ c. Select a group type.
__ d. Click OK to close the New Object - Group dialog box.

__ 4. Verify that the new user or new group appears on the details area of the
Active Directory Users and Computers window.

32 Installing IBM Network Station Manager V2R1 on Windows 2000



Adding Users and Groups
If your Windows 2000 server is a stand-alone server or a domain member server,
follow these steps to add domain users or domain groups to the NSMUser group
or NSMAdmin group:
__ 1. From your server desktop, click Start->Programs->Administrative

Tools->Computer Management.
The Computer Management window appears.

__ 2. Double-click Local Users and Groups to expand it.
__ 3. Click Groups, and select NSMUser or NSMAdmin from the list of groups.
__ 4. From the menu, select Action->Add to Group, and click Add.

The Select Users or Groups dialog box appears.
__ 5. Select users or groups from the list of names, and click Add.
__ 6. Click OK to close the Select Users or Groups dialog box.
__ 7. Click Apply, and then click Close.

If your Windows 2000 server is a domain controller, follow these steps to add
domain users or groups to the NSMUser group or NSMAdmin group:
__ 1. From your server desktop, click Start->Programs->Administrative

Tools->Active Directory Users and Computers.
The Active Directory Users and Computers window appears.

__ 2. Select Users.
__ 3. Select NSMUser or NSMAdmin from the list of groups.
__ 4. From the menu, select Action->Properties.

The group properties dialog box appears.
__ 5. Click the Members tab, and click Add.

The Select Users or Groups dialog box appears.
__ 6. Select the domain that contains the users or groups from the pulldown list.
__ 7. Select users or groups from the list of names, and click Add.
__ 8. Click OK to close the Select Users or Groups dialog box.
__ 9. Click Apply, and then click OK.

Configuring DHCP for your network
DHCP is a sophisticated tool for managing your network. A careful, well-thought
out DHCP configuration can make a network run effectively. Whenever you make
changes to your network configuration, you must ensure that the DHCP
configuration reflects those changes. Read “DHCP” on page 6 for additional
information about DHCP.

Collect the following information about your network before you configure DHCP.
Record your information in Table 6.

Table 6. Gathering DHCP Information

DHCP
Option

Number

DHCP
Option
Name

Description Write Your Network
Value Here

003 Router The IP address of the default router
which receives TCP/IP packets that
are not addressed to your network.
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Table 6. Gathering DHCP Information (continued)

DHCP
Option

Number

DHCP
Option
Name

Description Write Your Network
Value Here

006 DNS Servers Enables clients to use either fully
qualified host names or IP addresses
when they communicate with other
devices.

015 DNS
Domain
Name

Allows thin clients to specify their
domain to other devices.

066 Boot Server
Host Name

The IP address of the server from
which your thin client downloads its
operating system.

Table 7 specifies the directory path and boot file name for the different thin client
hardware.

Table 7. Boot File Name for different thin clients

Network Station Hardware Series
(Type-Model)

Boot File Name

Series 2800 (8364 - all models) /NetworkStationV2/prodbase/x86/kernel.2800

Series 2200 (8363 - all models) /NetworkStationV2/prodbase/x86/kernel.2200

Series 1000 (8362 - all models) /NetworkStationV2/prodbase/ppc/kernel.1000

Series 300 (8361-110 and 8361-210) /NetworkStationV2/prodbase/ppc/kernel.300

Configuring Microsoft DHCP
Follow these steps to configure Microsoft DHCP:
__ 1. Complete Table 6 on page 33.
__ 2. From your Windows 2000 server desktop, click Start->Programs-

>Administrative Tools->DHCP from your server’s desktop.
The DHCP window appears.

__ 3. Under the Tree area, highlight your server.
__ 4. From the menu bar, select Action->New Scope.

The New Scope Wizard appears.
__ 5. Complete the New Scope Wizard.

For more information, refer to the DHCP Help information from Microsoft.
__ 6. Repeat the steps above for creating additional scopes.

See the Using IBM Network Station Manager publication for information on
configuring your thin clients to start using DHCP.

Starting and stopping services
IBM Network Station Manager starts the following servers and services:
v Internet Information Services (IIS)
v DHCP
v IBM TCP/IP Services
v NFS server
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v TFTP server
v Ethernet adapter or token-ring adapter
v Network Station Login Service Version 2

Follow these steps to manually start or stop a service:
__ 1. From your server desktop, select Start->Programs->Administrative

Tools->Services.
__ 2. Select the service which you want to start or stop.
__ 3. Right-click on the service, and select Start or Stop.

Configuring printers for your thin clients
You can configure printers for your thin clients with IBM Network Station
Manager. In order to configure printing successfully, you have to identify the
datastreams that your printer understands. If an application produces a datastream
other than what your printer can understand, you might not get a printed output.
See the Using IBM Network Station Manager publication for more information on the
datastreams that the common thin client applications produce.

Figure 5 illustrates a typical network printing setup.

Table 8 on page 36 explains the basic steps to configure printers for your thin
clients. Identify the scenario that best meets your needs and follow the instructions
to configure your printers.

Figure 5. Possible thin client printing scenarios
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Table 8. Configuration Descriptions for Basic Printer Scenarios

Print Scenario Print Job Flow in
Figure 5 on page 35

Configuration Instructions

thin client to a LAN
printer

thin client A to Printer
1

1. In IBM Network Station Manager, access the following path
from the right-side menu: Hardware->Printers.

2. Configure an entry in the Remote Printer Server field for the
LAN printer.

thin client to a locally
attached printer

thin client B to Printer
5

1. In IBM Network Station Manager, access the following path
from the right-side menu: Hardware->Printers.

2. Configure an entry in the Local Parallel Printer or the Local
Serial Printer field, depending on how the printer connects to
the thin client.

thin client to another
thin client with an
attached printer

thin client A to thin
client B to Printer 5

1. In IBM Network Station Manager, access the following path
from the right-side menu: Hardware->Printers.

2. Configure an entry in the Remote Printer Server field with the
IP address of the thin client to which the printer is attached. In
the Queue name field, type PARALLEL1 or SERIAL1, depending on
how the printer connects to the thin client.

Windows 2000 server
to a thin client with
an attached printer

Windows 2000 to thin
client B to printer 5

1. Verify that Network File and Print Services is installed on your
Windows 2000 server.

a. From your Windows 2000 server desktop, click
Start–>Settings–>Control Panel–>Network and Dial-up
Connections.

b. Right-click on Local Area Connection, and select Properties.

c. Verify that the File and Printer Sharing for Microsoft
Networks is checked.

If you do not see this item, refer to the Microsoft online help
for information on adding the Other Network File and Print
Services component.

d. Click OK to close the window.

2. Add a printer connection to your Windows 2000 server.

a. From your Windows 2000 server desktop, click
Start–>Settings–>Printers.

b. Double-click Add Printer.

c. Click Next on the welcome screen.

d. Select Local Printer, and click Next.

e. Select Create a new port.

1) Select LPR Port from the pulldown list, and click Next.

f. In the Add LPR compatible printer dialog box, enter the
following information:

v IP address of the thin client to which the printer is
attached.

v Name of the printer, or print queue SERIAL1, or PARALLEL1.

g. Complete the rest of the wizard.

Printer Administration Techniques
Administrating a printer environment is a difficult task. You should create a printer
network diagram. From this network printing diagram, you can develop a printing
strategy that best meets your printing needs. Under the right conditions, thin
clients can print to most types of printers.
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Controlling print jobs through your Windows 2000 server
One technique to consider is to have a server control the printers for your thin
clients. In Figure 5 on page 35, the Windows 2000 server could control a LAN
printer like Printer 4. Network Station A and Network Station B send their print
jobs to the Windows 2000 server. The Windows 2000 server controls the flow of
print jobs to the printer.

Advantages Disadvantages

This scenario reduces the work load on the
thin clients when the printer buffer is full
because the Windows 2000 server negotiates
print jobs with the printer.

Handling these print jobs may likely
decrease the CPU performance of your
Windows 2000 server, depending on the size
and frequency of your print jobs. Your end
users may notice that it takes longer for
them to receive their printouts.

Since you would send the print job from a
Network Station, to a server, and then to a
printer, this technique would increase
network traffic, too.

To have a server control your Network
Station printing is advantageous in an
environment with mixed printer
datastreams. Since Network Station
applications produce certain datastreams,
you may need to send print jobs to a server.
The server processes the print job and
transforms it into a datastream that your
printer understands. Depending on which
application creates the job, you may or may
not need to transform your print jobs.

To eliminate confusion, you should consider
having all print jobs sent to the server
regardless of whether the job needs
transforming or not.

In the end, you will have fewer printer
entries in IBM Network Station Manager
and fewer printer device descriptions on the
server.

This may require more administration in
IBM Network station Manager and on the
server. Your end users would also need to
have a better understanding of printing and
networking.

Sending print jobs directly to the printer
The other technique is to set up your printing strategy so that your Network
Stations send their print jobs directly to the printer. You reduce printing time since
the print job goes directly to the printer. Your server does not bear the load of
controlling print jobs. Sending your print jobs directly to the printer also reduces
the chance of lost or damaged print jobs. When a server misinterprets a print job,
the job may become lost or damaged.

Before you continu e . . .
v To ensure correct operation and to take advantage of new functionality, verify

and update the boot code of your thin clients to the latest level. Even if you
have new thin clients, you must verify and update the boot code of your thin
clients. For more information about updating the boot code, see the Using IBM
Network Station Manager publication.
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v For Series 300 and Series 1000 thin clients, if you use the NVRAM boot method,
you must enable DNS support through IBM Network Station Manager. To
enable DNS support, see the Using IBM Network Station Manager publication.

v The information in the NS Boot Utility (Series 2800 and Series 2200) or Setup
Utility (Series 1000 and Series 300) of your thin client must agree with your boot
method. See the Using IBM Network Station Manager publication for more
information.

v Verify that you started your DHCP server, HTTP server, and either NFS server
or TFTP server. Refer to “Starting and stopping services” on page 34 for
instructions.

v Verify that you excluded any statically addressed devices in your DHCP IP
address range.

v If you have a router between your Network Stations and your boot server, verify
that your router can handle DHCP requests.

v For more information about setting up Network Stations, see the Using IBM
Network Station Manager publication.
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About this section
This section provides information for migrating IBM Network Station Manager
V1R3 preference files and existing thin clients to IBM Network Station Manager
V2R1 on a Windows 2000 server. You must read the information in this section
before attempting the migration.

Planning the migration
Before you can migrate V1R3 preference files and existing thin clients to IBM
Network Station Manager V2R1 on a Windows 2000 server, you must first
complete these tasks:
v Identify an upgrade path. See “Planning the installation” on page 13 for more

information.
v Read important migration information.

Important information
If you plan to migrate from V1R3 to V2R1, read the following information:
v The Windows 2000 Event Viewer maintains a status log of the migration. If you

encounter problems while running migration, refer to “Resolving installation
problems” on page 22 for error resolution.

v If you manually changed any configuration files in the past, refer to the online
IBM Network Station Advanced Information publication for information on
migrating these configuration files.

v You can migrate V1R3 preference files to V2R1 during the V2R1 installation, or
by running the V2R1 migration utility from a command prompt after the IBM
Network Station Manager installation. Migration during installation requires that
you have V1R3 Service Update 10 installed on the server from which you are
migrating.

v If you are migrating your V1R3 preference files to V2R1 on the same server
where you installed V1R3 and where you store your preference files, run a
single-server migration. If you are migrating your preference files from one
server to another server, you can run a dual-server migration. Install V2R1 on
your second server before attempting a dual-server migration.

v Typically, you group thin clients that use different boot methods to start up and
obtain their kernel files from your server into two client groups. NVRAM thin
clients and DHCP thin clients use different client migration methods to migrate
to V2R1. You use the migration utility to migrate NVRAM thin clients to V2R1.
You change the DHCP configuration to migrate DHCP thin clients to V2R1.

v If you need V1R3 to support certain thin clients (see Table 1 on page 10), you
need to maintain V1R3 on a Windows NT server. You can download the latest
V1R3 Service Update from http://techsupport.services.ibm.com/nc. Refer to
the latest versions of the following publications for more information:
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– Installing IBM Network Station Manager for Windows NT

– IBM Network Station Manager V1R3 Installation and Use

Running the migration
To migrate the V1R3 environment to V2R1, you carry out two tasks. First, you
move your preference files to V2R1 (preference file migration). There are two ways
in which you can perform preference file migration. You can run automatic
migration during the installation, or you can perform manual migration by
running the migration utility from a command prompt. After you migrate your
preference files, you then configure your thin clients to start and operate from the
new V2R1 software (client migration).

Preference File Migration
If you choose to migrate during installation (automatic migration), the migration
utility performs complete migration to V2R1 for all of your V1R3 preference files.
These include preference files for users, groups, thin clients, and system defaults.
For more information on migration during installation, refer to “Migration during
Installation” on page 41.

If you choose not to migrate during installation, Setup installs V2R1 on your
server. Your V1R3 preference files remain unchanged.

If you choose to migrate after running the V2R1 setup program, you can perform
manual migration. You can manually migrate individual preferences or thin clients
by using command-line instructions. You run the migration utility from the
Windows 2000 command prompt to accomplish migration in stages. The
command-line interface allows you to specify an individual user, group, or thin
client for migration. For more information on manual migration, refer to “Manual
Migration” on page 42.

The migration utility migrates other individual preferences when you run
migration. These include 3270/5250 emulators, browser files, login files, V1R3
suppression of login (kiosk) files, and all other files in the user or group directory.
When the migration utility migrates the old V1R3 browser files, it renames the old
V1R3 NC Navigator browser files, bookmarks.html, and address-book.html, to
v1r3_bm.htm and v1r3_ab.htm, respectively. The migration utility saves these files
under the thin client user’s
/NetworkStationV2/userbase/home/[username]/.netscape directory. If you want
to continue using your V1R3 browser preference information, you must import
these files.

Follow these steps to import your bookmarks file:
__ 1. Start the Netscape Communicator browser from your thin client.
__ 2. From the browser menu, click Communicator->Bookmarks->Edit

Bookmarks.
__ 3. From the main menu of the Bookmarks window, click File->Import.
__ 4. Select the v1r3_bm.htm file, and click Open.

Follow these steps to import your address book file:
__ 1. Start the Netscape Communicator browser from your thin client.
__ 2. From the browser menu, click Communicator->Address Book.
__ 3. From the main menu of the Address Book window, click File->Import.
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__ 4. Select an import format and click Next.
__ 5. Select the v1r3_ab.htm file, and click Open.

Preference file migration, whether automatic or manual, is one-way (V1R3 to
V2R1). You cannot migrate subsequent changes in V2R1 back to V1R3. Languages
and keyboards that were available in V1R3 may not be available in V2R1.
Although you can run the migration utility several times, it is advisable that you
run migration only once.

Migration during Installation
The IBM Network Station Manager V2R1 setup program runs automatic migration
when you choose to migrate during installation. Automatic migration requires
V1R3 Service Update 10.

Single-Server Migration: You can perform a single-server migration if you are
upgrading your V1R3 preference files from the same server where you plan to
install IBM Network Station Manager V2R1.

Follow these steps to run a single-server automatic migration:
__ 1. Verify that you can access the following V1R3 directories:

v [drive:]\{float}\nstation\userbase
v [drive:]\{float}\nstation\prodbase\configs

({float} is a subdirectory)
__ 2. Install IBM Network Station Manager V2R1. Refer to “Running the

installation” on page 18 for more information.
__ 3. On the Migration Location window of the IBM Network Station Manager

setup program, select Yes to confirm that you are migrating.
__ 4. On the same window, enter the location of the V1R3 preference files,

[drive:]\nstation, in the Source Directory box, and click Next.
__ 5. Complete the setup program.

The setup program migrates your V1R3 preference files to V2R1.
You can now move your existing thin clients to your new IBM Network
Station Manager V2R1 software. Refer to “Client Migration” on page 44 for
more information.

Dual-Server Migration: You can perform a dual-server migration if you are
upgrading your V1R3 preference files from a different server. A dual-server
migration lets you maintain V1R3 on another server until you can configure and
test the V2R1 software on another server.

Follow these steps to perform a dual-server preference file migration:
__ 1. Verify that your new server meets the server requirements and runs the

prerequisite software. Refer to “Server requirements” on page 16 and
“Prerequisite software” on page 17 for more information.

__ 2. On your new server, map a network connection to your old server.
__ 3. Create (or replicate) your V1R3 users and groups on your new V2R1 server.

__ a. Refer to “Creating Users and Groups” on page 31 for information on
creating the NSMUser and NSMAdmin groups on the new server.

__ b. Copy the users from the old NSMUser and NSMAdmin groups from
your old server to the new NSMUser and NSMAdmin groups on
your new server.
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__ c. If you are migrating to a Stand-Alone server, you need to manually
create all of your users on the new server. You must then add them to
the NSMUser and NSMAdmin groups as appropriate. Refer to
“Adding Users and Groups” on page 33 for instructions.

__ 4. Install IBM Network Station Manager. Refer to “Running the installation” on
page 18 for more information.

__ 5. On the Migration Location window of the IBM Network Station Manager
setup program, select Yes to confirm that you are migrating.

__ 6. On the same window, enter the location of the V1R3 preference files,
[drive:]\nstation, in the Source Directory box, and click Next.

__ 7. Complete the setup program.
The setup program migrates your V1R3 preference files to V2R1.
You can now move your existing thin clients to your new IBM Network
Station Manager V2R1 software. Refer to “Client Migration” on page 44 for
more information.

Manual Migration
You can run manual migration from the Windows 2000 command prompt. The
migration utility enables you to copy V1R3 configurations and users to the V2R1
environment.

The Migration Utility: The migration utility has the following requirements and
features:
v Your V2R1 server must have access to your V1R3 preference files.
v The migration utility does not support migration from a release earlier than

V1R3.
v You can only run the migration utility from a server that has V2R1 installed.
v Only users with administrator authority (members of the NSMAdmin group)

can run the V2R1 migration utility.
v The migration utility does not include an option to delete V1R3. You can

manually uninstall the V1R3 environment after the migration utility migrates the
configuration information and user preference files to V2R1.

Note: You need to maintain V1R3 on a Windows NT server to operate and
maintain any Series 100 (8361-100 and 8361-200) or Series 300 (twin-axial
8361-341) thin clients. Refer to Installing IBM Network Station Manager for
Windows NT for more information.

v Although you can run the migration utility several times, even over the same
users, groups, or thin clients, you should migrate preference files only once.
Each time the migration utility runs, it writes over any existing V2R1 preference
files.

v The migration utility can perform client migration for Series 300 (8361-110 and
8361-210) and Series 1000 (8362-all models) thin clients. However, you have to
manually configure DHCP and NVRAM for each thin client. Refer to “Client
Migration” on page 44 for instructions.

The migration utility is in [drive:]\{float}\NetworkStationV2\servbase\bin. You
can run the migration utility from the Windows 2000 command prompt by using
the following command structure:

nsmv2migr {parameter1 <attribute1>...<attribute#>}...{parameter# <attribute1>...<attribute#>}
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Table 9 explains the different parameters for running the migration utility.

Table 9. Migration Utility Command Parameters

Parameter Description and Format

-A Complete migration for all users, all groups, all terminals, and system
preferences. This parameter does not migrate the thin client clients. The
command structure is nsmv2migr -A.

-S Migrates system preference levels from V1R3 to V2R1. The command
structure is nsmv2migr -S.

-U Migrates user preference files. To migrate user preference files, the command
structure is nsmv2migr -U username1 <username2 . . . username#>. To
migrate all user preference files, the command structure is nsmv2migr -U
*ALL.

-G Migrates group preference files. To migrate group preference files, the
command structure is nsmv2migr -G groupname1 <groupname2 . . .
groupname#> To migrate all group preference files, the command structure is
nsmv2migr -G *ALL.

-T Migrates thin client preference files. To migrate thin client preference files,
the command structure is nsmv2migr -T NSname1 <NSname2 . . . NSname#>.
To migrate all thin clients, the command structure is nsmv2migr -T *ALL.

-P Specifies the directory path from which you can migrate. You specify the
root directory path for the old V1R3 preference files. This flag can specify a
directory path from the same server (single-server migration), or another
server (dual-server migration) that is connected via a LAN to your server.
When you do not specify a directory path, the migration utility looks for the
preference files in your current server. To migrate preference files from
another server, the command structure is nsmv2migr -P <drive:\nstation>.
Note: If you plan to run a dual-server migration by using this parameter,
make sure that you created your V1R3 user information on your new V2R1
server. Otherwise, the dual-server migration will not migrate your V1R3
preference files. Refer to “Dual-Server Migration” on page 41 and follow
Steps 1 to 3.

-C Client migration for all Series 1000 (8362 - all models) and Series 300
(8361-110 and 8362-210). Since this flag forces all of your Series 1000 (8362 -
all models) and Series 300 (8361-110 and 8362-210) thin clients to start from
the V2R1 software, you should use this option with caution. To migrate your
thin clients to V2R1, the command structure is nsmv2migr -C. Refer to “Client
Migration” on page 44 for testing instructions.

Notes:

1. This parameter only applies to NVRAM thin client clients. You can only
use this option in a single-server migration, where V1R3 and V2R1 are
both installed on the same server.

2. Running the migration utility with this parameter does not affect Series
100 thin clients and Series 300 Twin-Axial thin clients (8361-341
machine-type) on your network.

The following are examples of how to run the migration utility with the different
parameters:

Example 1: dual-server migration of preference files for system defaults, two users, one
group and a thin client

nsmv2migr -P j:\nstation -S -U John Jane -G NSMAdmin -T NSAlpha
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This migration utility command migrates system preferences, user preference files
of John and Jane, group preference files of the NSMAdmin group, and thin client
preference files of the NSAlpha thin client from another computer. The server that
is running the migration utility has a mapped network connection to the
[drive]:\nstation directory of the other computer via a LAN for the old
preference files. This directory appears as network drive and directory,
j:\nstation, on the current server.

Example 2: single-server migration of preference files for system defaults, all users, and two
thin clients

nsmv2migr -S -U *ALL -T NSDelta NSBeta
This migration utility command migrates system preferences, preference files for
all users, and thin client preference files for thin clients NSDelta and NSBeta.
V1R3 is installed on the same server where you are running migration.

Example 3: single-server migration of preference files for system defaults and two groups
nsmv2migr -S -G artdept newsdept
This migration utility command migrates system preferences and preference files
of the artdept and newsdept groups. V1R3 is installed on the same server where
you are running migration.

Example 4: single-server migration of all thin client NVRAM clients
nsmv2migr -C
This migration utility command migrates all NVRAM thin client clients, except
Series 100 (all models) and Series 300 Twin Axial (8361-341). V1R3 is installed on
the same server where you are running migration.

Client Migration
You run client migration when you have thin clients that were previously
supported in V1R3 but you now plan to operate using V2R1. These are Series 1000
(8362 - all models) thin clients and Series 300 (8361-110 and 8362-210) thin clients.

You run client migration after you complete preference file migration. It is
advisable that you run client migration only once.

Client Migration for DHCP clients
To move your existing DHCP thin clients5 to your new IBM Network Station
Manager V2R1 software, follow these instructions:
__ 1. Install and configure DHCP as instructed in “Configuring DHCP for your

network” on page 33.
__ 2. In your current DHCP configuration, set the following DHCP options so

that the following values apply to all of your thin clients:
v Option 66: IP address of the boot server
v Option 67: /NetworkStationV2/prodbase/ppc/[your kernel filename]

Refer to Table 7 on page 34 for the correct kernel filename.
__ 3. Configure DHCP option 211 as a global parameter with the value ″nfs″ or

″tftp″.

5. If you support Series 100 thin clients or Series 300 Twin-Axial thin clients, you must continue to support these thin clients in
V1R3 on a Windows NT server. If you start these thin clients through DHCP, you must configure a separate class for these DHCP
thin clients. See the Microsoft DHCP online help for more information. Specify V1R3 values when you configure DHCP options
for this class so they can continue to operate using V1R3.
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Notes:

a. If you select ″tftp″ as your boot protocol, the kernel downloads via the
TFTP protocol. The thin client then switches to the NFS protocol for all
other data transfers.

b. Option 211 does not exist on the Microsoft DHCP interface. To create a
new DHCP option while using Microsoft DHCP, refer to “Installing
Microsoft DHCP” on page 17.

__ 4. Restart one Series 1000 (8362 - all models) or Series 300 (8361-110 and
8362-210) thin client as a test client. The server automatically updates the
boot PROM of the thin client and the test client restarts automatically.

Note: Do not touch the thin client while the thin client boot PROM updates.
If you interrupt the boot PROM update, you have to replace the thin
client.

__ 5. If the test client has a token-ring adapter, it updates again and restarts
automatically.

__ 6. Restart the test client to check the DHCP configuration.
__ 7. If everything appears correctly on your test client, restart6 all of the

remaining thin clients that you plan to move over to the new V2R1 server.
__ 8. Test your thin clients to see if the user profile information is correct.

Client Migration for NVRAM thin clients
Follow these steps to move your existing NVRAM thin clients to IBM Network
Station Manager V2R1:
__ 1. Test one Series 300 thin client or Series 1000 thin client. Refer to Table 1 on

page 10 for the hardware type and model.
__ a. Power on your thin client.
__ b. Wait for the message ″NS0500 Searching for Host System″ to appear on

your monitor, and then press ESC to bring up the Setup Utility main
screen.
If password control is active, you must enter the case-sensitive
Administrator password.

__ c. From the Setup Utility main screen, press F3, Set Network Parameters.
__ 1) Enter the IP address of your new boot server in the First Boot

Host IP Address field.
If you did not change your boot server, or if you did not
perform a dual server preference file migration, the IP address
value here remains the same.

__ 2) Press Enter to save your changes.
__ d. From the Setup Utility main screen, press F4, Set Boot Parameters.

__ 1) Enter /NetworkStationV2/prodbase/ppc/ in the Boot Directory
field.

__ 2) Enter the correct kernel filename in the Boot File field. Refer to
Table 7 on page 34 for the correct filename for your test thin
client.

__ 3) Press Enter to save your changes.
__ e. From the Setup Utility main screen, press F5, Set Configuration

Parameters.

6. If you have several thin clients that you need to restart, you can restart these clients remotely by using a special command. Refer
to the IBM Network Station Manager Advanced Information publication for more information.
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__ 1) Enter /NetworkStationV2/userbase/profiles in the First
Configuration Directory field.

__ 2) Press Enter to save your changes.
__ f. From the Setup Utility main screen, press Enter to restart your test

thin client.
Your new V2R1 server automatically updates the boot PROM of your
thin client when your test thin client restarts.

Note: Do not touch the thin client during the boot PROM update. If
you interrupt the boot PROM update, you have to replace the
thin client.

__ g. Restart the test thin client.
__ h. Test your thin client to see if the preference information is correct.
__ i. If everything appears correctly on your test thin client, go to Step 2.

__ 2. From a Windows 2000 command prompt, run the migration utility by using
the client migration parameter7 (nsmv2migr -C). Refer to Table 9 on page 43
for the command syntax.

__ 3. Restart your thin clients.
The thin clients start from the new IBM Network Station Manager V2R1
software. The server may also automatically update the thin client boot
PROM so that the thin clients restart automatically.

Note: Do not touch the thin clients during the boot PROM update. If you
interrupt the boot PROM update, you have to replace the thin clients.

Each time you power on your thin clients, they start from the new IBM
Network Station Manager V2R1 software. Verify that the user preference
files on these thin clients are correct.

7. You can only use this option in a single-server migration, where V1R3 is still installed on your server. Running the migration
utility with this parameter does not affect Series 100 thin clients and Series 300 Twin-Axial thin clients (8361-341 machine-type) on
your network.
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Notices

This information was developed for products and services offered in the U.S.A.
IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
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programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
Software Interoperability Coordinator
3605 Highway 52 N
Rochester, MN 55901-7829
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurement may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrates programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM for the purposes of developing, using, marketing, or distributing application
programs conforming to IBM’s application programming interfaces.
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Trademarks
The following terms are trademarks of International Business Machines
Corporation in the United States, or other countries, or both:

AIX MVS
Application System/400 NetView
AS/400 NetVista
Client Access Network Station
DB2 On-Demand Server
eNetwork OpenEdition
IBM Operating System/400
IBM Network Station OS/390
IBM NetVista OS/400
InfoColor RS/6000
Information Assistant S/390
InfoPrint System/390
IPDS VM/ESA
Micro Channel 400

Lotus is a trademark of Lotus Development Corporation in the United States and
other countries.

Tivoli is a trademark of Tivoli Systems Inc. in the United States and other
countries.

Microsoft, Windows, Windows NT, Windows 2000, and the Windows logo are
trademarks of Microsoft Corporation in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

UNIX is a registered trademark in the United States and other countries licensed
exclusively through The Open Group.

Other company, product, and service names may be trademarks or service marks
of others.
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