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About Installing IBM Network Station Manager V2R1 on
Windows NT ® (SC41-0688)

Installing IBM Network Station Manager V2R1 on Windows NT (SC41-0688) provides
planning, installation, configuration, and migration information for the IBM
Network Station Manager Version 2 Release 1 licensed program (5648-C07),
hereafter referred to in this publication as IBM Network Station Manager, on a
Windows NT server.

IBM Network Station Manager V2R1 is also known as IBM NetVista™ Thin
Client Manager V2R1. This software enables a systems administrator to manage
and administer Network Stations and NetVista thin clients. For the purposes of
consistency, this publication uses the term thin clients to refer to both Network
Stations and NetVista thin clients.

Who should read this book
The person or group who installs and administers IBM Network Station Manager
on a Windows NT server should read this publication.

Information on the Internet
v You can find additional information about your thin client at the following URL:

http://www.ibm.com/pc/support

1. Click NetVista.
2. Click NetVista thin client.

v You can obtain the latest version of this information at the following URL:

http://www.ibm.com/nc/pubs

This is the same URL that is printed on the cover of this document.

Related information
The following information is available for IBM Network Station Manager:

Information name Information description

Installing IBM Network Station
Manager for AS/400®, SC41-0684

Describes the installation and simple configuration of an
AS/400 Network Station environment. It is shipped with
the IBM Network Station Manager licensed program.
Updates to this information are at
http://www.ibm.com/nc/pubs.

Installing IBM Network Station
Manager for RS/6000®, SC41-0685

Describes the installation and simple configuration of an
RS/6000 Network Station environment. It is shipped
with the IBM Network Station Manager licensed
program. Updates to this information are at
http://www.ibm.com/nc/pubs.
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Information name Information description

Installing IBM Network Station
Manager on Windows NT, SC41-0688

Describes the installation and simple configuration of a
Windows NT thin client environment. It is shipped with
the IBM Network Station Manager licensed program.
Updates to this information are at
http://www.ibm.com/nc/pubs.

Installing IBM Network Station
Manager on Windows® 2000, SA23-2811

Describes the installation and simple configuration of a
Windows 2000 thin client environment. Updates to this
information are at http://www.ibm.com/nc/pubs.

Using IBM Network Station Manager,
SC41-0690

Describes the basic tasks for managing user desktops
through the IBM Network Station Manager program. It
is shipped with the IBM Network Station Manager
licensed program. Updates to this information are at
http://www.ibm.com/nc/pubs.

IBM Network Station Advanced
Information

Describes tasks and information beyond a basic
installation and configuration of your Network Station
environment. This information is only available at
http://www.ibm.com/nc/pubs.

IBM Network Station Manager help text Describes the basic how-to tasks for configuring your
Network Station desktop appearance. This information is
availble by clicking the help icon in the IBM Network
Station Manager program.

Desktop help Describes how to use and operate the Network Station
desktop. This information is available by clicking the
help icon in the lower right of the Network Station
desktop.

How to send your comments
Your feedback is important in helping to provide the most accurate and
high-quality information. If you have any comments about this book or any other
documentation, fill out the readers’ comment form at the back of this book.
v If you prefer to send comments by mail, use the readers’ comment form with the

address that is printed on the back. If you are mailing a readers’ comment form
from a country other than the United States, you can give the form to the local
IBM branch office or IBM representative for postage-paid mailing.

v If you prefer to send comments by FAX, use either of the following numbers:
– United States and Canada: 1-800-937-3430
– Other countries: 1-507-253-5192

v If you prefer to send comments electronically, use this network ID:
– IBMMAIL, to IBMMAIL(USIB56RZ)
– RCHCLERK@us.ibm.com

Be sure to include the following:
v The name of the book.
v The publication number of the book.
v The page number or topic to which your comment applies.
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Overview
The IBM Network Station Manager licensed program code is made up of several
programs that are installed on a server. One of these programs is Network Station
Manager. Network Station Manager allows you to set and change configurations
for IBM thin clients (also referred to as Network Stations or NetVista thin clients)
and thin client users through a Web browser. See the Using IBM Network Station
Manager book for more information about the IBM Network Station Manager
program.

Since the thin client does not contain a hard drive, the Network Station accesses a
server to download the client operating system, client programs, and data. After
the thin client loads the client operating system, the thin client displays a graphical
user interface (GUI). The GUI can provide the user access to the following
resources:
v 5250 emulator application
v 3270 emulator application
v Telnet application
v Web browser application (Netscape Communicator)
v Java™ applets or applications
v Windows-based applications
v Local and remote printers

The thin client communicates using Transmission Control Protocol/Internet
Protocol (TCP/IP) over a token-ring connection or Ethernet connection to a server.
Each thin client runs the client operating system and communicates to a server that
runs Network Station Manager and other application programs.

Figure 1 on page 2 shows what happens when you power on a thin client.
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«1¬ A non-volatile random access memory (NVRAM) resident program starts. The
thin client automatically runs a series of power-on self tests (POST).

«2¬ The thin client contacts a DHCP boot server. The thin client exchanges its
media access control (MAC) address for the IP address that is provided by the
server. The boot server also provides the address or path of the base code server.
The thin client may alternatively retrieve this information from values that are
stored in its NVRAM.

«3¬ The thin client downloads the base code from the base code server using
trivial file transfer protocol (TFTP) or network file system (NFS).

«4¬ The thin client downloads the workstation-based configuration information
from the workstation configuration server.

«5¬ The thin client presents a logon screen. When the user enters a user id and
password, the authentication server verifies the user’s identification.

«6¬ The user’s configuration server downloads and initiates the personalized
environment preferences of the user.

«7¬ The thin client displays the personalized desktop of the user. The user is able
to access application programs that reside on the application server (or host
computer).

Each thin client contains a simple network management protocol (SNMP) agent as
part of its operating system. An SNMP manager at a central location can
communicate and exchange information with the agent on a thin client. You can

Figure 1. Thin client power-on sequence
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use this information to manage your network environment. SNMP is an
industry-standard protocol for network management. See IBM Network Station
Advanced Information for more information about SNMP. You can find this
document at http://www.ibm.com/nc/pubs.

Each thin client can display the IBM Network Station Setup Utility or IBM
Network Station NS Boot utility. The Setup Utility or NS Boot utility allows you to
View or Set (change) configuration settings on a particular thin client. For
example, you can view the MAC address or you can set the monitor resolution of
the thin client. See Using IBM Network Station Manager for more information about
the Setup Utility and NS Boot Utility.

TCP/IP overview
In order for the thin client to communicate with your servers, you need a TCP/IP
network. If you understand your TCP/IP network, installing and configuring your
thin client and Network Station Manager is much easier. To help understand your
network, draw a diagram of your network.

Refer to the network examples in this section to help you understand how to
configure your network. Choose the network example that most closely resembles
your network diagram. Refer to these examples as you configure and install
Network Stations on your network.

Note: You do not need to be an expert in order to set up a TCP/IP network.
However, you should have an understanding of basic TCP/IP. A detailed
introduction to TCP/IP is beyond the scope of this book. If you need to
improve your understanding of TCP/IP, you can contact your IBM sales
representative, who has information about classes in your area. You may
also want to refer to the redbook, TCP/IP Tutorial and Technical Overview,
GG24-3376.

LAN network examples

LAN network example 1
Figure 2 on page 4 shows an example of a network diagram in which two Network
Stations are connected over a simple local area network (LAN).
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LAN network example 2
Figure 3 shows an example of a network diagram in which two Network Stations
are connected to the server over a local LAN. Two more Network Stations connect
to the server through a router over a remote LAN.

LAN network example 3
In Figure 4 on page 5, additional Network Stations connect to the server by using
Ethernet connections and token-ring connections. Two token-ring LANs connect
via a router. A Domain Name Server (DNS) also connects to the network.

Figure 2. Two Network Stations connected to the server over a simple LAN

Figure 3. Two Network Stations connected to the server over a local LAN and two Network
Stations connected to the server through a router over a remote LAN
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MAC addresses
Every thin client comes with a unique identifying number that can be used to keep
track of which IP address has been assigned to it. Media access control (MAC)
addresses of each thin client are assigned by manufacturing and hard-coded into
the machine. The MAC address of a thin client is on the side panel of the small
box in which the logic unit is packaged. If you no longer have the box, see the
Using IBM Network Station Manager book for instructions on how to find the MAC
address.

You can override the hard-coded MAC address with a customer-assigned MAC
address. See Using IBM Network Station Manager for instructions on how to
override the hard-coded MAC address.

IP addresses
Internet Protocol (IP) addresses are numbers that are assigned to devices on a
network (or on the Internet). IP addresses allow computers to communicate
through TCP/IP. IP addresses consist of four numbers (from 0 to 255) that are
separated by periods, for example 192.168.1.1. The numbers that are separated by
periods indicate the network to which a computer belongs and the specific location
of the host computer within that network.

IP addresses are not just for computers such as Network Stations, but also for
routers, servers, and even subnets and networks themselves. For example, the IP
address of a network might be 192.168.1.0. A router on that network might use the
IP address 192.168.1.1. A thin client on the same network might have the address
192.168.1.145.

Figure 4. Four Network Stations connected to a network using a router and a domain name
server

Understanding the thin client 5



Each thin client must have a unique IP address. If you are using the DHCP boot
method, you must specify a range of IP addresses so that the server can assign an
address to each thin client. For intranets (networks within your own organization),
you can assign your own addresses. However, if you want to connect to the
Internet, a central authority must officially assign the network addresses and
domain names. At the time of this writing, the authority is as follows:
Network Solutions, Inc.
InterNIC Registration Services
505 Huntmar Park Drive
Herndon, VA 22070
1-703-742-4811
E-mail: hostmaster@internic.net
http://rs.internic.net

Boot methods
Since a thin client has no disk from which to start, it must request information
either from its own non-volatile random access memory (NVRAM) or from a
server. The thin client needs to find an IP address for itself. The IP address allows
the thin client to communicate with other hosts. The thin client can use one of the
following methods to request and receive this information:
v Dynamic Host Control Protocol (DHCP)
v Non-Volatile Random Access Memory (NVRAM)

Note: If you use the DHCP boot method, you must configure all routers and
gateways in your network to send and receive DHCP packets. If you cannot
configure your routers to be DHCP relay agents, you could do either of the
following:
v Use a system that has the necessary configuration support to receive

limited DHCP broadcasts. Then forward those broadcasts to the
appropriate server.

v Use the NVRAM boot method for those Network Stations that are behind
a router that cannot forward DHCP broadcasts.

DHCP
Dynamic Host Configuration Protocol (DHCP) is a TCP/IP protocol. DHCP
provides a way for a server to automatically allocate IP addresses and
configuration information without forcing the administrator to record and track the
MAC addresses of the networked computers. DHCP is capable of assigning either
a permanent IP address or a temporary IP address for every host or thin client
within a predetermined range of IP addresses. You can also use DHCP to assign IP
addresses either statically or dynamically.

In static IP address assignment, you define the MAC address of every thin client in
the DHCP server configuration along with an IP address, which is reserved for the
thin client with this MAC address. A thin client, identifying itself by its MAC
address, sends a request to the DHCP server. The server then returns the IP
address that it has reserved for that client.

In dynamic IP address assignment, the server still identifies a thin client by its
MAC address. However, instead of using a fixed IP address, the server allocates
any address out of the available pool. The server leases the address to the thin
client for a specified period of time. The address returns to the pool either when
the client releases it or when the lease runs out.
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DHCP can allow for unlisted clients. Any client, even one with an undefined MAC
address in the DHCP configuration, may request an IP address from the pool of
available addresses. The use of unlisted clients might be appropriate in an
environment in which it is not necessary or preferable to keep track of MAC
addresses.

DHCP servers can reuse IP addresses that are not currently being used.

Finally, DHCP provides a large set of configuration options that may include
user-defined options. These options are useful in configuring advanced network
environments. See IBM Network Station Advanced Information for a more in-depth
discussion of advanced network environments. You can find this document at
http://www.ibm.com/nc/pubs.

NVRAM
Non-Volatile Random-Access Memory (NVRAM) refers to local thin client memory.
When you use the NVRAM boot method, you code the IP addresses of the thin
client and its server into the memory of the individual thin client. The thin client
powers on and requests the download of the base code file from the server.

The NVRAM boot method is most practical in small, stable networks. You may
also choose to use the NVRAM boot method for one of the following reasons:
v As a method to avoid routers that block DHCP broadcast requests. DHCP

broadcast requests for IP addresses can create unnecessary traffic on the
network. Many network routers are configured not to pass these broadcast
requests. Since NVRAM does not need to request its IP address (because it has
been entered in the NVRAM of the Network Station), it does not make
broadcasts.

v As an aid in finding and correcting problems with network connections.
v As an aid in finding and correcting problems with DHCP configurations.

This method may not work well for larger networks for the following reasons:
v You must enter setup data into each thin client manually.
v DHCP can configure many more parameters that may not be easily configured

with this method.

For information about how to configure NVRAM in the Setup Utility or NS Boot
utility, see the Using IBM Network Station Manager book.

Boot file service
The thin client uses either TFTP or NFS to receive the base code file from the base
code server. Trivial file transfer protocol (TFTP) is a simple protocol that is used to
transfer files. The network file system (NFS) makes files and directories available
to clients. NFS is generally more reliable than TFTP.

Java on the Network Station
Java is a programming language that is designed to bridge the gap between
different platforms. Java’s imperative, ″Write once, run anywhere,″ refers to its
portability and to the ability of a single Java program to run on different platforms.
To view Java applications, you need a bundle of Java-enabling programs called
Java Virtual Machine (JVM). Using JVM on diskless clients such as the thin client
allows the user to access applications without using permanent disk space either
on the thin client or on the server.
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There are two kinds of Java programs:
v Applets — require a browser or applet viewer
v Applications — display directly

The first variety, applets, rely on a browser or applet viewer to provide windows
and graphical layout. In general, the browser does not “trust” applets because they
are downloaded across the Internet. In other words, the browser can restrict
applets from reading or writing to local files and from connecting to machines
other than those from which they are downloaded. These restrictions protect users
from virus-contaminated programs and provide a safe environment for examining
programs on the Internet.

See IBM Network Station Advanced Information for more information about Java. You
can find this document at at http://www.ibm.com/nc/pubs.

Windows applications on the thin client
Network Stations can run Windows-based applications through the use of a
multi-user Windows server. There are several products that can provide a
multi-user Windows server:
v Citrix WinFrame is a multi-user Windows application server that is based on

Windows NT 3.51. Citrix WinFrame communicates to the thin client by using the
independent computer architecture (ICA) protocol.

v NCD WinCenter is a multi-user Windows application product that requires
Citrix WinFrame or Microsoft® Windows NT Server 4.0, Terminal Server Edition.
NCD WinCenter communicates to the thin client by using the X11 protocol.

v Citrix MetaFrame is a multi-user Windows application product that is supported
by Microsoft Windows NT Server 4.0, Terminal Server Edition, and Microsoft
Windows 2000 Servers. Citrix MetaFrame communicates to the thin client by
using the ICA protocol.

Network Stations that start from a V1R3 or V2R1 IBM Network Station Manager
licensed program server can communicate to a multi-user Windows server using
the X11 protocol or the ICA protocol.

For more information, see the following Web sites:
v WinFrame and MetaFrame - http://www.citrix.com
v WinCenter - http://www.ncd.com
v Windows NT Server 4.0, Terminal Server Edition - http://www.microsoft.com
v Windows 2000 Servers - http://www.microsoft.com

Thin client memory requirements
Thin clients download each of their applications into memory. If you plan to run
multiple applications on your thin clients, verify that each thin client has adequate
memory to handle the projected applications. Subsequent releases of applications
may have increased memory requirements.

Follow these steps to verify that your thin clients have enough memory to run
their applications:
__ 1. Open your browser, and access the following URL:

http://www.pc.ibm.com/support
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__ 2. Click NetVista, and then click NetVista thin client.
__ 3. In the Search box, type memory requirements.

Taking advantage of multiple server environments
You can install the IBM Network Station Manager licensed program on multiple
computer systems. For a more in-depth discussion of this topic, see the IBM
Network Station Advanced Information. You can find this document at
http://www.ibm.com/nc/pubs.

New features in Version 2 Release 1
IBM Network Station Manager Version 2 Release 1 (V2R1) introduces many new
features. These features include:

Client desktop
The client desktop has a new look and includes the following:
v 16-bit color support
v Scalable fonts
v Desktop help
v Kiosk mode

For more information, see the Using IBM Network Station Manager book.

Netscape Communicator 4.5
Netscape Comunicator 4.5 includes the Navigator browser, and Messenger
(e-mail and news). The browser is fully compatible with other Unix
versions of Netscape Navigator. Key features that are new in this version
include:
v Netscape JVM
v Runtime Plug-in for the Network Station, Java Edition
v PDF helper application
v Real Player helper application
v Audio player helper application
v Video player helper application

For more information, see the Using IBM Network Station Manager book.

Windows application support
Enhanced ICA support. For more information, see the Using IBM Network
Station Manager book.

VT emulator
Enhanced VT emulator. For more information, see the Using IBM Network
Station Manager book.

Productivity applications

v File manager
v Text editor
v Calendar
v Calculator
v Paint

For more information, see the Using IBM Network Station Manager book.

Understanding the thin client 9

http://www.ibm.com/nc/pubs


Java environments
The IBM Network Station Manager licensed program provides two JVMs:
v Netscape 4.5 JVM
v IBM JVM (JDK 1.1.8)

Flash memory support
Flash memory support provides the ability to boot locally from a flash
memory card and a flash memory management utility. For more
information, see IBM Network Station Advanced Information. You can find
this document at http://www.ibm.com/nc/pubs.

Hardware support

Table 1 shows the IBM thin client hardware by machine type, model
number, and series. It also shows which version and release of the IBM
Network Station Manager licensed program is required to support a
particular hardware machine type and model.

For example:
v Machine type 8364 model Exx requires V2R1
v Machine type 8362 model A22 is supported by either V2R1 or V1R3

Table 1. IBM thin client hardware types, models, and series

Compatible
release

Machine type - model

Series 100 Series 300 Series 1000 Series 2200 Series 2800

V2R1 only 8363-Exx
8363-Txx

8364-Exx
8364-Txx

both V2R1
and V1R3

8361-110
8361-210

8362-A22
8362-A23
8362-A52
8362-A53

V1R3 only 8361-100
8361-200

8361-341*

* Twinaxial model supported only on AS/400 servers.

Coexistence with V1R3
Windows NT, AS/400, and RS/6000 server environments can support
V2R1 coexistence with V1R3. You can install V2R1 on a system1 that runs
V1R3. The V2R1 installation does not affect the V1R3 environment. Both
V2R1 and V1R3 can coexist and operate on the same server. The ability to
have V2R1 and V1R3 coexist on the same server allows support for all thin
client hardware models.

1. Coexistence does not apply to Windows 2000 thin client environments. V1R3 is not supported on Windows 2000 servers.
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About this section
This section provides information on planning and running a typical installation
of IBM Network Station Manager V2R1 on a Windows NT server.

Planning the installation
Plan the installation of IBM Network Station Manager by identifying an applicable
upgrade path from the following table. To minimize errors and reduce installation
time, you can follow the upgrade paths that are recommended by IBM. An asterisk
(*) marks a recommended upgrade path.

Current server
environment

Upgrade goals Upgrade paths

* Fresh installation

A single, newly installed
Windows NT server

Install IBM Network
Station Manager for the
first time on the same
Windows NT server

1. Read important release information. See “Important
information” on page 12.

2. Ensure that your Windows NT server meets the server
requirements. See “Server requirements” on page 13.

3. Verify that your Windows NT server runs the
prerequisite software. See “Prerequisite software” on
page 14.

4. Install IBM Network Station Manager V2R1. See
“Running the installation” on page 15.

Single-server: operating system upgrade

A single Windows NT
server with IBM Network
Station Manager V2R1
installed

v Upgrade your Windows
NT server operating
system to Windows 2000
Server

v Maintain IBM Network
Station Manager V2R1
on the same server after
the operating system
upgrade

1. Refer to the Installing IBM Network Station Manager V2R1
on Windows 2000 online publication.

2. Refer to Microsoft documentation for Windows 2000
upgrade information.

* Dual-server: operating system upgrade
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Current server
environment

Upgrade goals Upgrade paths

v A single Windows NT
server with IBM
Network Station
Manager V2R1

v A single Windows 2000
server on which you
plan to maintain IBM
Network Station
Manager V2R1

v Move IBM Network
Station Manager V2R1
from the Windows NT
server to the Windows
2000 server

1. Refer to the Installing IBM Network Station Manager V2R1
on Windows 2000 online publication.

2. Refer to Microsoft documentation for Windows 2000
upgrade information.

Single-server: operating system upgrade and IBM Network Station Manager migration

A single Windows NT
server with IBM Network
Station Manager V1R3

Attention: If you have
thin clients that you need
to support with V1R3,
ensure that you maintain
V1R3 on a Windows NT
server.

v Upgrade your Windows
NT server operating
system to Windows 2000
Server

v Upgrade IBM Network
Station Manager from
V1R3 to V2R1 on the
same server after the
operating system
upgrade

1. Refer to the Installing IBM Network Station Manager V2R1
on Windows 2000 online publication.

2. Refer to Microsoft documentation for Windows 2000
upgrade information.

* Dual-server: operating system upgrade and IBM Network Station Manager migration

v A single Windows NT
server with IBM
Network Station
Manager V1R3

v A single Windows 2000
server on which you
plan to install IBM
Network Station
Manager V2R1

Attention: If you have
thin clients that you need
to support with V1R3,
ensure that you maintain
V1R3 on a Windows NT
server.

v Install IBM Network
Station Manager on the
Windows 2000 server

v Migrate V1R3 preference
files on the Windows
NT server to V2R1 on
the Windows 2000
server

1. Refer to the Installing IBM Network Station Manager V2R1
on Windows 2000 online publication.

2. Refer to Microsoft documentation for Windows 2000
upgrade information.

Important information
1. If you are migrating from IBM Network Station Manager V1R3, read the

information in “Migrating to your new IBM Network Station Manager release”
on page 47 before you start the IBM Network Station Manager V2R1

installation.
2. If you plan to separate various IBM Network Station Manager V2R1 functions

across your servers, refer to the IBM Network Station Advanced Information online
publication.

3. Read the readme.txt file on the IBM Network Station Manager installation CD
for important product release information.
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Server requirements
Verify that your Windows NT server meets these system requirements.

Table 2. Server Requirements

Server requirement How to check for the requirement

Your Intel-based server must run
any of the following operating
system software:

v Windows NT Server 4.0 with
Service Pack 4 (or higher) for
Windows NT Server 4.0

v Windows NT Server 4.0,
Terminal Server Edition with
Service Pack 4 (or higher) for
Windows NT Server 4.0,
Terminal Server Edition

To check for the operating system version:

1. From your Windows NT server desktop, click
Start->Settings->Control Panel->System.

2. Click the General tab.

3. Verify that the correct Windows NT Server
software is installed.

To check for the Service Pack version:

1. From your Windows NT server desktop, click
Start->Programs->Administrative
Tools->Windows NT Diagnostics.

2. Click the Version tab.

3. Verify that the correct Service Pack is installed.

Your server must be configured as
one of the following:

v Stand-alone server

v Domain member (member server
of a domain)

v Domain controller

IBM recommends the installation
and configuration of a thin client
environment on a stand-alone
server or a domain member server.

__ 1. From your Windows NT server desktop, click
Start->Settings->Control Panel->Network.

__ 2. Click the Identification tab.

__ 3. Verify that your server is a member of either a
domain or a workgroup.

Your server must have at least 500
MB of free hard disk space to
accommodate IBM Network Station
Manager and other required
software.

If you are installing IBM Network
Station Manager from the Internet,
you need an extra 250 MB of free
disk space. This extra disk space is
for downloading the software and
expanding the executable files on
your hard drive.

__ 1. From your Windows NT server desktop,
double-click on the My Computer icon.

__ 2. Right-click on the drive where you plan to
install IBM Network Station Manager.

__ 3. Select Properties, and click the General tab.

__ 4. Verify that you have enough free hard disk
space to accommodate the IBM Network
Station Manager software.

The file system of your server must
be NTFS.

__ 1. From your Windows NT server desktop,
double-click on the My Computer icon.

__ 2. Right-click on the drive where you plan to
install IBM Network Station Manager.

__ 3. Select Properties, and click the General tab.

__ 4. Verify that your file system is NTFS.
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Table 2. Server Requirements (continued)

Server requirement How to check for the requirement

Your server must have correct
regional settings.

__ 1. From your Windows NT server desktop, click
Start->Settings->Control Panel->Regional
Settings.

__ 2. Click the Regional Settings tab.

__ 3. Check to see if your locale is highlighted.

__ 4. Check Set as system default locale.

__ 5. Click Apply, and then click OK.

Prerequisite software
Verify that your Windows NT server runs the following prerequisite software:
v Any of the following web browsers:

– Netscape Communicator 4.5 or higher
– Microsoft Internet Explorer 5.0 or higher

v Any of the following web servers:
– Lotus Domino Go 4.6.2.2 or higher
– Microsoft Internet Information Server 5.0 (IIS) or higher

v Any of the following DHCP2 services:
– IBM DHCP
– Microsoft DHCP

Notes:

1. If you plan to upgrade your operating system to Windows 2000, you must
install and use IIS and Microsoft DHCP. The Windows 2000 thin client
environment does not support Lotus Domino Go Webserver and IBM DHCP.
Refer to the Installing IBM Network Station Manager V2R1 on Windows 2000
online publication for more information on prerequisite software for installing
IBM Network Station Manager on Windows 2000.

2. Microsoft does not support Microsoft Internet Information Server on Windows
NT Server 4.0, Terminal Server Edition.

3. You can use the IBM Network Station Manager installation CD to install
Netscape Communicator on your server.

4. You need the Windows NT Server installation CD to install these prerequisites.
Refer to Microsoft documentation for more information on installation and
configuration.
v Microsoft Internet Explorer 5.0
v Microsoft Internet Information Server 5.0
v Microsoft DHCP

Installing Microsoft DHCP
Follow these steps to install Microsoft DHCP:
__ 1. Insert the Windows NT installation CD into your CD-ROM drive.
__ 2. From your Windows NT server desktop, select Start->Settings->Control

Panel->Network->Services.
__ 3. Select the Services tab, and click Add.

2. Microsoft DHCP is not required if you plan to only use NVRAM to manage the network IP information for your thin clients.

14 Installing IBM Network Station Manager V2R1 on Windows NT



__ 4. Select Microsoft DHCP Server, and click OK.
__ 5. Follow the installation prompts.

Note: You may need to reinstall the correct Windows NT Service Pack after
you install Microsoft DHCP. Refer to Microsoft documentation for
more information.

Installing IBM DHCP
You can choose to install IBM DHCP automatically during the IBM Network
Station Manager installation.

To manually install the NDIS intermediate driver, follow these steps:
__ 1. Install the NDIS intermediate driver.

__ a. Insert the installation CD into your CD-ROM drive.
__ b. Wait for the autorun dialog box to appear. Exit from this window.
__ c. From your Windows NT server desktop, click Start->Settings-

>Control Panel->Network.
__ d. Select the Protocols tab, and click Add.
__ e. Click Have Disk.
__ f. Enter the directory path, [CD-ROM

drive]:\ntnsm\en\products\enod\ndis, and click OK.
__ g. Highlight IBM Intermediate Support Driver, and click OK.
__ h. Close the Network window.
__ i. Click Yes to restart your computer.

__ 2. Install IBM DHCP3.
__ a. Insert the IBM Network Station Manager CD into your CD-ROM

drive.
__ b. Wait for the autorun dialog box to appear. Exit from this window.
__ c. Run the command, [CD-ROM

drive]:\ntnsm\en\products\eNOD\tcpip\setup.exe, from the
Windows NT Run command box.

__ d. Click Next on the Welcome screen.
__ e. Select TCP/IP Services and click Change.
__ f. Select DHCP Server and DDNS Server only. Click Continue.
__ g. Review the current settings and make sure that the Setup program

lists down DHCP Server and DDNS Server under Selected
Components. Click Next to start copying files.

__ h. Select Finish to restart your computer and complete the IBM DHCP
installation.

Running the installation
These instructions pertain to a typical installation of IBM Network Station
Manager V2R1 on a Windows NT server.

3. You can use these instructions to install DHCP services on a separate server. For more information on separation of servers, refer
to the IBM Network Station Advanced Information publication.
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Attention: If you choose another type of installation, some screens4 of the setup
program may not appear. For more information on a custom installation, a base
code server installation, or an authentication server installation, refer to the IBM
Network Station Advanced Information online publication.

Follow these steps to install IBM Network Station Manager on your Windows NT
server:
__ 1. Verify that there are no active users that are logged onto your server.
__ 2. Close all programs, restart your computer, and log in as administrator.
__ 3. Insert the IBM Network Station Manager CD into your CD-ROM drive.
__ 4. Select the language for the CD installation program.
__ 5. Select Install IBM Network Station Manager V2.
__ 6. Select Run Installation.
__ 7. Select the language for the installation, and click OK.
__ 8. Click Next on the Welcome window.
__ 9. Select Yes to accept the license agreement.
__ 10. The Setup program checks for any existing version of IBM Network Station

Manager.
a. If the setup program finds IBM Network Station Manager V1R3 on

your server, the Important Coexistence Information window appears.
This window briefly describes coexistence and other installation
options. Read the information on this window carefully. Click Next to
continue.

b. Setup then asks if you would like to uninstall the existing version of
IBM Network Station Manager. Select Yes if you would like to uninstall
it. Otherwise, select No.

Notes:

a. The Important Coexistence Information window does not appear if you
do not have any existing version of IBM Network Station Manager on
your server.

b. If Setup finds a software release older than IBM Network Station
Manager V1R3 on your server, Setup ends and prompts you to exit the
installation program. You can download the latest V1R3 software from
http://www.ibm.com/nc. Refer to the V1R3 readme.txt file for
installation instructions of V1R3.

c. For more information on migration and coexistence, refer to “Migrating
to your new IBM Network Station Manager release” on page 47.

__ 11. Click Next to install IBM Network Station Manager in the default
directory.5

__ 12. Select Typical Install, and click Next.

Notes:

a. For general information on the types of installation, refer to “Types of
Installation” on page 17.

4. The Migration Location window does not appear if you select a Custom Install or a Base Code Server installation. If you select
Custom Install, and if you plan to migrate your V1R3 preference files to V2R1, you should run a manual migration. Refer to the
IBM Network Station Advanced Information online publication, and “Migrating to your new IBM Network Station Manager release”
on page 47 for more information.

5. If you use TFTP to start your thin clients, you must install in the default directory.
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b. For technical information on a custom installation, a base code server
installation, or an authentication server installation, refer to the IBM
Network Station Advanced Information online publication.

__ 13. Click Next to add icons to the default program folder.
__ 14. Select one of the following options, and click Next.

v Select Yes to migrate your V1R3 preference files to V2R1, and enter the
location of the V1R3 user preference files in the source directory box.

v Select No if you are not migrating any V1R3 preference files during the
current installation.

__ 15. Click Next to install eNetwork On-Demand Server (eNOD) in the default
directory.

__ 16. Select any additional options to install, and click Next.
__ 17. Click Next to accept the current settings.

The setup program stores your installation settings in a log file,
[drive:]\NetworkStationV2\instops.txt.

__ 18. Click Yes to begin copying files.
The setup program installs the components and options you selected on
your server.

__ 19. Click Finish to complete the setup program.

If you have additional software components to install, refer to “Installing the
strong encryption (128-bit) products” on page 19.

If you encountered errors during the installation, refer to “Resolving installation
problems” on page 20.

To configure your thin client environment, read “Configuring a thin client
environment” on page 29.

Types of Installation

Type of Installation Description

Typical Install Provides a full installation of IBM Network Station Manager
that supports authentication and base code functions. A typical
install is the equivalent of an Authentication Server installation
and a Base Code Server installation. This option installs the
Network Station Files and Server Files of IBM Network Station
Manager in the language of the default locale.

Custom Install
(advanced users only)

Lets you select and specify individual components of IBM
Network Station Manager for installation.

Notes:

1. This option may require additional configuration on your
server after installation. Refer to the IBM Network Station
Advanced Information online publication for more information.

2. For a general description of each component, read
“Components of IBM Network Station Manager” on page 18.
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Type of Installation Description

Authentication Server Authenticates users and lets you configure IBM Network Station
Manager settings for each user. This option installs the Server
Files.

Notes:

1. Refer to the IBM Network Station Advanced Information online
publication for more information.

2. For a general description of the Server Files, read
“Components of IBM Network Station Manager”.

Base Code Server Sets up TCP/IP services, and lets you run application programs
on your thin clients. This option installs the Network Station
Files.

Notes:

1. Refer to the IBM Network Station Advanced Information online
publication for more information.

2. For a general description of the Network Station Files, read
“Components of IBM Network Station Manager”.

Components of IBM Network Station Manager
1. Network Station Files include programs that allow you to run your thin client

applications. Network Station Files have the following main components:
v Components for Series 2800 and Series 2200

These include subcomponents for both Series 2800 and Series 2200 thin
clients.

v Components for Series 1000 and Series 300
These include subcomponents for both Series 1000 and Series 300 thin clients.

Each of these two main components includes installable subcomponents.
Table 3 briefly describes each of these subcomponents.

Table 3. Subcomponents of Network Station Files

Component Name Description

Network Station
Operating System

The kernel or operating system controls the operations of your
thin clients.

ICA Client and Remote
Application Manager

ICA enables thin clients to run Windows-based programs. ICA
lets you see and work with the Windows-based user interface
of a program while the application runs on the server.

Terminal Emulation
Software

This program allows you to run 5250, 3270, and VT terminal
sessions on your thin clients.

Netscape Communicator On the thin client, the Netscape Communicator browser
functions as a client by sending requests for information and
displaying the information for the user. You also use Netscape
Communicator to access and configure your thin clients.

Network Station Java
Virtual Machine (JVM)

JVM provides your thin clients with a Java runtime
environment that enables loading of Java-based applications.

Network Station Complete
Font Support

This component installs the entire collection of system fonts
for your thin clients.

National Language
Support

This program allows you to run IBM Network Station
Manager in your preferred language.
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2. Server Files include programs that your server runs to manage your thin
clients. Server Files have the following main components:
v Network Station Manager Program

Network Station Manager allows you to configure and manage your thin
clients from a server.

v Network Station Login Service
This program allows you to authenticate users and start login access on your
thin clients.

v Common Server Files
These are components that support IBM Network Station Manager.

Supported languages
Table 4. Supported Languages and Language Designators

UNIX
Language

Designator

Language Language
Designator

Language

da_DK Danish in Denmark fr_CH French in Switzerland

de_CH German in Switzerland fr_FR French in France

de_DE German in Germany it_CH Italian in Switzerland

en_GB English in Great Britain it_IT Italian in Italy

en_US English in the United States nl_BE Dutch in Belgium

es_ES Spanish in Spain nl_NL Dutch in The Netherlands

es_LA Spanish in Latin America no_NO Norwegian in Norway

fi_FI Finnish in Finland pt_BR Portuguese in Brazil

fr_BE French in Belgium pt_PT Portuguese in Portugal

fr_CA French in Canada sv_SE Swedish in Sweden

Installing the strong encryption (128-bit) products
Customers from countries that allow strong encryption product imports have the
option of installing the strong encryption (128-bit) products that are included in the
IBM Network Station Manager (strong encryption) installation CD. The strong
encryption (128-bit) products include the following:
v 128-bit Netscape Communicator browser
v Secure Sockets Layer (SSL shared library)
v 128-bit ICA Client and Remote Application Manager.

You can automatically install these products during the IBM Network Station
Manager installation by clicking Yes when the the setup program prompts you.

Follow these steps to manually install the strong encryption (128-bit) products:
__ 1. Insert the IBM Network Station Manager CD into your CD-ROM drive.
__ 2. Run the following command from the Windows NT Run command box:

[CD-ROM drive]:\ntnsm\en\products\nsm128\setup.exe

An installation wizard screen appears.
__ 3. Follow the prompts of the installation wizard to complete the installation.
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Uninstalling IBM Network Station Manager
Follow these steps to uninstall IBM Network Station Manager:
__ 1. Verify that there are no active users that are logged onto your server.
__ 2. Close all programs, restart your computer, and log in as administrator.
__ 3. Select Start-Settings-Control Panel-Add/Remove Programs.
__ 4. Select IBM Network Station Manager V2R1, and click Add/Remove.
__ 5. Follow the prompts of the wizard that appears.
__ 6. Click Finish to complete the uninstallation.

Resolving installation problems
If problems occur during the installation of IBM Network Station Manager, consult
Table 5 for an explanation of the installation error and the suggested steps to
resolve it. If the installation problem persists, contact IBM technical support.

Table 5. Common Installation Errors

Error message How do I resolve the error?

Cannot create an IBM Network
Station Manager user group.

The setup program did not create the NSMUser group or NSMAdmin group.

1. Exit the setup program.

2. Restart your server.

3. Run the setup program again.
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

Cannot configure Microsoft
Internet Information Server.

The setup program cannot configure Microsoft Internet Information Server 4.0.
Follow these instructions to configure it manually:

1. From your Windows NT server desktop, click Start->Programs-> Windows
NT 4.0 Option Pack->Microsoft Internet Information Server->Internet
Service Manager.

2. Select the Default website.

3. From the Actions menu, select New->Virtual Directory.

4. For Alias to be used to access virtual directory, enter networkstationv2.
Click Next.

5. For the path, enter [drive:]\{float}\NetworkStationV2\servbase\html.
Click Next.

6. Select Allow Read Access only. Click Finish.

7. Right-click networkstationv2 and select Properties.

8. Select the Documents tab.

9. Check enable Default Document.

10. Click Add and enter admin.htm.

11. Select the Directory Security tab and click Edit.

12. Check Basic Authentication (Password is sent in clear text.), and click OK.

13. Click OK.

14. Right-click networkstationv2.

15. Click New->Virtual Directory.

16. Repeat Steps 4 to 6 with the following values:
Alias = admin and cgi (2 aliases with the same

values)
Path = [drive:]\{float}\NetworkStationV2\servbase\cgi-bin

17. Select Allow execute access (includes script access) only.

18. Repeat Steps 7 to 13 for admin. For step 9, enter nsmcgain.exe.

19. Repeat Steps 2-13 with the following values:
Alias = flashconfigs
Path = [drive:]\{float}\NetworkStationV2\userbase

\flash\ImageConfigs

20. Select Allow Read Access only. Click Finish.

Cannot find file system. The drive or partition where you plan to install IBM Network Station Manager
may be damaged.

Select a fixed drive for the IBM Network Station Manager installation.

Cannot install the IBM Network
Station Login Service.

The setup program cannot install the IBM Network Station Login Service.

1. Make sure that you configured your Network Adapter card correctly. Your
Network Adapter card should work properly before installing IBM Network
Station Manager.

2. Make sure that your network cable is plugged in correctly.

3. Restart your server.

4. Run the setup program again.

Cannot obtain the Domain
Controller name.

The setup program cannot locate the Domain Controller name for your
Windows NT server.

Verify that your Windows NT Domain Controller is responding to requests and
is accessible from the network.
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

Corrupted AS/400 Integrated PC
Server Registry.

The required PTF is not installed on the Integrated Netfinity® Server. This PTF
fixes a registry compatibility problem with the installation of the NDIS
intermediate support driver.

1. Exit from the setup program.

2. Restart your server.

3. Refer to the V2R1 readme.txt file for the PTF name.

4. Apply the required PTF.

5. Run the setup program again.

Error configuring DHCP. Configure DHCP manually. Refer to “Configuring DHCP for your network” on
page 32 for instructions.

Error configuring NFS. The setup program cannot configure NFS properly.

Follow these steps to configure NFS manually:

1. From your Windows NT server desktop, click Start->Programs->eNetwork
On Demand Server->NFS Server Configuration.

2. Select the Directories tab and click Add.

3. Enter [drive:]\{float}\NetworkStationV2\userbase in the Directory field.

4. Enter /NetworkStationV2/userbase/ in the Alias field.

5. Select Allow hosts read and write access, and click Add.

6. Click Add.

7. Enter [drive:]\float\NetworkStationV2\prodbase in the Directory field.

8. Enter /NetworkStationV2/prodbase/ in the Alias field.

9. Select Allow hosts read-only access, and click Add.

10. Select the Users tab, and click Add.

11. Select NSMNFS_User, and click Add.

12. Select NSM_NFSRoot.

13. From the pulldown menu, click File->Save

Error configuring TFTP. The setup program cannot configure TFTP properly. Configure TFTP properly.
Follow these instructions:

1. From your Windows NT server desktop, click Start->Programs->eNetwork
On Demand Server->TFTP Server Configuration.

2. Enter [drive:]\{float}\NetworkStationV2\prodbase in the Directory field,
and click Add.

3. From the pulldown menu, click File->Save.
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

Error creating user directories. The setup program did not create some or all of the following directories:

/NetworkStationV2/userbase
/NetworkStationV2/userbase/profiles
/NetworkStationV2/userbase/profiles/groups
/NetworkStationV2/userbase/profiles/ncs
/NetworkStationV2/userbase/profiles/users

/NetworkStationV2/userbase/nsmshared
/NetworkStationV2/userbase/nsmshared/kiosk

/NetworkStationV2/userbase/home/
/NetworkStationV2/userbase/home/kiosk

/NetworkStationV2/userbase/flash/

The setup program did not create some or all of the following base permissions:

v Full Control for Administrators, NSMAdmin, and SYSTEM

v Read for NSMUser

Follow these steps:

1. Exit from the setup program.

2. Restart your server.

3. Run the setup program again.

v Error launching eNetwork™

On-Demand Server installation.

v Error creating input file for
eNetwork On-Demand Server
installation.

The setup program cannot install eNOD properly.

Install the eNOD services manually. Follow these instructions:

1. Insert the IBM Network Station Manager CD into your CD-ROM drive.

2. Wait for the autorun dialog box to appear. Exit from this window.

3. Run the command, [CD-ROM
drive]:\ntnsm\en\products\eNOD\tcpip\setup.exe, from the Windows NT
Run command box.

4. Follow the installation instructions.

5. Select Finish to restart your computer and complete the eNOD services
installation.

Error updating path environment
variable.

The setup program cannot add the necessary entries to the system path.

Add IBM Network Station Manager to the system path manually. To update the
path environment variable manually, follow these instructions:

1. From your Windows NT server desktop, click Start->Settings->Control
Panel->System.

2. Click the Environment tab.

3. Under System Variables, select Path.

4. Append [drive:]\{float}\NetworkStationV2\servbase\bin to the end of the
current value of your path variable.

5. Click Set, and then click OK.

Error while trying to synchronize
the /etc/hosts file.

This file was not correctly set up. Use the following sample to replace this file
manually:

Example for:

[drive:]\{float}\NetworkStationV2\prodbase\ppc\etc\hosts
[drive:]\{float}\NetworkStationV2\prodbase\x86\etc\hosts
127.0.0.1 localhost
9.3.159.186 starscream starscream.austin.ibm.com

Format: <Server IP Address> <computer name> <fully qualified computer
name>
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

File system is not NTFS. The drive or partition where you plan to install IBM Network Station Manager
must be formatted using NTFS.

1. Exit from the setup program.

2. Select a fixed drive that uses the NTFS file system, or switch the current
drive to NTFS.

3. Run the setup program again.

Installation was unable to
configure the /etc/resolv.conf file.

This file was not correctly set up. Use the following sample to replace these files
manually:

Files to be replaced:

[drive:]\{float}\NetworkStationV2\prodbase\ppc\etc\resolv.conf
[drive:]\{float}\NetworkStationV2\prodbase\x86\etc\resolv.conf

Format:

domain <domain name>
search <domain name 1> . . . <domain name n>
nameserver <name server IP address>

. . . nameserver <name server IP address>
lookup file bind

Example:

domain rchland.ibm.com
search rchland.ibm.com ibm.com
nameserver 12.34.56.78
nameserver 12.34.56.89
nameserver 12.34.56.90
lookup file bind

Migration internal error. Run the
migration utility from the
command line.

An invalid parameter was used to run migration.

1. Check the Windows NT Application Event Log for more information.

2. Refer to Table 11 on page 53 for valid migration parameters.

3. Run the migration utility from the command line.

Migration utility initialization
failed. Run the migration utility
from the command line.

An invalid parameter was used to run migration, or the migration program did
not complete successfully.

1. Check the Windows NT Application Event Log for more information.

2. Refer to Table 11 on page 53 for valid migration parameters.

3. Run the migration utility from the command line.

Migration utility parameter not
valid. Run the migration utility
from the command line.

An invalid parameter was used to run migration.

1. Check the Windows NT Application Event Log for more information.

2. Refer to Table 11 on page 53 for valid migration parameters.

3. Run the migration utility from the command line.

NDIS Driver failed to install. The setup program cannot find the path to install the IBM NDIS Intermediate
Driver automatically.

Install the NDIS intermediate driver manually. See “Installing IBM DHCP” on
page 15 for instructions.

Network File System (NFS) failed
with the following error:

An error occurred while setting NFS permissions. See the NSM_NFS_Error.txt
for more information. Contact IBM Technical Support.
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

NFS user creation error. The setup program cannot create an NFS User for the Network Station.

Create this user manually. Refer to “Creating Users and Groups in Windows
NT” on page 29 for instructions.

North American (128-bit)
encrypted products installation
error.

This error appears if you are using the North American version of the IBM
Network Station Manager installation CD. The installation cannot install the
128-bit strong encryption products.

Install the 128-bit strong encryption products manually. Refer to “Installing the
strong encryption (128-bit) products” on page 19 for instructions.

Not enough Free Space on Disk. You need at least 500 MB of free disk space to install IBM Network Station
Manager on your server.

1. Exit from the IBM Network Station Manager setup program.

2. Free up some disk space or select another fixed drive with enough free disk
space.

3. Run the IBM Network Station Manager setup program again.

Setup cannot install the IBM
NDIS Intermediate Driver 3.0.

The IBM Network Station Manager setup program cannot install the IBM NDIS
Intermediate Driver automatically.

Install the NDIS intermediate driver manually. See “Installing IBM DHCP” on
page 15 for instructions.

The drive chosen is not a fixed
drive. Choose another install
location.

The setup program cannot install IBM Network Station Manager on a remote or
network drive.

Select a fixed drive for the IBM Network Station Manager installation.

The following error occurred
during Setup. Error: 100

The V1R3 Network Station Login Service was not removed successfully.

Disable the V1R3 Network Station Login Service. Refer to “Starting and
Stopping Servers and Services” on page 42 for instructions.

The following error occurred
during Setup. Error: 101

The IBM Network Station Manager setup program cannot migrate the IBM
Network Station Login Service to V2R1.

Disable the V1R3 Network Station Login Service. Refer to “Starting and
Stopping Servers and Services” on page 42 for instructions.

The following error occurred
during Setup. Error: [102 to 115]

The program used to automatically syncronize the language initial locale
preference for the Network Station login encountered an error. The language
preference for the client login needs to be set properly.

A utility program can be run to automatically set this preference. This program
is in [drive]:\{float}\NetworkStationV2\servbase\bin ({float} is a subdirectory).

You can run this program from a Windows NT command prompt. The
command is:

nsmutlds -v ll_CC

where ll_CC is the 5 digit language designator for the client login language.
Refer to “Supported languages” on page 19 for more information.

If this utility does not run successfully, contact IBM technical support.
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

Unknown client synchronization
error.

The setup program was unable to configure following files. Use the following
samples to replace these files manually.

Files to be replaced:

[drive:]\{float}\NetworkStationV2\prodbase\ppc\etc\hosts
[drive:]\{float}\NetworkStationV2\prodbase\x86\etc\hosts

Format:

<server IP address><computer name><fully qualified computer name>

Example:

12.34.56.01 localhost
12.34.56.78 starscream starscream.rchland.ibm.com

Files to be replaced:

[drive:]\{float}\NetworkStationV2\prodbase\ppc\etc\resolv.conf
[drive:]\{float}\NetworkStationV2\prodbase\x86\etc\resolv.conf

Format:

domain <domain name>
search <domain name 1> . . . <domain name n>
nameserver <name server IP address>

. . . nameserver <name server IP address>
lookup file bind

Example:

domain rchland.ibm.com
search rchland.ibm.com ibm.com
nameserver 12.34.56.78
nameserver 12.34.56.89
nameserver 12.34.56.90
lookup file bind

User not authorized to run setup
and migration. User must belong
to the NSMAdmin group. Run
the migration utility from the
command line.

A user that belongs to the NSMAdmin group should run migration.

1. Check the Windows NT Application Event Log for more information.

2. Restart your server.

3. Login as a user that belongs to the NSMAdmin group.

4. Run the migration utility from the command line.

V1R3 migration source directory
does not exist or V1R3 not
installed on this server. Run the
migration utility from the
command line.

The setup program cannot locate the V1R3 preference files on your server, or the
source directory location specified was not accessible.

1. Check the Windows NT Application Event Log for more information.

2. Verify the directory location of IBM Network Station Manager V1R3.

3. Run the migration utility from the command line.

V1R3 uninstall error. The setup program was unable to automatically uninstall IBM Network Station
Manager V1R3.

Uninstall this product manually by using Add/Remove Programs from the
Windows NT Control Panel.
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Table 5. Common Installation Errors (continued)

Error message How do I resolve the error?

WARNING: Previous version
found:

The setup program detected an earlier version of IBM Network Station Manager.

1. Exit from the IBM Network Station Manager setup program.

2. Download Version 1 Release 3.08 (V1R3 Service Update 8) from
http://www.ibm.com/nc.

3. Upgrade IBM Network Station Manager Version 1 Release 2.0 to IBM
Network Station Manager Version 1 Release 3.08 to preserve user
preferences.

4. Restart your server.

5. Run the IBM Network Station Manager setup program again.
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About this section
This section provides information on configuring a thin client environment on
Windows NT.

Planning the configuration
To configure a thin client environment on your Windows NT server, you must
complete the following tasks:
v Add a user account to the NSMUser group for the thin client user.
v Configure your DHCP settings.

Managing users in a single Windows NT domain
IBM Network Station Manager assigns administrative control and sets directory
permissions by using Windows NT local groups. The IBM Network Station
Manager setup program creates the NSMUser and NSMAdmin local groups on
your server.

You must define each thin client user in your network and add each thin client
user to the NSMUser group. To limit administrative control, you should put the
user in the NSMUser group only. To assign full administrative control, include the
user in both the NSMUser and the NSMAdmin groups.

IBM Network Station Manager supports the Single Domain Model. If you installed
IBM Network Station Manager on a Member Server of a domain, you should
create your users on a Primary Domain Controller. You can add these users to the
NSMUser group on the Member Server later. This setup eliminates duplication of
users and makes future expansion of your network easier.

Creating Users and Groups in Windows NT
When you add a user account, or create a group and add users to it, observe the
following restrictions for user names, group names, and passwords:
v User names and group names nust not be identical to Windows NT domain

names or server names.
v Names cannot be more than 20 characters long.
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v Names must be subsets of ″invariant ASCII″ or the English alphanumeric set.
They may not contain any of the following elements:

Double-byte characters
Characters above ASCII 33 and below ASCII 27
Control characters
Spaces or tabs
Any of the following characters:
Forward slash (/)
Backward slash (\)
Colon (:)
Semicolon (;)
Asterisk (*)
Question mark (?)
Quotation mark (″)
″Greater than″ symbol
″Less than″ symbol
Brackets ([, ])
Plus sign (+)

To create users or groups in your Windows NT server, follow these instructions:
__ 1. From your Windows NT server desktop, click Start->Programs-

>Administrative Tools (Common)->User Manager for Domains.
__ 2. From the pulldown menu, select User.
__ 3. If you are creating a new user, select New User. If you are creating a new

group, select New Local Group.
To manually create the NSMUser group or NSMAdmin group, follow these
instructions:
__ a. Select New Local Group.
__ b. Enter NSMUser or NSMAdmin in the Group Name field.
__ c. Click OK.
__ d. Make sure that the NSMUser or NSMAdmin group appears on the

list of groups on the main window.
__ e. Continue to “Adding Users and Groups in Windows NT” to add

users to the NSMUser group or NSMAdmin group.
__ 4. Set up a user account or group account by entering information in the input

fields. Click OK when completed.
__ 5. Make sure that the newly created user or group appears on the list of users

or groups on the main window.

Adding Users and Groups in Windows NT
To add domain users or groups to the local NSMUser group or NSMAdmin group,
follow these instructions:
__ 1. From your Windows NT server desktop, click Start->Programs-

>Administrative Tools (Common)->User Manager for Domains.
__ 2. Double-click on the NSMUser group or NSMAdmin group.
__ 3. Click Add.
__ 4. Make sure that the correct domain is visible in the List Names From box.
__ 5. Highlight the domain user or group and click Add.
__ 6. Click OK to close the Add Users and Groups window.
__ 7. Click OK to close the Local Group Properties window.
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If you would like a user with full administrative authority, you need to add the
user name to the Domain Admins global group. You can add this group to your
user name from the Primary Domain Controller.

Managing users in a Windows NT trusted domain
Multiple domains allow you to store accounts and access resources from other
domains. IBM Network Station Manager also supports the Single Master Domain
Model. If your network has a single master domain, you can share resources
through a trust relationship. A trust relationship allows one domain to share its
resources to other domains.

Figure 5 illustrates a one-way trust relationship between a resource domain and a
user accounts domain. The trusting domain is the resource domain. The trusting
domain allows the users and groups from the user accounts domain to use the
trusting domain’s resources. The trusted domain, which is also known as the
Master domain, is the user accounts domain. This domain includes the users and
groups who are allowed to use the trusting domain’s resources.

To eliminate duplication of users and efficiently manage your network, you should
define all users and groups on a Primary Domain Controller in the Master domain.
You can then install IBM Network Station Manager on a Member Server of the
resource domain. You then establish a trust relationship between the two domains
in the Primary Domain Controller of the trusted domain which is the user accounts
domain. After you set up the trusting domain that can trust the user accounts
domain, you then specify the trusted domain from the resource domain.

To set up a trust relationship from the trusted domain, follow these instructions:
__ 1. From your Windows NT server desktop, click Start->Programs-

>Administrative Tools->User Manager for Domains.
__ 2. Click Policies and select Trust Relationships.

Figure 5. Trust Relationship between Two Domains

Configuring a thin client environment 31



__ 3. A window from the trusted domain appears. Enter the name of the trusting
domain. Enter a password for the trust relationship. Click OK.

__ 4. A window appears showing you that the trusting domain is added to the
Trust Relationships box. Click Close.

To set up the trusted domain from the trusting domain, follow these instructions:
__ 1. From your Windows NT server desktop, click Start->Programs-

>Administrative Tools->User Manager for Domains.
__ 2. Click Policies and select Trust Relationships.
__ 3. Enter the name of the trusted domain. Enter the password for the trust

relationship. Click OK.
__ 4. A window appears showing you that the trusted domain is added to the

Trust Relationships box. Click Close.

After you set up the trust, add users and groups to the NSMUser group or the
NSMAdmin group on the Member Server of the trusting domain. To add domain
users or global groups from the trusted domain to the Member Server of the
trusting domain, follow these instructions:
__ 1. On the Member Server of the trusting domain, click Start->Programs-

>Administrative Tools (Common)->User Manager for Domains.
__ 2. Double-click on the NSMUser group.
__ 3. Click Add.
__ 4. Make sure that the Master Domain (trusted domain) is visible in the List

Names From box.
__ 5. Highlight the domain user or global group and click Add.
__ 6. Click OK to close the Add Users and Groups window.
__ 7. Repeat these steps to add domain users or global groups to the NSMAdmin

group.

If you would like a user with full administrative authority, you need to add the
user name to the Domain Admins global group. You can add this group to the
user name from the Primary Domain Controller on the Master Domain.

On the Member Server of the trusting domain, the IBM Network Station Manager
Login Service searches for the domain user on the local machine. If the Login
Service finds the domain user, the Login Service attempts to log the domain user
in. The Login Service stops searching for the domain user even if the login attempt
is unsuccessful.

If you have identical user names set up on both the trusting domain and the
trusted domain, the Login Service logs in and authenticates the user name that is
found on the trusting domain.

Configuring DHCP for your network
DHCP is a sophisticated tool for managing your network. A careful, well-thought
out DHCP configuration can make a network run effectively. Whenever you make
changes to your network configuration, you must ensure that the DHCP
configuration reflects those changes. Read “DHCP” on page 6 for additional
information about DHCP.

Collect the following information about your network before configuring DHCP.
Record your information in Table 6 on page 33.
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Table 6. Gathering DHCP Information

DHCP Option
Number

Field Description Write Your Network Value
Here

Defining DHCP Options

Option 1 Subnet Mask A value that enables network devices to direct
packets of information accurately in a subnet.

Option 3 Router IP
Address (Default
Gateway)

The IP address of the default router to which
TCP/IP packets which are not addressed to your
network will be sent.

Option 6 Domain Name
Server (IP
Address)

Delivering the Domain Name Server IP address
to clients allows them to use either fully qualified
host names or IP addresses when they
communicate with other devices.

Option 15 Domain Name The domain name allows the thin client to
specify its domain to other devices. For example,
in a network where the fully qualified host name
is server.mycompany.com, the domain name is
mycompany.com.

Option 66 Trivial File
Transfer Protocol
(TFTP) Server
Name (TFTP or
NFS)

The IP address of the server from which the thin
client downloads its operating system. This
option serves the operating system kernel using
both NFS and TFTP. NFS is the recommended
download protocol. Enable the NFS download
with Option 211.

Option 67 Boot File name The name of the file that contains the thin client
operating system. Refer to Table 7 on page 34 for
the appropriate boot file name.

/NetworkStationV2/
prodbase/[x86 or ppc]/[your
kernel filename]
Note: This is the NFS
pathname. Refer to Table 7 on
page 34 for the correct
directory path and kernel file
name.

Option 211 Base Code
Server Protocol

This option sets the protocol used for the
operating system kernel download. Specify this
option to enable Option 66 to serve the kernel
using NFS.

nfs

Defining the Subnet Options

N/A Subnet Address
(Subnet IP
Address)

The IP address associated with a particular
subnet. For Class C networks whose subnet mask
is 255.255.255.0, the subnet address is the same as
the network address.

N/A Start DHCP Pool
Address (IP
Range From)

The first IP address in the range which you have
specified for your pool of available addresses.

N/A Last DHCP Pool
Address (IP
Range To)

The last IP address in the range which you have
specified for your pool of available addresses.

Table 7 on page 34 specifies the directory path and boot file name for the different
thin client hardware models.
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Table 7. Boot File Name for the thin client hardware

Hardware Series (Type-Model) Boot File Name

Series 2800 (8364 - all models) /NetworkStationV2/prodbase/x86/kernel.2800

Series 2200 (8363 - all models) /NetworkStationV2/prodbase/x86/kernel.2200

Series 1000 (8362 - all models) /NetworkStationV2/prodbase/ppc/kernel.1000

Series 300 (8361-110 and 8361-210) /NetworkStationV2/prodbase/ppc/kernel.300

Configuring IBM DHCP on your Windows NT server

Important
Before you begin the IBM DHCP configuration, read the following notes:
v If you plan to use IBM DHCP, you must ensure that the device driver

associated with your LAN adapter card is compatible with the NDIS
Intermediate Driver. Refer to the installation readme.txt file for known
incompatibilities.

v If you chose to install IBM DHCP during the IBM Network Station
Manager installation, the setup program automatically configures the IBM
DHCP service with a sample subnet for your thin clients. If your server has
an existing IBM DHCP configuration, Setup creates two example files that
you may look at to configure DHCP manually.
– [drive:]\OnDemand\SERVER\ETC\v2r1dhcpext.cfg
– [drive:]\OnDemand\SERVER\ETC\v2r1dhcpsd.cfg

The v2r1dhcpext.cfg file provides a list of DHCP options necessary to start
and run a thin client in V2R1. The v2r1dhcpsd.cfg file is a sample DHCP
subnet configuration for thin clients.

To configure a simple IBM DHCP network setup, follow these instructions:
__ 1. Complete Table 6 on page 33.
__ 2. Stop the IBM DHCP service. Refer to “Starting and Stopping Servers and

Services” on page 42 for instructions.
__ 3. From your Windows NT server desktop, click Start->Programs->eNetwork

On-Demand Server->DHCP Server Configuration.
The following screen appears:
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__ 4. Define your global DHCP options.
__ a. From the main menu, click File->New.
__ b. Highlight Global and click Configure->Modify selected item from

the main menu.
__ c. The Global Parameters window opens. Click the DHCP Options tab.

The following screen appears:

__ d. In the Available Options list, select the DHCP options from Table 6
on page 33 and enter your corresponding network values in the

Option Value window. Click OK to go back to the main screen.
__ 5. Define a subnet within your global configuration.

__ a. Highlight Global and click Configure->Add Subnet from the main
menu.

Figure 6. Main eNOD DHCP Configuration Window

Figure 7. Defining Global DHCP Options
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The Subnet Parameters window appears with the Subnet Definition
tab selected.

__ b. Enter your network values from Table 6 on page 33 in the appropriate
input fields.
v Specify a range of IP addresses that DHCP can assign to your thin

clients.
v Enter a lease time in which a client may use an IP address.
v Specify a range of excluded IP addresses.

To exclude an IP address, enter the IP address in the IP address
field. Click Add.
Exclude IP addresses of any devices on your network whose IP
addresses are permanent or fixed to avoid address conflicts in your
network. Exclude the IP addresses of the following devices:
– Boot servers, configuration servers, http servers, domain name

servers
– Routers and network printers
– thin clients that start using NVRAM

__ c. Click the DHCP Options tab.
__ d. In the Available Options list, select the DHCP options from Table 6

on page 33 and enter your corresponding network values in the
Option Value window. Any values you enter at this point override
values that you specified previously. Click OK to go back to the main
screen.

__ 6. Click File->Save to save your settings.
__ 7. Start the IBM DHCP service for your changes to take effect. Refer to

“Starting and Stopping Servers and Services” on page 42 for instructions.

Creating a Class for your thin clients
Most organizations typically have a mixed network composed of thin clients,
personal computers, and UNIX workstations. To simplify DHCP configuration for

Figure 8. Defining a Subnet
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thin clients that access two different servers to download the operating system and
the kernel file, you create a class for your thin clients.

You can create a separate class for each hardware model of thin clients in your
network. Thus, when a client that belongs to a thin client class reaches the DHCP
server, it receives the necessary and appropriate information to access its kernel.

To create a class, follow these instructions:
__ 1. Stop the IBM DHCP service. Refer to “Starting and Stopping Servers and

Services” on page 42 for instructions.
__ 2. Based on your organization’s network setup, decide where you want to

create the class, whether within your global configuration or subnet
configuration.

__ 3. In the main eNOD DHCP configuration window, click Global if you plan
to create the class outside of a subnet. If you are creating the class within a
subnet, click the appropriate subnet.

__ 4. From the main menu, click Configure->Add class.
The following screen appears:

__ 5. Enter the correct class value in the text field. Refer to Table 8.

Table 8. IBM thin client DHCP Classes

Hardware Series (Type-Model) Class

Series 2800 (8364-EXX) IBM 8364-EXX

Series 2800 (8364-TXX) IBM 8364-TXX

Series 2200 (8363-EXX) IBM 8363-EXX

Series 2200 (8363-TXX) IBM 8363-TXX

Series 1000 (8362-A52) IBMNSM A.5.0

Series 1000 (8362-A53) IBMNSM A.5.0

Series 1000 (8362-A22) IBMNSM A.2.0

Figure 9. Adding a Class
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Table 8. IBM thin client DHCP Classes (continued)

Hardware Series (Type-Model) Class

Series 1000 (8362-A23) IBMNSM A.2.0

Series 300 (8361-210) IBMNSM 1.1.0

Series 300 (8361-110) IBMNSM 2.1.0

__ 6. Enter the range of IP addresses that the server can assign to your thin
clients in this class.

__ 7. Click the DHCP Options tab.
__ 8. In the Available Options list, select the DHCP options from Table 6 on

page 33 and enter your corresponding network values in the Option Value
window. Values you enter at this point override values that you specified
previously. Click OK to go back to the main screen.

__ 9. Click File->Save to save your settings.
__ 10. Start the IBM DHCP service for your changes to take effect. Refer to

“Starting and Stopping Servers and Services” on page 42 for instructions.

Assigning a Static IP Address to a thin client in a DHCP
Environment
You can configure DHCP to assign a static IP address to a client (such as a thin
client that is attached to a network printer). When the client requests an IP address
from the server, the server assigns the same IP address to the defined client.

To create an individual client at the global level, follow these instructions:
__ 1. Stop the IBM DHCP service. Refer to “Starting and Stopping Servers and

Services” on page 42 for instructions.
__ 2. Click Global on the main eNOD Configuration window.
__ 3. From the main menu, click Configure->Add Client.

The Client Parameters window appears with the Client Definition tab
selected.

Figure 10. Defining a Client with a Fixed IP Address
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__ 4. Enter the following information in the appropriate input fields.
v Enter the computer name of the thin client in the Client name field.
v For Client hardware type, choose 1 Ethernet (10 MB) for Ethernet

machines or 6 IEEE 802 Networks for token-ring machines.
v The client ID is the MAC address of the thin client.
v Click Assign this address and enter an IP address for the thin client.

__ 5. Select the DHCP Options tab.

__ 6. In the Available Options list, select the DHCP options from Table 6 on
page 33 and enter your corresponding network values in the Option Value
window. Values you enter at this point override values that you specified
previously. Click OK to go back to the main screen.

__ 7. Click File->Save to save your settings.
__ 8. Start the IBM DHCP service for your changes to take effect. Refer to

“Starting and Stopping Servers and Services” on page 42 for instructions.

When you make changes to your network, make sure to update your DHCP
configuration. To change an existing configuration for global, subnet, class, or
client levels, highlight the object in the main window and choose
Configure->Modify selected item.

Creating DHCP Options on IBM DHCP
For advanced configurations, you may need to configure DHCP options which do
not appear in the list of options on the DHCP interface. For more information on
advanced DHCP configurations, refer to the IBM Network Station Advanced
Information publication.

To create a DHCP option, follow these instructions:
__ 1. From your Windows NT server desktop, click Start->Programs->eNetwork

On-Demand Server->DHCP Server Configuration.
__ 2. Click Global.
__ 3. Select Configure->Modify selected item from the main menu.

Figure 11. Specifying DHCP Options for a Client with a Fixed IP Address
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__ 4. Click DHCP Options tab.
__ 5. Click New.
__ 6. Fill in the Create New Option screen.
__ 7. Once you have created your DHCP option, click OK to return to the main

DHCP configuration page.
__ 8. Highlight Global or the class, subnet, or client for which you want to

configure your new DHCP option.
__ 9. Select the new DHCP option that you created and enter the appropriate

information.
__ 10. When you are finished, click OK to save your changes and then exit the

DHCP configuration utility.

Configuring Microsoft DHCP on your Windows NT server
To configure Microsoft DHCP, follow these instructions:
__ 1. Complete Table 6 on page 33.
__ 2. From your Windows NT server desktop, click Start->Programs-

>Administrative Tools->DHCP Manager from your server’s desktop.
__ 3. In the DHCP Manager window, select Server from the main menu. Click

Add.
__ 4. Enter the IP address of the server which will act as the DHCP server.
__ 5. In the left pane of the main DHCP Manager window, highlight your server.
__ 6. In the DHCP Manager window menu bar, select Scope->Create.
__ 7. In the Create Scope window, enter the pool of available IP addresses for

your thin clients. If you have many thin clients, you can create two or
more scopes to accommodate your clients.

__ 8. Enter the following information in the Create Scope window:
v Start Address: This is the first address in the range of available IP

addresses for the scope. It is part of the range.
v End Address: This is the last address in the range of available IP

addresses for the scope. It is also part of the range.
v Subnet Mask: Enter the subnet mask for this scope.
v Exclusion Range: If any addresses within the scope belong to a device

with a fixed6 IP address, exclude this IP address from the scope.
Enter the following two values under the Exclusion Range:
– Start Address: Type the first IP address to exclude from your scope.

Click Add to enter it in the Excluded Addresses box.
– End Address: Type the last IP address to exclude from your scope.

Click Add to enter it in the Excluded Addresses box.
v Lease Duration: You can specify the length of time your thin clients use

their assigned IP addresses. Choose a workable lease time. thin clients
automatically renew their own leases when they pass half of their lease
time.

__ 9. Click OK after entering all of the required information on the Create Scope
screen.

__ 10. Choose Activate Now to activate the scope.

6. Examples of devices whose IP addresses are fixed include the DHCP server, DNS servers, routers, and thin clients that do not use
DHCP to start. If you leave those addresses in the range, the DHCP server might assign them to another thin client.
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__ 11. In the main DHCP Manager window, highlight the scope that you just
created.

__ 12. Select DHCP Options from the menu bar and choose from among Scope,
Global, or Defaults.

Notes:

a. If you select Global, the options apply to every client on your network.
b. If you select Scope, the options apply to all of the clients in the scope

that you have highlighted.
c. Do not select Default. If you do, a standard set of options takes effect

which will not allow you to start your thin clients.
__ 13. Once you select a group of clients, you must specify which options you

want to configure for the selected group of clients. To configure DHCP
options, carry out the following steps:
__ a. In the Unused Options box, select the DHCP options from Table 6

on page 33. Option Value window. Click OK to go back to the main
screen.

__ b. Once you have highlighted an option, click Add.
__ c. If you an option requires a value (like an IP address), click Value.

Enter your corresponding network values. If the option requires an
array of values (such as a range of IP addresses), click Edit Array.
Enter the required information, click Add, and then click OK.

__ d. Once you have configured your DHCP options, click OK.
__ 14. Repeat this process for additional scopes that you would like to create.
__ 15. If you want to reserve an IP address for an individual client, you can do so

by carrying out the following steps:
__ a. In the DHCP Manager window, highlight the scope in which you

want the new client to exist.
__ b. From the DHCP Manager window menu bar, select Scope->Add

Reservations.
__ c. Enter the following information in the Add Reserved Clients

window:
v IP Address: Enter the IP address that you want to reserve for this

thin client. The address may be outside the range of the scope that
you highlighted.

v Unique Identifier: The unique identifier is the MAC address of the
thin client.

v Client Name: Enter the computer name of the thin client.
v Client Comment: Use this optional field to enter an administrative

comment.
__ d. Click Add.
__ e. Click Close to return to the main DHCP Manager window.
__ f. From the menu bar, select Scope->Active Leases.
__ g. The client that you just created should now appear in the Active

Leases window.
__ h. Highlight the client that you just created.
__ i. Click Properties.
__ j. Select Options.
__ k. Enter options for this client as you did before for the scope.
__ l. Click OK.
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__ 16. Your Microsoft DHCP server is ready to start thin clients. See the Using
IBM Network Station Manager publication for instructions on how to
configure your thin clients to start using DHCP.

Creating DHCP Options on Microsoft DHCP
For advanced configurations, you may need to configure DHCP options which do
not appear in the list of options on the DHCP interface. For more information on
advanced DHCP configurations, refer to the IBM Network Station Advanced
Information publication.

To create a DHCP option, follow these instructions:
__ 1. Open the DHCP interface by selecting Start->Programs->Administrative

Tools->DHCP Manager.
__ 2. Highlight the group of clients to which you want the new option to apply

(global, scope, or client).
__ 3. Select DHCP Options from the main menu.
__ 4. Choose Defaults.
__ 5. In the Option Class list, select Standard Option Types.
__ 6. In the Name box, type a new option name. The name should be descriptive

of the function that the option adds to your configuration.
__ 7. In the Data Type list, click the data type for the option. The data type is

the way that the system reads the option value information.
__ 8. In the Identifier box, type a unique number to associate with the option.
__ 9. In the Comment box, enter a brief description about the new option. For

example, a comment might read, Protocol to use for terminal configuration
information.

__ 10. Enter the value for the DHCP option in the Value box.
__ 11. After configuring your new option, click OK to save your changes and exit

the configuration utility.

Starting and Stopping Servers and Services
Ensure that you start your servers and services so that your network runs
smoothly. There are several servers and services that must be running:
v Lotus Domino Go Webserver or Microsoft Internet Information Server
v IBM or Microsoft DHCP server
v IBM TCP/IP Services
v NFS server or TFTP server
v Ethernet adapter or token-ring adapter
v Network Station Login Service Version 2

To start or stop a service, follow these instructions:
__ 1. From your Windows NT server desktop, click Start->Settings->Control

Panel->Services.
__ 2. Select the server or service which you want to start or stop.
__ 3. If you are starting a service, click Start. If you are stopping a service, click

Stop.

To enable your Ethernet adapter or token-ring adapter, follow these instructions:
__ 1. From your Windows NT server desktop, click Start->Settings->Control

Panel->Network->Adapters.
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__ 2. Select the network adapter of your server.
__ 3. To enable the adapter, click Start. To disable the adapter, click Stop.

Configuring Printers for your thin clients
You can configure printers for your thin clients with IBM Network Station
Manager. In order to configure printing successfully, you have to identify the
datastreams that your printer understands. If an application produces a datastream
other than what your printer can understand, you might not get a printed output.
See the Using IBM Network Station Manager publication for more information on the
datastreams that the common thin client applications produce.

Figure 12 illustrates a typical network printing setup.

Table 9 explains the basic steps to configure printers for your thin clients. Identify
the scenario that best meets your needs and follow the instructions to configure
your printers.

Table 9. Configuration Descriptions for Basic Printer Scenarios

Print Scenario Print Job Flow in
Figure 12

Configuration Instructions

thin client to a LAN
printer

thin client A to Printer
1

1. In IBM Network Station Manager, access the following path
from the right-side menu: Hardware->Printers.

2. Configure an entry in the Remote Printer Server field for the
LAN printer.

thin client to a locally
attached printer

thin client B to Printer
5

1. In IBM Network Station Manager, access the following path
from the right-side menu: Hardware->Printers.

2. Configure an entry in the Local Parallel Printer or the Local
Serial Printer field, depending on how the printer connects to
the thin client.

Figure 12. Possible Printing Scenarios
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Table 9. Configuration Descriptions for Basic Printer Scenarios (continued)

Print Scenario Print Job Flow in
Figure 12 on page 43

Configuration Instructions

thin client to another
thin client with an
attached printer

thin client A to thin
client B to Printer 5

1. In IBM Network Station Manager, access the following path
from the right-side menu: Hardware->Printers.

2. Configure an entry in the Remote Printer Server field with the
IP address of the thin client to which the printer is attached. In
the Queue name field, type PARALLEL1 or SERIAL1, depending on
how the printer connects to the thin client.

Windows NT Server
4.0 to a thin client
with an attached
printer

Windows NT Server
4.0 to thin client B to
printer 5

1. Insert the correct Windows NT Server installation CD into
your CD-ROM drive.

2. Click Start->Control Panel->Network.

3. Click the Services tab.

4. Highlight Microsoft TCP/IP Printing and click Add.

5. Select Microsoft TCP/IP Printing.

6. Click OK to close the current window.

7. Restart your server.

You may need to reinstall the Windows NT Service Pack.

8. Start the thin client.

9. From your Windows NT server desktop, click My
Computer->Printers->Add Printer.

10. Select My Computer and click Next.

11. Select Add Port.

12. Highlight LPR Port and click on New Port.

13. In the Add LPR Compatible Printer window, enter the name
or IP address of the thin client to which the printer is attached.
Enter the name of the printer or print queue (SERIAL1 or
PARALLEL1) on that server. Click OK.

14. Specify PCL, ASCII, or PostScript in IBM Network Station
Manager for this printer. The default is PostScript.

15. Click Close->Next.

16. In the Add Printer wizard window, select the manufacturer
and model of the printer that is attached to the thin client.

17. Click Next.

18. Select whether you want to share your printer.

19. Print a test page to confirm proper setup.

Printer Administration Techniques
Administrating a printer environment is a difficult task. You should create a printer
network diagram. From this network printing diagram, you can develop a printing
strategy that best meets your printing needs. Under the right conditions, Network
Stations can print to most types of printers.

Controlling print jobs through your Windows NT server
One technique to consider is to have a server control the printers for your Network
Stations. In Figure 12 on page 43, the Windows NT server could control a LAN
printer like Printer 4. Network Station A and Network Station B send their print
jobs to the Windows NT server. The Windows NT server controls the flow of print
jobs to the printer.
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Advantages Disadvantages

This scenario reduces the work load on the
Network Stations when the printer buffer is
full because the Windows NT server
negotiates print jobs with the printer.

Handling these print jobs may likely
decrease the CPU performance of your
Windows NT server, depending on the size
and frequency of your print jobs. Your end
users may notice that it takes longer for
them to receive their printouts.

Since you would send the print job from a
Network Station, to a server, and then to a
printer, this technique would increase
network traffic, too.

To have a server control your Network
Station printing is advantageous in an
environment with mixed printer
datastreams. Since Network Station
applications produce certain datastreams,
you may need to send print jobs to a server.
The server processes the print job and
transforms it into a datastream that your
printer understands. Depending on which
application creates the job, you may or may
not need to transform your print jobs.

To eliminate confusion, you should consider
having all print jobs sent to the server
regardless of whether the job needs
transforming or not.

In the end, you will have fewer printer
entries in IBM Network Station Manager
and fewer printer device descriptions on the
server.

This may require more administration in
IBM Network Station Manager and on the
server.

Your end users would also need to have a
better understanding of printing and
networking.

Sending print jobs directly to the printer
The other technique is to set up your printing strategy so that your Network
Stations send their print jobs directly to the printer. You reduce printing time since
the print job goes directly to the printer. Your server does not bear the load of
controlling print jobs. Sending your print jobs directly to the printer also reduces
the chance of lost or damaged print jobs. When a server misinterprets a print job,
the job may become lost or damaged.

Before you continu e . . .
v To ensure correct operation and to take advantage of new functionality, verify

and update the boot code of your Network Stations to the latest level. Even if
you have new Network Stations, you must verify and update the boot code of
your Network Stations. For more information about updating the boot code, see
the Using IBM Network Station Manager publication.

v For Series 300 and Series 1000 Network Stations, if you use the NVRAM boot
method, you must enable DNS support through IBM Network Station Manager.
To enable DNS support, see the Using IBM Network Station Manager publication.

v The information in the NS Boot Utility (Series 2800 and Series 2200) or Setup
Utility (Series 1000 and Series 300) of your Network Stations must agree with
your boot method. See the Using IBM Network Station Manager publication for
more information.

Configuring a thin client environment 45



v Verify that you started your DHCP server, HTTP server, and either NFS server
or TFTP server. Refer to “Starting and Stopping Servers and Services” on page 42
for instructions.

v Verify that you excluded any statically addressed devices in your DHCP IP
address range.

v If you have a router between your Network Stations and your boot server, verify
that your router can handle DHCP requests.

v For more information about setting up Network Stations, see the Using IBM
Network Station Manager publication.
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About this chapter
This chapter provides instructions for migrating your IBM Network Station
Manager V1R3 preference files and your existing Network Stations to IBM
Network Station Manager V2R1.

The Windows NT Application Event Log documents the status of the migration. If
you encounter problems while running migration, refer to “Resolving installation
problems” on page 20 for error resolution.

If you manually changed any configuration files in the past, refer to the IBM
Network Station Manager Advanced Information publication for information on
migrating these configuration files.

You should read this entire chapter before you take any steps to migrate your files.
Preference file migration and client migration are complex processes. Do not try to
migrate your preference files without reading the sections below.

Important Considerations
If you plan to migrate from V1R3 to V2R1, read the following information:
v If you need to update your software with V1R3 Service Update 8, you can

download V1R3 Service Update 8 from http://www.ibm.com/nc. Service
Update 8 includes both IBM Network Station Manager Release 3.08 software and
updated eNetwork On-Demand software.

v You can migrate your V1R3 preference files to V2R1 during the IBM Network
Station Manager installation, or by running the V2R1 migration utility from a
Windows NT command prompt after the IBM Network Station Manager
installation. Migration during installation requires that you have V1R3 Service
Update 8 installed on the server from which you are migrating.

v If you plan to install V2R1 on your server and maintain V1R3 support for your
Network Stations, you need to install V1R3 Service Update 8.

v If you are migrating your V1R3 preference files to V2R1 on the same server
where you installed V1R3 and where you store your preference files, run a
single-server migration. If you are migrating your preference files from one
server to another server, you can do a dual-server migration. Install V2R1 on
your second server before attempting a dual-server migration.

v Typically, you group Network Stations that use different boot methods to start
up and obtain their kernel files from your server into two client groups.
NVRAM Network Station clients and DHCP Network Station clients use
different client migration methods to migrate to V2R1. You use the migration
utility to migrate NVRAM Network Station clients to V2R1. You change the
DHCP configuration to migrate DHCP Network Station clients to V2R1.
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v If you have different Network Station hardware on your network, you have to
decide which software release should support a particular Network Station. To
find out if V2R1 supports a specific Network Station machine type-model,
consult Table 1 on page 10. If you find that you need both V2R1 and V1R3 to
support your hardware, you may choose to operate both V2R1 and V1R3
through coexistence.

Coexistence
If you have Network Stations that operate only in the V1R3 environment, you need
to maintain V1R3 on your server. The coexistence feature of IBM Network Station
Manager V2R1 allows both V2R1 and V1R3 to coexist and operate on the same
server.

Coexistence requires V1R3 Service Update 8. If you are using a release earlier than
V1R3 Service Update 8, update your current software with Service Update 8.

These are the features of the Coexistence option:
v You use the V2R1 login service to login and authenticate your Network Stations.
v You have two IBM Network Station Manager program interfaces. Each interface

has its own URL.
v You have two directory structures for IBM Network Station Manager on your

server.
v You may need to reconfigure DHCP or NVRAM to point to the V2R1

environment. Refer to “Client Migration” on page 54.
v You have two sets of preference files. You may need to configure users in both

the V1R3 and the V2R1 environments.
v You should refer to V1R3 documentation for information about V1R3 and V2R1

documentation for V2R1 information.

If you operate both software versions on the same server, you can run the V2R1
migration utility to specify which Network Stations should operate using V2R1.
You also have to change your DHCP and NVRAM configurations such that your
Network Stations start from V2R1 software. You can perform this migration on a
per Network Station basis.

Migration to V2R1
To migrate your old IBM Network Station Manager environment to V2R1, you
carry out two tasks. First, you move your preference files to V2R1 (preference file
migration). There are two ways in which you can perform preference file
migration. You can run automatic migration during your installation of IBM
Network Station Manager V2R1, or you can perform manual migration by running
the migration utility from the Windows NT command prompt. After you migrate
your preference files, you then configure your Network Stations to start and
operate from the new V2R1 software (client migration).

Preference File Migration
If you choose to migrate during installation (automatic migration), the migration
utility performs complete migration to V2R1 for all of your V1R3 preference files.
These include preference files for users, groups, Network Stations, and system
defaults. For more information on migration during installation, refer to “Migration
during Installation” on page 49.
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If you choose not to migrate during installation, Setup installs V2R1 on your
server. Your V1R3 environment remains unchanged.

If you choose to migrate after running the IBM Network Station Manager
installation program, you can perform manual migration. You can manually
migrate individual preferences or Network Stations by using command-line
instructions. You run the migration utility from the Windows NT command
prompt to accomplish migration in stages. The command-line interface allows you
to specify an individual user, group, or Network Station for migration. For more
information on manual migration, refer to “Manual Migration” on page 52.

The migration utility migrates other individual preferences when you run
migration. These include 3270/5250 emulators, browser files, login files, V1R3
suppression of login (kiosk) files, and all other files in the user or group directory.
When the migration utility migrates the old V1R3 browser files, it renames the old
V1R3 NC Navigator browser files, bookmarks.html and address-book.html, to
v1r3_bm.htm and v1r3_ab.htm, respectively. The migration utility saves these files
under the Network Station user’s
/NetworkStationV2/userbase/home/[username]/.netscape directory. If you want
to continue using your V1R3 browser preference information, you must import
these files.

To import your bookmarks file, follow these instructions:
__ 1. Start your Network Station’s Netscape Communicator browser.
__ 2. From the main menu, click Communicator->Bookmarks->Edit Bookmarks.
__ 3. From the main menu of the Bookmarks window, click File->Import.
__ 4. Select the v1r3_bm.htm file. Click Open.

To import your address book file, follow these instructions:
__ 1. Start your Network Station’s Netscape Communicator browser.
__ 2. From the main menu, click Communicator->Address Book.
__ 3. From the main menu of the Address Book window, click File->Import.
__ 4. Select an import format and click Next.
__ 5. Select the v1r3_ab.htm file. Click Open.

Preference file migration, whether automatic or manual, is one-way (V1R3 to
V2R1). You cannot migrate subsequent changes in V2R1 back to V1R3. Languages
and keyboards that were available in V1R3 may not be available in V2R1.

Although you can run the migration utility several times, it is advisable that you
run migration only once. If you make changes to the V1R3 environment after
running migration, you can remigrate these changes to V2R1 by running migration
again. This overwrites any V2R1 changes since the previous migration. Each time
migration runs, this process overwrites any settings that were configured in V2R1
prior to running migration again.

Migration during Installation
The IBM Network Station Manager Setup program runs automatic migration when
you choose to migrate during installation. Automatic migration requires V1R3
Service Update 8. If you are using a release earlier than V1R3 Service Update 8,
update your current software with Service Update 8.

Migrating to your new IBM Network Station Manager release 49



Single-Server Migration
If you have one IBM Network Station Manager server that you wish to completely
migrate to V2R1, you should perform a single-server automatic migration.

Table 10 explains the two methods of migrating all of your preference files during
a single-server automatic migration.

Table 10. Software Update Methods for Single-Server Automatic Migration

Software Update Method Use in this Situation

Standard Simple upgrade of IBM Network Station Manager from
V1R3 to V2R1 and complete migration of all V1R3
preference files to V2R1.

Media-assisted v When you change the server type (for example, from a
PDC to a Stand-Alone Server).

v When you reinstall the Windows NT operating system.

To do a single-server automatic migration, follow these instructions:
__ 1. If you are using the standard method, skip to Step 2. If you are using the

media-assisted method, copy all the files from the following V1R3
directories onto a diskette or other storage media:
v [drive:]\{float}\nstation\userbase
v [drive:]\{float}\nstation\prodbase\configs ({float} is a subdirectory)

__ 2. Install the IBM Network Station Manager by following the instructions in
Step “Running the installation” on page 15.

__ 3. On the Migration Location window of the IBM Network Station Manager
Setup program, click Yes to confirm that you are migrating.

__ 4. On the same window, Setup prompts you to select the location of the V1R3
preference files. If you are using the standard method, skip to Step 5. If you
are using the media-assisted method, skip to Step 6.

__ 5. The default location of the V1R3 preference files appears on the source
directory box. Make sure that the directory location of your old user
preference files appears correctly in the source directory box. Click Next to
continue with the installation. Skip to Step 7.

__ 6. Enter the disk drive letter and the subdirectory where Setup can access the
preference files. This path is [drive:]\nstation\. Make sure that the
directory of your old user preference files appears correctly in the source
directory box. Click Next to continue with the installation.

__ 7. Installation completes and migrates your V1R3 preference files to V2R1. You
should move your existing Network Stations to your new IBM Network
Station Manager V2R1 software. Refer to “Client Migration” on page 54.

Dual-Server Migration
If you have more than one Windows NT Server in your network, you can run
dual-server migration to migrate your current V1R3 user preference files and
update your V1R3 software. Your current Network Station users can operate off the
old server until you configure and test the new server. You need to install a copy
of V2R1 software on one server and test the V2R1 software installation.

To perform a dual-server preference file migration, follow these instructions:

50 Installing IBM Network Station Manager V2R1 on Windows NT



__ 1. On your new server, make sure that you install Windows NT Server 4.0 or
Windows NT Server 4.0, Terminal Server Edition with the necessary system
requirements. You can check the requirements for your Windows NT server
in “Server requirements” on page 13.

__ 2. On your new server, map a network connection to your old server.
__ a. From your Windows NT server desktop, right-click on the Network

Neighborhood icon.
__ b. Select Map Network Drive.
__ c. Enter an unused drive letter that you want to assign to the mapped

drive.
__ d. Enter the directory for the mapped drive (for example,

\\V1R3server\C$).
__ e. Select Ok.

Notes:

1) You may need to enter a user name and password to map a
network connection to the old server.

2) If you cannot map a network connection between your new server
and your old server, see “Migration during Installation” on
page 49 for instructions on performing a media-assisted software
update method.

__ 3. Create (or replicate) users from your old V1R3 server to your new V2R1
server. Follow these instructions:
__ a. You need to create the NSMUser and NSMAdmin groups on the new

server. Refer to “Creating Users and Groups in Windows NT” on
page 29 for instructions.

__ b. To migrate from a Primary Domain Controller to a Member Server of
a domain, copy the users from your old server to your new server.
Copy the users from the old NSMUser and NSMAdmin groups on
your old server to the new NSMUser and NSMAdmin groups on
your new server.
You may also add global groups from the Primary Domain Controller
to the NSMUser and NSMAdmin groups on your new server.

__ c. If you are migrating to a Stand-Alone server, you need to manually
create all of your users on the new server. You must then add them to
the NSMUser and NSMAdmin groups as appropriate. Refer to
“Adding Users and Groups in Windows NT” on page 30 for
instructions.

__ 4. Install the IBM Network Station Manager by following the instructions in
Step “Running the installation” on page 15.

__ 5. On the Migration Location window of the IBM Network Station Manager
Setup program, click Yes to confirm that you are migrating.

__ 6. On the same window, Setup prompts you to select the location of the V1R3
preference files. Enter the disk drive letter and the subdirectory where Setup
can access the preference files. This path is [drive:]\nstation\. Make sure
that the directory of your old user preference files appears correctly in the
source directory box. Click Next to continue with the installation.

__ 7. Installation completes and migrates your V1R3 preference files to V2R1. You
should move your existing Network Stations to your new IBM Network
Station Manager V2R1 software. Refer to “Client Migration” on page 54.
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Manual Migration
You run manual migration from the Windows NT command prompt. The
migration utility enables you to copy V1R3 configurations and users to the V2R1
environment. The V1R3 operating environment remains unchanged. Because V2R1
can coexist with V1R3, you may or may not remove the previous product prior to
the installation of V2R1. You can uninstall the V1R3 environment after the
migration utility migrates the configuration information and user information.
After you uninstall the V1R3 environment and delete the V1R3 preference files,
you can no longer run the migration utility, nor perform preference file migration.

The Migration Utility
The migration utility has the following requirements and features:
v Your V2R1 server must have access to where your V1R3 preference files are.
v If you have Network Stations which you plan to support with V1R3, then you

need to apply Service Update 8 to your V1R3 release. The migration utility does
not support migration from a release earlier than V1R3.

v You can only run the migration utility from a server that has V2R1 installed.
v Only users with administrator authority (members of the NSMAdmin group)

can run the V2R1 migration utility.
v The migration utility does not include an option to delete V1R3. You can

manually uninstall the V1R3 environment after the migration utility migrates the
configuration information and user preference files to V2R1.

Note: If you are supporting any Series 100 (8361-100 and 8361-200) Network
Stations or Series 300 (twin-axial 8361-341) Network Stations, you must
install V1R3 Service Update 8. You need V1R3 Service Update 8 to operate
and maintain these Network Stations. You can still operate other Network
Stations in V2R1. Refer to “Coexistence” on page 48 for more information
on how you can still operate other Network Stations in V2R1 while
maintaining V1R3-supported Network Stations.

v After you manually uninstall the V1R3 environment and delete the V1R3
preference files, you no longer need to run the migration utility.

v Although you can run the migration utility several times, even over the same
users, groups, or Network Stations, you should migrate preference files only
once. Each time the migration utility runs, it writes over any existing V2R1
preference files.

v The migration utility can perform client migration for Series 300 (8361-110 and
8361-210) and Series 1000 (8362-all models) Network Stations. However, you
have to manually configure DHCP and NVRAM for each Network Station. Refer
to “Client Migration” on page 54 for instructions.

The migration utility is in [drive:]\{float}\NetworkStationV2\servbase\bin. You
can run the migration utility from the Windows NT command prompt by using the
following command structure:

nsmv2migr {parameter1 <attribute1>...<attribute#>}...{parameter# <attribute1>...<attribute#>}

Table 11 on page 53 explains the different parameters for running the migration
utility.
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Table 11. Migration Utility Command Parameters

Parameter Description and Format

-A Complete migration for all users, all groups, all terminals, and system
preferences. This parameter does not migrate the Network Station clients.
The command structure is nsmv2migr -A.

-S Migrates system preference levels from V1R3 to V2R1. The command
structure is nsmv2migr -S.

-U Migrates user preference files. To migrate user preference files, the command
structure is nsmv2migr -U username1 <username2 . . . username#>. To
migrate all user preference files, the command structure is nsmv2migr -U
*ALL.

-G Migrates group preference files. To migrate group preference files, the
command structure is nsmv2migr -G groupname1 <groupname2 . . .
groupname#> To migrate all group preference files, the command structure is
nsmv2migr -G *ALL.

-T Migrates Network Station preference files. To migrate Network Station
preference files, the command structure is nsmv2migr -T NSname1 <NSname2 .
. . NSname#>. To migrate all Network Stations, the command structure is
nsmv2migr -T *ALL.

-P Specifies the directory path from which you can migrate. You specify the
root directory path for the old V1R3 preference files. This flag can specify a
directory path from the same server (single-server migration), or another
server (dual-server migration) that is connected via a LAN to your server.
When you do not specify a directory path, the migration utility looks for the
preference files in your current server. To migrate preference files from
another server, the command structure is nsmv2migr -P <drive:\nstation>.
Note: If you plan to run a dual-server migration by using this parameter,
make sure that you created your V1R3 user information on your new V2R1
server. Otherwise, the dual-server migration will not migrate your V1R3
preference files. Refer to “Dual-Server Migration” on page 50 and follow
Steps 1 to 3.

-C Client migration for all Series 1000 (8362 - all models) and Series 300
(8361-110 and 8362-210). Since this flag forces all of your Series 1000 (8362 -
all models) and Series 300 (8361-110 and 8362-210) Network Stations to start
from the V2R1 software, you should use this option with caution. To migrate
your Network Stations to V2R1, the command structure is nsmv2migr -C.
Refer to “Client Migration” on page 54 for testing instructions.

Notes:

1. This parameter only applies to NVRAM Network Station clients. You can
only use this option in a single-server migration, where V1R3 and V2R1
are both installed on the same server.

2. Running the migration utility with this parameter does not affect Series
100 Network Stations and Series 300 Twin-Axial Network Stations
(8361-341 machine-type) on your network.

The following are examples of how to run the migration utility with the different
parameters:

Example 1: dual-server migration of preference files for system defaults, two users, one
group and a Network Station

nsmv2migr -P j:\nstation -S -U John Jane -G NSMAdmin -T NSAlpha
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This migration utility command migrates system preferences, user preference files
of John and Jane, group preference files of the NSMAdmin group, and Network
Station preference files of the NSAlpha Network Station from another computer.
The server that is running the migration utility has a mapped network connection
to the [drive]:\nstation directory of the other computer via a LAN for the old
preference files. This directory appears as network drive and directory,
j:\nstation, on the current server.

Example 2: single-server migration of preference files for system defaults, all users, and two
Network Stations

nsmv2migr -S -U *ALL -T NSDelta NSBeta
This migration utility command migrates system preferences, preference files for
all users, and Network Station preference files for Network Stations NSDelta and
NSBeta. V1R3 is installed on the same server where you are running migration.

Example 3: single-server migration of preference files for system defaults and two groups
nsmv2migr -S -G artdept newsdept
This migration utility command migrates system preferences and preference files
of the artdept and newsdept groups. V1R3 is installed on the same server where
you are running migration.

Example 4: single-server migration of all Network Station NVRAM clients
nsmv2migr -C
This migration utility command migrates all NVRAM Network Station clients,
except Series 100 (all models) and Series 300 Twin Axial (8361-341). V1R3 is
installed on the same server where you are running migration.

Client Migration
You run client migration when you have Network Stations that were previously
supported in V1R3 but you now plan to operate using V2R1. These are Series 1000
(8362 - all models) Network Stations and Series 300 (8361-110 and 8362-210)
Network Stations.

You run client migration after you complete preference file migration. It is
advisable that you run client migration only once.

Client Migration for DHCP clients
To move your existing DHCP Network Station clients7 to your new IBM Network
Station Manager V2R1 software, follow these instructions:
__ 1. Install and configure DHCP as instructed in “Configuring DHCP for your

network” on page 32.
__ 2. In your current DHCP configuration, set the following DHCP options so

that the following values apply to all of your Network Stations:
v Option 66: IP address of the boot server
v Option 67: /NetworkStationV2/prodbase/ppc/[your kernel filename]

Refer to Table 7 on page 34 for the correct kernel filename.
__ 3. Configure DHCP option 211 as a global parameter with the value ″nfs″ or

″tftp″.

7. If you support Series 100 Network Stations or Series 300 Twin-Axial Network Stations, you must continue to support these
Network Stations in V1R3. If you start these Network Stations through DHCP, you must configure a separate class for these
DHCP Network Station clients. Refer to “Creating a Class for your thin clients” on page 36 for instructions. Specify V1R3 values
when you configure DHCP options for this class so they can continue to operate using V1R3.
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Notes:

a. If you select ″tftp″ as your boot protocol, the kernel downloads via the
TFTP protocol. The Network Station then switches to the NFS protocol
for all other data transfers.

b. Option 211 does not exist on the Microsoft DHCP interface. To create a
new DHCP option while using Microsoft DHCP, refer to “Installing
Microsoft DHCP” on page 14.

__ 4. Restart one Series 1000 (8362 - all models) or Series 300 (8361-110 and
8362-210) Network Station as a test client. The server automatically updates
the boot PROM of the Network Station and the test client restarts
automatically.

Note: Do not touch the Network Station while the Network Station boot
PROM updates. If you interrupt the boot PROM update, you have to
replace the Network Station.

__ 5. If the test client has a token-ring adapter, it updates again and restarts
automatically.

__ 6. Restart the test client to check the DHCP configuration.
__ 7. If everything appears correctly on your test client, restart8 all of the

remaining Network Stations that you plan to move over to the new V2R1
server.

__ 8. Test your Network Stations to see if the user profile information is correct.

Client Migration for NVRAM clients
To move your existing NVRAM Network Station clients to your new IBM Network
Station Manager V2R1 software, follow these instructions:
__ 1. Test one Series 300 (8361-110 or 8361-210) Network Station or Series 1000

(8362-A22, 8362-A23, 8362-A52, or 8362-A53) Network Station.
__ a. Power on the Network Station.
__ b. Wait for the message ″NS0500 Searching for Host System″ to appear on

the screen. Press the Esc key to bring up the IBM Network Station
Setup Utility main screen.
If password control is active, you must enter the case-sensitive
Administrator password.

__ c. From the Setup Utility main screen, press F3, Set Network Parameters.
__ 1) Enter the IP address of your new boot server in the First Boot

Host IP Address field.
If you did not change your boot server, or if you did not
perform a dual server preference file migration, the IP address
value here remains the same.

__ 2) Press Enter to save your changes.
__ d. From the Setup Utility main screen, press F4, Set Boot Parameters.

__ 1) Enter /NetworkStationV2/prodbase/ppc/ in the Boot
Directory field.

__ 2) Enter the correct kernel filename in the Boot File field. Refer to
Table 7 on page 34 for the correct filename for your test
Network Station.

8. If you have several Network Stations that you need to restart, you can restart these clients remotely by using a special command.
Refer to the IBM Network Station Manager Advanced Information publication for more information.
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__ 3) Press Enter to save your changes.
__ e. From the Setup Utility main screen, press F5, Set Configuration

Parameters.
__ 1) Enter /NetworkStationV2/userbase/profiles in the First

Configuration Directory field.
__ 2) Press Enter to save your changes.

__ f. From the Setup Utility main screen, press Enter to restart your test
Network Station.

__ g. Your new V2R1 server automatically updates the boot PROM of your
Network Station when your test Network Station client restarts.

Note: Do not touch the Network Station during the boot PROM
update. If you interrupt the boot PROM update, you have to
replace the Network Station.

__ h. Restart the test Network Station client.
__ i. Test your Network Station to see if the preference information is

correct.
__ j. If everything appears correctly on your test Network Station, go to

Step 2.
__ 2. From a Windows NT command prompt, run the migration utility by using

the client migration parameter9 (nsmv2migr -C). Refer to Table 11 on page 53
for the command structure.

__ 3. Restart the test client without making any changes to the Network Station.
The Network Station starts from the new IBM Network Station Manager
V2R1 software. The server may also automatically update the Network
Station boot PROM so that the Network Station restarts automatically.

Note: Do not touch the Network Station during the boot PROM update. If
you interrupt the boot PROM update, you have to replace the
Network Station.

__ 4. If your Network Station has a token-ring adapter, it updates again and
restarts automatically.

__ 5. Each time you restart the test Network Station it starts from the new IBM
Network Station Manager software. Test the user preference files on the test
client. If everything appears correctly, repeat the instructions from step 3 for
all of the clients that you want to migrate.

__ 6. Once you migrate all of the clients so that they start from the new server,
test your Network Stations to see if the preferences are correct.

9. You can only use this option in a single-server migration, where V1R3 is still installed on your server. Running the migration
utility with this parameter does not affect Series 100 Network Stations and Series 300 Twin-Axial Network Stations (8361-341
machine-type) on your network.
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Notices

This information was developed for products and services offered in the U.S.A.
IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
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programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
Software Interoperability Coordinator
3605 Highway 52 N
Rochester, MN 55901-7829
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurement may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrates programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM for the purposes of developing, using, marketing, or distributing application
programs conforming to IBM’s application programming interfaces.
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Trademarks
The following terms are trademarks of International Business Machines
Corporation in the United States, or other countries, or both:

AIX® MVS™

Application System/400® NetView
AS/400 NetVista
Client Access Network Station
DB2® On-Demand Server
eNetwork OpenEdition®

IBM Operating System/400®

IBM Network Station OS/390®

IBM NetVista OS/400®

InfoColor RS/6000
Information Assistant S/390®

InfoPrint System/390®

IPDS™ VM/ESA®

Micro Channel® 400®

Lotus® is a trademark of Lotus Development Corporation in the United States and
other countries.

Tivoli® is a trademark of Tivoli Systems Inc. in the United States and other
countries.

Microsoft, Windows, Windows NT, Windows 2000, and the Windows logo are
trademarks of Microsoft Corporation in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

UNIX® is a registered trademark in the United States and other countries licensed
exclusively through The Open Group.

Other company, product, and service names may be trademarks or service marks
of others.
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