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IBM Datacenter Solution xSeries 440 Upgrade Instructions

This document is intended for upgrading an existing Microsoft® Windows® 2000 Datacenter Server
installation on an IBM®

ERserver

™ xSeries™ 440 server to Microsoft Windows Server 2003 Datacenter
Edition. This document is also available in HTML format as a README.HTM file on the IBM Datacenter
Device Drivers CD that comes with this upgrade package.

Attention: Please read this document completely before beginning the upgrade process, and make sure
that you complete the steps in the order that they appear within this document. Also, do not leave your
server unattended during the upgrade process.

What you will need
You must have the following software and hardware available during the upgrade process:
v One licensed copy of the Microsoft Windows Server 2003 Datacenter Edition operating system (the IBM

Datacenter Upgrade CD provided with this upgrade package)
v The IBM Datacenter Device Drivers CD provided with this upgrade package
v IBM ServeRAID™ Setup CD version 6.0.3.1
v Blank diskettes to create driver diskettes for the following:

– IBM custom HAL for the xSeries 440 server
– IBM FAStT FC2-133 Host Bus Adapter firmware update

Important: You must create these diskettes before you begin the upgrade procedure.

Once you have everything you need, you will complete the following procedures during the upgrade
process:
1. “Creating HAL and other diskettes from the CD” on page 2
2. “Removing and disconnecting devices before upgrading” on page 3
3. “Upgrading the operating system” on page 4
4. “Installing and updating device drivers and firmware” on page 5
5. “Completing the upgrade” on page 12



Creating HAL and other diskettes from the CD
Complete the following steps to create the required HAL and other diskettes before you begin the
upgrade process.
1. From any server with a Microsoft Windows operating system installed, insert the IBM Datacenter

Device Drivers CD that comes with this upgrade package into the CD-ROM drive.
2. Create the HAL diskette:

a. Insert one of the blank diskettes into the server diskette drive.
b. Copy the contents of the HAL\ directory on the IBM Datacenter Device Drivers CD to the diskette.
c. Remove the diskette when done; then, label the diskette.

3. Create the FAStT FC2-133 Host Bus Adapter device driver diskettes:
a. Insert one of the blank diskettes into the server diskette drive.
b. In the HBA\QL2300\BIOS\ directory on the IBM Datacenter Device Drivers CD, run the 74P4831.EXE

program.
c. Follow the on-screen instructions to create the diskette.
d. Remove the diskette when done; then, label the diskette.

4. Continue with “Removing and disconnecting devices before upgrading” on page 3 to prepare your
xSeries 440 for the operating system upgrade.
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Removing and disconnecting devices before upgrading
Before you continue the upgrade process, complete the following steps to prepare your xSeries 440 server
for the upgrade.

Attention: If you have an existing IBM TotalStorage™ FAStT storage subsystem as part of your current
installation, you can only perform this upgrade under the following conditions:
v The storage subsystem is not the startup device.
v The Fibre Channel controllers are running firmware version 04.00.00.00 or higher.
1. Update the ServeRAID 4-MX firmware:

a. Turn on the server according to the documentation that comes with the server; then, insert the
IBM ServeRAID Setup CD into the CD-ROM drive. The ServeRAID configuration program will
start automatically.

b. When the window is displayed that contains the current firmware levels for the ServeRAID 4-MX
adapter, click Update to update the firmware levels.

c. Wait for the firmware update to complete; then, restart the server and remove the IBM ServeRAID
Setup CD as instructed.

2. If you have an IBM Remote Expansion Enclosure, such as an IBM RXE-100, connected to your server,
you must disconnect it at this time. Follow the instructions in the documentation that comes with
your server or expansion enclosure for disconnect instructions.

Note: After upgrading the operating system, you can reconnect the RXE-100 according to
“Connecting an RXE-100” on page 5.

3. Uninstall Windows 2000 Service Processor device drivers:
a. From the Start menu, select All Programs→Administrative Tools→Computer Management→Device

Manager.
b. Select the IBM Remote Supervisor + Serial Port + Mouse/Keyboard device (located just

underneath the Multi-Function Device icon).
c. Right-click on this device and choose Uninstall. Do not restart the server when prompted.
d. Click Start→Search→For Files or Folders... and type ibmsp*.* in the Search box; then, select My

Computer from the Look in list and click Search.
e. After the search completes, select all the found files and delete them.
f. Restart the server and login; then, click Cancel when the Windows 2000 Found New Hardware

Wizard displays.
4. Uninstall IBM TotalStorage FAStT Storage Management software:

Attention: To avoid possible data loss, you must uninstall any existing versions of this software
before upgrading the operating system. After the upgrade, you can reinstall the FAStT Storage
Management software.
a. From the Start menu, select Settings→Control Panel→Add/Remove Programs.
b. Uninstall each of the following: SMagent, SMutil, RDAC, and SMclient.

5. Continue with “Upgrading the operating system” on page 4 to begin upgrading the operating system
on your server.
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Upgrading the operating system
Before you continue the upgrade process, make sure that you have read this entire document completely,
have created the required diskettes according to “Creating HAL and other diskettes from the CD” on
page 2, and have completed the steps in “Removing and disconnecting devices before upgrading” on
page 3. Complete the following steps to upgrade the operating system on your server.
1. Turn on the server according to the documentation that comes with the server; then, wait for the

Windows 2000 Datacenter Server operating system to start.
2. Log in to the server as the Administrator.
3. Insert the IBM Datacenter Upgrade CD that comes with this Windows Server 2003 Datacenter Edition

upgrade package. When prompted, select Exit.
4. From a command prompt, type

<cd-rom>:i386\winnt32 /s:<cd-rom>:\i386 /unattend:<cd-rom>:\i386\winnt.sif

(where <cd-rom> represents the drive letter of the server CD-ROM drive) and press Enter.
5. Read and agree to the terms and conditions of the License Agreement and Product Installation Key

screens.
A Windows Server 2003 compatibility check is performed, and you will see a notification that a
custom HAL is present and that some Windows services will be stopped during the upgrade
process.

6. Click Next to continue with the upgrade, or click Cancel to return to the Windows Installation
menu.
Installation files are copied from the CD to the hard disk drive. This process could take several
minutes to complete; then, the server will automatically restart.

7. After the server restarts, the OS loader menu displays. A few seconds later the Windows Setup
screen displays and the message Starting Windows 2003 Server Setup displays. Press the F5 key on
the keyboard while this message is displayed.
Attention: Pressing the F5 key allows you to specify installation of the custom HAL from the
diskette you created earlier. You have only a few seconds to press this key combination on the
keyboard. You must specify the custom HAL during the upgrade process. Failure to do so can cause
your server operating system to behave unexpectedly. If you do not press these keys in time, you
must stop the upgrade process and begin at step 1 again.

8. When prompted, select Other as the Computer Type and press Enter.
9. Insert the HAL diskette that you created earlier into the server diskette drive; then, press Enter to

install the custom HAL.

Note: Remove the HAL diskette when this process completes, but do not remove the diskette while
the drive is still in use.

The installation file copying process will continue. You will be prompted to insert the HAL diskette
again during this process. This process could take several minutes to complete.

The server will restart and the graphical user interface (GUI) for Windows Setup will continue the
upgrade process. During this process, setup will automatically install and configure detected devices
in the server.

10. When a message displays stating that the IBM Active PCI device driver is not signed, click No to
continue. The device detection process could take several minutes to complete.

11. After the operating system installation completes, remove the IBM Datacenter Upgrade CD from the
CD-ROM drive; then, click Finish. The server will restart automatically.

12. Log in to the Windows Server 2003 Datacenter Edition operating system; then, continue with
“Installing and updating device drivers and firmware” on page 5 to continue configuring your
server.
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Note: For more information about the operating system, see the Microsoft documentation that comes
with this upgrade package and the online help for the operating system.

Installing and updating device drivers and firmware
After upgrading the operating system on your server to Windows Server 2003 Datacenter Edition, you
must update some of the device drivers. You can also connect your RXE-100 expansion enclosure, if
applicable, and other devices to your server at this time.

Continue with the following sections in order as applicable for your IBM Datacenter Solution
configuration:
1. “Connecting an RXE-100”
2. “Updating the Active PCI device driver”
3. “Updating the Advanced Systems Management device driver” on page 6
4. “Updating the 10/100 Ethernet adapter device driver” on page 6
5. “Updating the Broadcom NetXtreme Gigabit Ethernet adapter device driver” on page 6
6. “Updating the Adaptec AIC-7899 on-board SCSI device driver” on page 7
7. “Updating the FAStT FC2-133 Host Bus Adapter device driver and firmware” on page 7
8. “Installing TotalStorage FAStT Storage Manager software” on page 8
9. “Updating storage-subsystem firmware” on page 11

Connecting an RXE-100
If you have an RXE-100, complete the following steps to connect it to your server:
1. Shut down the operating system and turn off the server according to the documentation that comes

with the server and operating system.
2. If the RXE-100 is connected to power, unplug the power cord and wait at least ten seconds before you

plug it in again; then, connect the RXE-100 to your server according to the documentation that comes
with your server and the RXE-100.

3. Turn on the server. If the RXE-100 does not automatically turn on, repeat step 1 and step 2.
4. Update the device drivers for any adapters installed in the RXE-100.
5. Continue with “Updating the Active PCI device driver”.

Updating the Active PCI device driver
Complete the following steps to update the Active PCI™ device driver for your server:
1. If the server is not already on, turn on the server according to the documentation that comes with

the server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Insert the IBM Datacenter Device Drivers CD into the CD-ROM drive on the server.
4. From the ActivePCI\ directory, run the Hotp5111.EXE program.
5. Follow the on-screen instructions for installing the Active PCI device driver. Note the location where

the device drivers are installed for later in this procedure.
6. After the device driver installation completes, right-click the My Computer icon; then, select Manage

from the menu.
7. Click Device Manager. The IBM Active PCI device is detected automatically and is displayed as an

unknown device. Right-click the unknown device; then, select Properties from the menu.
8. In the Properties window, click Update Driver; then, in the Welcome to Hardware Update Wizard

select Install from a list or specific location and click Next.
9. Make sure that Search removable media (floppy, CDROM...) is not selected. Select Search for the

best driver in these locations, and check the Include this location in the search box.
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10. Enter the location where you installed the IBM Active PCI device driver in the appropriate fields and
click Next.

11. When the System found a driver for your device prompt displays, click Next to install the driver.
12. When prompted that the device driver installation has completed, click Finished. When prompted,

click Yes to restart the server.
13. Continue with “Updating the Advanced Systems Management device driver”.

Updating the Advanced Systems Management device driver
Complete the following steps to update the advanced systems management device driver on your server:

Attention: If IBM Director is already installed and running on your server, you must stop the program
before you update the device drivers.
1. If the server is not already on, turn on the server according to the documentation that comes with the

server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Insert the IBM Datacenter Device Drivers CD into the CD-ROM drive on the server.
4. IF IBM Director is installed and running, from a command prompt, type net stop twgipc and press

Enter. For detailed information about how to shut down the IBM Director program, see the
documentation that comes with IBM Director.

5. From the ASM\Driver\Win2000\ directory, run the setup.exe program.
6. Follow the on-screen instructions to complete the device driver installation.

Note: If the Hardware Wizard starts before or during this installation because the operating system
has detected the systems management hardware, close the Hardware Wizard window by
clicking the Cancel button.

7. Continue with “Updating the 10/100 Ethernet adapter device driver”.

Updating the 10/100 Ethernet adapter device driver
If you have an optional 10/100 Ethernet adapter installed, complete the following steps to update the
device driver:
1. If the server is not already on, turn on the server according to the documentation that comes with the

server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Insert the IBM Datacenter Device Drivers CD into the CD-ROM drive on the server.
4. Right-click the My Computer icon; then, select Manage from the menu.
5. Click Device Manager. Select the IBM 10/100 Ethernet Server adapter icon, located underneath the

Network Adapter icon. Right-click the device; then, select Update Driver from the menu.
6. From the Welcome to Hardware Update Wizard select Search removable media (floppy, CDROM...)

and click Next.
7. When the System found a driver for your device prompt displays, click Next to install the driver.
8. When prompted that the device driver installation has completed, click Finished.
9. Continue with “Updating the Broadcom NetXtreme Gigabit Ethernet adapter device driver”.

Updating the Broadcom NetXtreme Gigabit Ethernet adapter device
driver
Complete the following steps to update the device driver for the on-board Ethernet controller:
1. If the server is not already on, turn on the server according to the documentation that comes with the

server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
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3. Insert the IBM Datacenter Device Drivers CD into the CD-ROM drive on the server.
4. Right-click the My Computer icon; then, select Manage from the menu.
5. Click Device Manager. Select the Broadcom Gigabit Ethernet Server adapter icon, located

underneath the Network Adapter icon. Right-click the device; then, select Update Driver from the
menu.

6. From the Welcome to Hardware Update Wizard select Search removable media (floppy, CDROM...)
and click Next.

7. When the System found a driver for your device prompt displays, click Next to install the driver.
8. When prompted that the device driver installation has completed, click Finished.
9. Continue with “Updating the Adaptec AIC-7899 on-board SCSI device driver”.

Updating the Adaptec AIC-7899 on-board SCSI device driver
Complete the following steps to update the device driver for the on-board SCSI controller:
1. If the server is not already on, turn on the server according to the documentation that comes with

the server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Insert the IBM Datacenter Device Drivers CD into the CD-ROM drive on the server.
4. Right-click the My Computer icon; then, select Manage from the menu.
5. Click Device Manager. Select the Adaptec AIC-7899 SCSI adapter icon, located underneath the

SCSI and RAID Controllers icon. Right-click the device; then, select Update Driver from the menu.
6. From the Welcome to Hardware Update Wizard select Search removable media (floppy, CDROM...)

and click Next.
7. When the System found a driver for your device prompt displays, click Next to install the driver.
8. When prompted that the device driver installation has completed, click Finished.
9. Repeat steps 5 through 8 for the second on-board SCSI controller.

10. Continue with “Updating the FAStT FC2-133 Host Bus Adapter device driver and firmware”.

Updating the FAStT FC2-133 Host Bus Adapter device driver and
firmware
Complete the following steps to update the device driver for an IBM FAStT FC 133 Host Bus Adapter
installed in your server:
1. If the server is not already on, turn on the server according to the documentation that comes with

the server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Insert the IBM Datacenter Device Drivers CD into the CD-ROM drive on the server.
4. Right-click the My Computer icon; then, select Manage from the menu.
5. Click Device Manager. Select the QLogic QLA23xx Fibre Channel adapter icon, located underneath

the SCSI and RAID Controllers icon. Right-click the device; then, select Update Driver from the
menu.

6. From the Welcome to Hardware Update Wizard select Search removable media (floppy, CDROM...)
and click Next.

7. When the System found a driver for your device prompt displays, click Next to install the driver.
8. When prompted that the device driver installation has completed, click Finished.
9. Repeat step 5 through step 8 for a second FAStT FC2-133 Host Bus Adapter installed in your server.

10. Shut down the operating system and restart the server according to the documentation that comes
with the server and operating system.
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11. Insert the FAStT FC2-133 Host Bus Adapter firmware diskette that you created earlier into the
diskette drive on the server. The server will start from the diskette and wait at a RAM disk C:\
prompt.

12. From the command line, type ’flasutil /l /f /o ql2312rm.bin’ and press Enter. This will update
the BIOS and NVRAM firmware for all FAStT FC2-133 Host Bus Adapters installed in your server.

Note: For more information on this program you can type flasutil /? at the command prompt or
refer to the documentation that comes with the FAStT FC2-133 Host Bus Adapter.

13. When the program completes, remove the diskette from the diskette drive and restart the server.
14. Continue with “Installing TotalStorage FAStT Storage Manager software”.

Installing TotalStorage FAStT Storage Manager software
Before you install the TotalStorage FAStT Storage Manager software, see the documentation that comes
with your hardware for specific configuration information. A specific configuration might be required for
your hardware to support the storage management software in a clustered environment. You can only
install the software on cluster-only nodes or cluster nodes and management workstations.

Management workstations:

A management workstation is a server that you use to manage the storage subsystem. You can attach the
management workstation to the storage subsystem in the following ways:
v Through a TCP/IP Ethernet connection to the controllers in the subsystem
v Through a TCP/IP network connection to a cluster node with the host-agent software installed

You must install storage management software on a management workstation in the following order:
1. Microsoft Virtual Machine; see “Installing Microsoft Virtual Machine”
2. Storage Manager client (SMclient); see “Installing SMclient” on page 9

Cluster nodes:

The cluster nodes attach directly to the storage subsystem through a Fibre Channel I/O path.

You must install storage management software on each cluster node in the following order:
1. Microsoft Virtual Machine; see “Installing Microsoft Virtual Machine”
2. Storage Manager client (SMclient); see “Installing SMclient” on page 9
3. Remote Disk Access Control (RDAC); see “Installing RDAC” on page 9
4. Storage Manager agent (SMagent); see “Installing SMagent” on page 10
5. Storage Manager utility (SMutil); see “Installing SMutil” on page 10

Installing Microsoft Virtual Machine
Complete the following steps to install Microsoft Virtual Machine on management workstations or cluster
nodes:
1. If the server is not already on, turn on the server according to the documentation that comes with the

server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Insert the IBM Datacenter Device Drivers CD into the CD-ROM drive on the server.
4. From the FAStT.WS03\ directory, run the MSJavx86-3805.EXE program.
5. Follow the on-screen instructions to install the software.

Note: When prompted to restart the server, select No, do not restart the system at this time.
6. Continue with “Installing SMclient” on page 9.
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Installing SMclient
Complete the following steps to install the SMclient software on management workstations or cluster
nodes:
1. If the server is not already on, turn on the server according to the documentation that comes with the

server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Insert the IBM Datacenter Device Drivers CD into the CD-ROM drive on the server.
4. From the FAStT.WS03\ directory, run the SMclient-WS32-08303502.EXE program.
5. Follow the on-screen instructions to install the software. Read and accept the End User License

Agreement (EULA), when prompted.
6. Click Finish when the software installation is complete.
7. Verify that the SMclient software installed correctly:

a. Select Start→All Programs and verify that the IBM FAStT Storage Manager 8 Client is displayed
in the list of installed programs.

Note: If the program is not displayed, repeat step 3 through step 6. If the program is still not
displayed, contact your IBM support representative.

b. Select Start→All Programs→Administrative Tools→Services to display the Services window.
c. Verify that the IBM FAStT Storage Manager 8 Event Monitor is displayed with startup set to

Automatic and the status Started. If the service is not started, click Start. Contact your IBM
support representative if you have continued problems.

8. Continue with “Installing RDAC”.

Installing RDAC
RDAC contains the multipath device driver that is required for the FAStT storage controller failover
support. Make sure that you have at least 1 MB of available hard disk space on each cluster node and
that the appropriate host bus adapter is already installed. Complete the following steps to install the
RDAC software on cluster nodes:
1. If the server is not already on, turn on the server according to the documentation that comes with the

server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Insert the IBM Datacenter Device Drivers CD into the CD-ROM drive on the server.
4. From the FAStT.WS03\ directory, run the SMrdac-WS32-08303502_signed.EXE program.
5. Follow the on-screen instructions to install the software.
6. When the software installation is complete, select Yes I want to restart my computer now; then, click

Finish.
7. When the server restarts, log in to the server again as the Administrator.
8. Verify that the RDAC software installed correctly:

a. Select Start→All Programs→Accessories→System Tools→System Information to display the System
Information window.

b. Verify that the rdacbus32 is displayed in the list of device drivers and the state is Running with a
status of OK.

Note: If the device driver is not started, repeat step 3 through step 7. If the device driver is still
not started, contact your IBM support representative.

9. Continue with “Installing SMagent” on page 10.
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Installing SMagent
You must install the SMagent software if you intend to manage the storage subsystem using the
host-agent method. Before installing the SMagent software on a cluster node, ensure the following
conditions are met:
v Each cluster node has at least 1 MB of available hard disk space
v RDAC is already installed on each cluster node; see “Installing RDAC” on page 9
v Microsoft Virtual Machine is already installed; see “Installing Microsoft Virtual Machine” on page 8

Complete the following steps to install the SMagent software on cluster nodes:
1. If the server is not already on, turn on the server according to the documentation that comes with the

server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Insert the IBM Datacenter Device Drivers CD into the CD-ROM drive on the server.
4. From the FAStT.WS03\ directory, run the SMagent-WS32-08303501.EXE program.
5. Follow the on-screen instructions to install the software.
6. When the software installation is complete, click Finish.
7. Verify that the SMagent software installed correctly:

a. Select Start→All Programs→Administrative Tools→Services to display the Services window.
b. Verify that the IBM FAStT Storage Manager 8 Agent is displayed with startup set to Automatic

and the status Started. If the service is not started, click Start. Contact your IBM support
representative if you have continued problems.

Note: If the device driver is not started, repeat step 3 through step 6. If the device driver is still
not started, contact your IBM support representative.

8. Continue with “Installing SMutil”.

Installing SMutil
The SMutil software contains utilities that will register and map new logical drives to the operating
system. Complete the following steps to install the SMutil software on cluster nodes:
1. If the server is not already on, turn on the server according to the documentation that comes with the

server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Insert the IBM Datacenter Device Drivers CD into the CD-ROM drive on the server.
4. From the FAStT.WS03\ directory, run the SMutil-WS32-08303501.EXE program.
5. Follow the on-screen instructions to install the software. Read and accept the End User License

Agreement (EULA), when prompted.
6. When the software installation is complete, click Finish.
7. Browse to the <installation_directory>\IBM_FAStT\Util\ directory (where

<installation_directory> is the location you chose during installation), and verify that the following
files exist:
v hot_add.EXE

v SMdevices.BAT

v SMflashcopyassist.EXE

8. Continue with “Updating storage-subsystem firmware” on page 11.
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Updating storage-subsystem firmware
Complete the following steps to update the storage-subsystem firmware and NVSRAM:
1. If the server is not already on, turn on the server according to the documentation that comes with the

server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Insert the IBM Datacenter Device Drivers CD into the CD-ROM drive on the server.
4. Select Start→All Programs→IBM FAStT Storage Manager 8 Client to start the client software and

display the Enterprise Management window.

Note: There might be a delay of several minutes before the window displays. No indication of
progress is given during this time.

5. From the Enterprise Management window, select a storage subsystem.
6. Select Tools→Manage Device to display the Subsystem Management window.
7. Select Storage Subsystem→Download→Firmware to update the firmware. Follow the on-screen

instructions. Browse to the FAStT.WS03\Firmware\ directory on the IBM Datacenter Device Drivers CD,
when prompted.

8. Select Storage Subsystem→Download→NVSRAM to update the NVRAM. Follow the on-screen
instructions. Browse to the FAStT.WS03\NVSRAM\ directory on the IBM Datacenter Device Drivers CD,
when prompted.

9. Continue with “Completing the upgrade” on page 12.
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Completing the upgrade
To complete the upgrade process, you will need to complete the following procedures:
1. “Performing initial automatic discovery of storage subsystems”
2. “Verifying and defining the default host type” on page 13
3. “Updating the ServeRAID 4Mx adapter device driver” on page 14

For more information about these and other storage-subsystem management tasks, see the appropriate
topics in the subsystem-management online help.

Performing initial automatic discovery of storage subsystems
Complete the following steps to perform an initial automatic discovery of storage systems:
1. If the server is not already on, turn on the server according to the documentation that comes with the

server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Select Start→All Programs→IBM FAStT Storage Manager 8 Client to start the client software and

display the Enterprise Management window.

Note: There might be a delay of several minutes before the window displays. No indication of
progress is given during this time.

4. Click Yes to begin an initial automatic discovery of hosts and storage subsystems attached to the local
subnetwork.
After the discovery completes, all hosts and storage subsystems attached to the local subnetwork are
displayed.

Note: There might be a delay of up to a minute after the discovery completes before the display
refreshes.

5. Verify that each host and storage subsystem is displayed in the Enterprise Management window. If a
host or subsystem is not displayed, check the following:
v Verify hardware connections between devices. Refer to the hardware documentation as necessary.
v See the Enterprise Management online help for additional information about storage subsystem

discovery.
v If you are using the direct-management method, verify that all hosts and storage subsystems are

connected to the same subnet on the network.
v If you are using the host-agent method, ensure that the Fibre Channel connection between the host

and storage subsystems is correct.

Make sure that you complete all of the preparation steps for configuring the storage subsystems for a
directly-managed system; then, use the Add Device option to add the IP addresses of the storage
subsystem. Make sure that you add both IP addresses of the controller to prevent the partially-managed
device error message from displaying when you try to manage the storage subsystem.

Note: If you are using the host-agent management method, make sure that the SMagent is installed on
the host. Also, verify that you have a Fibre Channel connection from the storage subsystems to the
host that has the SMagent installed.

Continue with “Verifying and defining the default host type” on page 13.
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Verifying and defining the default host type
Before using the logical drives in the host, you must specify the host type. The host type determines how
the storage subsystem controllers work with each particular operating system on the hosts to which they
are connected. If all of the host computers connected to the same storage subsystem are running the same
operating system, and you do not intend to define partitioning, then you can define a default host type.

To verify the current default host type, complete the following steps:
1. If the server is not already on, turn on the server according to the documentation that comes with the

server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Select Start→All Programs→IBM FAStT Storage Manager 8 Client to start the client software and

display the Enterprise Management window.

Note: There might be a delay of several minutes before the window displays. No indication of
progress is given during this time.

4. Select Tools→Manage Device to display the Subsystem Management window.
5. Select View→Storage Subsystem profile to display the Storage Subsystem Profile window.
6. Click the Mappings folder tab; then, scroll down to NVSRAM Host Type Internal Definitions.

The host type name of the index that has the DEFAULT setting next to it is the default host type.
7. Click Close.
8. To define a default host type:

a. Click Storage subsystem→Change-Default host-type to open the Default Host-type window.
b. Select the new default host type from the list; then, click OK.

Important: To use the heterogeneous host feature, you must do the following:
v Enable storage partitioning

Note: If you disable partitioning, you must contact your IBM support representative to
obtain a key that will permit you to enable partitioning again.

v During host-port definition, you must set each host type to the appropriate operating
system so that the firmware on each controller can respond correctly to the host.

Complete the following steps to start the heterogeneous host configuration:
1. From the Subsystem Management window, click Mappings View.
2. Follow the on-screen instructions to define the heterogeneous host configuration.
3. Continue with “Updating the ServeRAID 4Mx adapter device driver” on page 14.
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Updating the ServeRAID 4Mx adapter device driver
Complete the following steps to update the IBM ServeRAID 4Mx adapter device driver for your server:
1. If the server is not already on, turn on the server according to the documentation that comes with the

server; then, wait for the Windows Server 2003 Datacenter Edition operating system to start.
2. If you are not already logged into the server, log in to the server as the Administrator.
3. Insert the IBM Datacenter Device Drivers CD into the CD-ROM drive on the server.
4. Right-click the My Computer icon; then, select Manage from the menu.
5. Click Device Manager. Select the IBM ServeRAID 4Mx adapter icon, located underneath the SCSI

and RAID Controllers icon. Right-click the device; then, select Update Driver from the menu.
6. From the Welcome to Hardware Update Wizard select Search removable media (floppy, CDROM...)

and click Next.
7. When the System found a driver for your device prompt displays, click Next to install the driver.
8. When prompted that the device driver installation has completed, click Finished.
9. Restart the server before you start using your updated configuration.
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